LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-30-2012, 11:32 AM   #1
Phorize
Member
 
Registered: Sep 2005
Location: UK
Distribution: Slackware
Posts: 218

Rep: Reputation: 26
Smile No keyboard with 3.5.4 initrd


Hi All,

I'm playing around with the testing configs in Slackware64 14 and have run into a problem with 3.5.4. My install uses 2 partitions, 1 for /boot and another luks encrypted volume with everything else on it. My initrd was built using the output of the mkinitrd command generator in /usr/share/mkinitrd as follows:

Code:
mkinitrd -c -k 3.4.11 -f ext4 -r /dev/cryptvg/root -m usbhid:ehci-hcd:xhci-hcd:mbcache:jbd2:ext4 -C /dev/sda5 -L -h /dev/cryptvg/swap -l uk -u -o /boot/initrd-generic-3.4.11.gz
My usb keyboard won't work with the resulting initrd, the implication being that I can't log into my encrypted partition. The kernel itself uses the testing config with 2 changes made; the cpu is changed to core duo and later (I have an ivybridge cpu) and the latency is changed to low latency desktop.

The mkinitrd command generator produces working output for all other kernels.

Discuss....
 
Old 10-01-2012, 06:16 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,521

Rep: Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185
I would type "lsusb -t" with another kernel running to check which modules are needed by your USB keyboard, then check that theses modules are available and loaded using the 3.5.4 kernel.
 
1 members found this post helpful.
Old 10-05-2012, 06:25 PM   #3
Phorize
Member
 
Registered: Sep 2005
Location: UK
Distribution: Slackware
Posts: 218

Original Poster
Rep: Reputation: 26
Quote:
Originally Posted by Didier Spaier View Post
I would type "lsusb -t" with another kernel running to check which modules are needed by your USB keyboard, then check that theses modules are available and loaded using the 3.5.4 kernel.
lsusb -t gives this output:
Code:
/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci_hcd/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
        |__ Port 5: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 6: Dev 4, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 6: Dev 4, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci_hcd/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
i should correct the mkinitrd command used, which was:

Code:
mkinitrd -c -k 3.5.4 -f ext4 -r /dev/cryptvg/root -m usbhid:ehci-hcd:xhci-hcd:mbcache:jbd2:ext4 -C /dev/sda5 -L -h /dev/cryptvg/swap -l uk -u -o /boot/initrd-generic-3.5.4.gz
It looks fine to me. Hmm....I'm perplexed.
 
Old 10-06-2012, 01:07 AM   #4
taichi135
LQ Newbie
 
Registered: Oct 2010
Location: Vancouver, BC
Distribution: Slackware 14.1 x64
Posts: 8

Rep: Reputation: 4
Hi,

Try adding the module hid-generic. (make sure it's module compiled option of course.)

I had a similar problem with luks - fully encrypted root partition w/ Slackware x64 14.0, but with kernel 3.6.0.

It appears they (kernel devs) made a change where the generic usbhid module doesn't have "all" the drivers with it, and instead broken them up. (correct me if I'm wrong, anyone...) If you make menuconfig on the /usr/src/3.2.29 that Patrick includes and compare it in parallel with a make menuconfig on a newer kernel you will notice the Device Drivers ---> HID menu is slightly different. I'm not sure which exactly kernel version this occurs. I haven't had the chance to go digging. I haven't compiled a new kernel in a few months.

Like you, I was thrown off by this for a little while, having done many Luks setups and custom kernels in the past with prior Slackware versions.

I've already informed Eric of the issue, regarding the document and the script not picking the latest driver. He's taken note and will investigate later, as the team is on a much needed break after this latest release.

Hope that helps.
 
3 members found this post helpful.
Old 10-06-2012, 04:40 AM   #5
Phorize
Member
 
Registered: Sep 2005
Location: UK
Distribution: Slackware
Posts: 218

Original Poster
Rep: Reputation: 26
Quote:
Originally Posted by taichi135 View Post
Hi,

Try adding the module hid-generic. (make sure it's module compiled option of course.)

I had a similar problem with luks - fully encrypted root partition w/ Slackware x64 14.0, but with kernel 3.6.0.

It appears they (kernel devs) made a change where the generic usbhid module doesn't have "all" the drivers with it, and instead broken them up. (correct me if I'm wrong, anyone...) If you make menuconfig on the /usr/src/3.2.29 that Patrick includes and compare it in parallel with a make menuconfig on a newer kernel you will notice the Device Drivers ---> HID menu is slightly different. I'm not sure which exactly kernel version this occurs. I haven't had the chance to go digging. I haven't compiled a new kernel in a few months.

Like you, I was thrown off by this for a little while, having done many Luks setups and custom kernels in the past with prior Slackware versions.

I've already informed Eric of the issue, regarding the document and the script not picking the latest driver. He's taken note and will investigate later, as the team is on a much needed break after this latest release.



Hope that helps.
Sorted, thanks and well spotted!
 
Old 08-06-2013, 03:03 PM   #6
Barcoboy
LQ Newbie
 
Registered: May 2010
Distribution: Slackware
Posts: 27

Rep: Reputation: Disabled
Thumbs up Thanks taichi135!

Just wanted to add my thanks to taichi135. I experienced the same problem with a non-booting system last night... wasn't able to use my keyboard to figure out what the problem was. I booted to an emergency partition, added the hid-generic module to my initrd, and I was then able to figure out why my system wasn't booting and fix it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windowmaker: bound keyboard commands use qwerty keyboard but within apps, dvorak. daweefolk Linux - General 2 09-01-2012 06:21 PM
How to add non-US keyboard layout to initrd (cryptsetup)? malo_umoran Slackware 6 04-05-2008 09:44 AM
How to create new initrd.gz (or initrd.img) file? kkpal Programming 2 12-10-2007 09:38 AM
Failed to symbolic-link boot/initrd.img-2.6.18-4-486 to initrd.img Scotteh Linux - Software 8 06-02-2007 12:24 AM
usb keyboard and soundcard conflict (sound set to keyboard?) netsurf Linux - Hardware 2 04-09-2005 08:08 AM


All times are GMT -5. The time now is 07:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration