-   Linux - Software (
-   -   Suse Linux 9.1 Pro: boot hang on "scanning pci..." (

paulsm4 11-13-2004 01:52 AM

Suse Linux 9.1 Pro: boot hang on "scanning pci..."
Hi -

I installed Suse Linux 9.1 Professional last week, and everything seemed fine.

Today, it started hanging at boot:
scanning pci: *******.

I found some postings on suggesting I boot with this option:

That works ... except that SuSe doesn't see the NIC (an on-board Realtek 100M Ethernet; it worked just fine during install and all last week).

OK - so I go into Yast, Network Devices, [Select] the Realtek, type [Edit], click through the prompts to [Finish] ...
... and the whole system hangs (it looks like somewhere in SuSEconfig).

The behavior is the same whether I boot into "Failsafe mode" or normally.

Setting the "NOHOTPLUG=1" option makes no difference - only disabling cold plug ("NOCOLDPLUG=1") seems to help.

Any ideas why the default boot hangs in "scanning pci: ***"?

Any ideas on what I can do about it ("NOCOLDPLUG=1" lets me boot, but I lose my NIC).

Thanx in advance .. PSM

paulsm4 11-16-2004 02:54 PM

Mysteriously started working again...
Just FYI -

I booted SuSE Linux 9.1 Pro today with no problem:

1) No "coldboot ... scanning pci..." hang at boot

2) I see my NIC fine (and successfully registered a dynamic address from our DHCP server); my NIC sees my LAN (and the Internet) without any problems.

3) Nothing whatsoever to indicate what might have been wrong in any of the logs.


Had it failed again, I would have tried the following three things:

1) vi /etc/hotplug/input.rc =>
/etc/hotplug/input.agent < /dev/null # ORIGINAL (LINE 103)
/sbin/hotplug input < /dev/null > /dev/null 2>&1 & # MODIFIED

2) Tried a static (instead of dynamic) IP address

3) Scrubbed SuSE 9.1 and reinstalled from scratch

All times are GMT -5. The time now is 07:21 AM.