-   Linux - Software (
-   -   Google Earth and Ubuntu 10.04 Dell 1545n laptop (

frankbell 09-28-2010 04:02 PM

Google Earth and Ubuntu 10.04 Dell 1545n laptop
1 Attachment(s)
Google Earth runs with no problems on my Slackware box. Download the binary, chmod the executable flag, run the installation, bing, bang, boom.

I have not yet gotten it to run on my Dell 1545 Ubuntu v. 10.04 laptop (Celeron 2.16 GHz 2 GB RAM). With Google Earth v. 4, the best I could do is to get it to run once. Then it would not run again: the program would start, but would stop before the picture of the earth loaded from the Google server.

After installing Google Earth v. 5 successfully on my Slackware desktop yesterday, I tried again. Both computers are connecting through the same router; the Slackware box is wired, the Ubuntu is wireless.

After the installation routine finished, it presented me with the option to start the application immediately. I clicked "Yes" and the installation dialog window went away, then nothing happened.

I tried running it from a terminal as root and got an error that GLIBCXXX.3.4.9 was missing.

I found this link which suggested I delete or rename these two files in the installation directory (/opt/google-earth): and

I renamed them to *.old; after I did that, the program started from the command line, but crashed before loading while the startup tip window is showing (I hate startup tips with a passion). I was still under su rights ("sudo su").

This LQ post suggests disabling the startup tips, but the display did not last long enough for me to point the mouse at the checkbox, let alone click anything.

But all that was yesterday. Today it got truly weird.

Today, while I was drafting this post in Gedit (I wanted to have all the details correct), I tried sudo googleearth from the terminal and now it runs; I seem to have full functionality. The computer has not been rebooted: uptime=2 days, 17:41.

When I start it from the command line as user, though, it loads but does not load the maps.

It does not throw any errors when started by user. It just chokes.

Here's the ls on /opt/google-earth/googleearth; it is the same on both computers:


ls -l googleearth
-rwxr-xr-x 1 root root 1308 2010-09-27 17:48 googleearth

I've attached a screen shot of what happens when I try to start it as user. I don't consider this an urgent problem, because, frankly, Google Earth is a toy for me. A really nice fun toy, but still a toy.

Any thoughts?

van_Zeller 10-15-2010 07:44 AM


I've had this problem (black screen, no planet) while running ubuntu. I believe the cause of this was that you clicked "yes" immediately after the instalation finished. At this point you were root, I'm guessing. There is your problem. So instead of clicking to start the program immediately, instead exit the installer and call the program manually from your "start menu" equivalent. This worked for me.

EDIT: perhaps you will need to uninstall+reinstall.

frankbell 10-15-2010 08:55 PM

I will remove the program, reinstall it, and test out this idea sometime this weekend.


No one in my LUG had any suggestions either, and it's full of old Unix heads who really know their stuff.

frankbell 10-21-2010 12:14 PM

Before I got around to testing this, I updated to Meerkat. I don't know if that had any bearing on what happened next.

I did the following:

Removed Google Earth using /opt/goole-earth/uninstall.

Tried to reinstall it from the original downloaded file and it crashed with this error:


Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux parser error : Document is empty

^ parser error : Start tag expected, '<' not found

Couldn't load ''

Deleted the downloaded file and got a new copy from the Google mothership. No change. (Googling revealed a number of links regarding the same error, so I can take comfort in knowing its not just me.)

Found this thread on the Ubuntu forums and grabbed the deb from Medibuntu.

Installed it with Gdebi.

Result: No change in behavior: Runs with sudo, hangs before the globe appears when started by user.

Curiouser and curioser.

It works, so it's hardly a crisis, but it's inelegant to have to run a user app with sudo.

frankbell 12-06-2010 09:23 PM

I've figured this out.

I have been experimenting with rsync so as to automate backups from my laptop (my primary computer) to my file server.

rsync threw errors about the directory /home/[username]/.config/google.

That directory was owned by root.

I changed the ownership of that directory and all its files recursively to [username] and now [username] can start GoogleEarth with no problems.

Yesterday, I changed the ownership of /home/[username]/.googleearth and all its contents recursively, but that was not enough.

All times are GMT -5. The time now is 08:31 PM.