LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-26-2010, 07:44 PM   #1
dfiggy
Member
 
Registered: Aug 2010
Location: Valrico, FL
Distribution: Unbutu
Posts: 42

Rep: Reputation: 0
Question Enabling Google Earth Linux


I've looked at the other threads on the Google Earth topic, but I guess my questions boils down to this: Now that I have downloaded Google Earth Linux to my desktop (it is a .bin), how do I enable it as an application I can run?
I've seen some posts saying it works very well.

dfiggy
 
Old 09-26-2010, 08:27 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,796

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
The .bin file is not executable until you make it executable.

In a terminal, run the command
chomd +x googleearth.bin

or whatever the file name is.
 
Old 09-26-2010, 08:51 PM   #3
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,229

Rep: Reputation: 175Reputation: 175
Quote:
Originally Posted by bigrigdriver View Post
chomd +x googleearth.bin
There's a typo in chmod

chmod +x GoogleEarthLinux.bin

Last edited by jens; 09-26-2010 at 09:48 PM.
 
Old 09-26-2010, 10:30 PM   #4
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,229

Rep: Reputation: 175Reputation: 175
Quote:
Originally Posted by dfiggy View Post
I've seen some posts saying it works very well.
Their last bin files have two *huge* bugs.

1. It didn't install at all.
If you get this error:

Quote:
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 5.2.1.1588..............................................................
setup.data/setup.xml:1: parser error : Document is empty

^
setup.data/setup.xml:1: parser error : Start tag expected, '<' not found

^
Kan 'setup.data/setup.xml' niet laden
Install it like this (as root or using sudo):

./GoogleEarthLinux.bin --target /tmp/ge
(ignore the error message)
cd /tmp/ge/setup.data/bin/Linux/x86/
mv setup.gtk setup.gtk2
cd /tmp/ge
./setup.sh



2. It crashed when starting it.
The only "fix" for this is closing/disabling the "tips and tricks" window when starting it (you'll only get a second to do this, just click on the window as fast as you can).

After that, it all seems to work (Debian Sid).

Last edited by jens; 09-26-2010 at 10:46 PM.
 
1 members found this post helpful.
Old 09-27-2010, 12:47 AM   #5
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
sudo wget http://dl.google.com/earth/client/cu...EarthLinux.bin && chmod +x GoogleEarthLinux.bin && ./GoogleEarthLinux.bin

worked great for me
 
0 members found this post helpful.
Old 09-27-2010, 07:50 AM   #6
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,229

Rep: Reputation: 175Reputation: 175
Quote:
Originally Posted by prayag_pjs View Post
sudo wget http://dl.google.com/earth/client/cu...EarthLinux.bin && chmod +x GoogleEarthLinux.bin && ./GoogleEarthLinux.bin

worked great for me
The setup.gtk2 part might be fixed by your distro, but how did you get past that "tips and tricks" bug (without disabling it)?
 
Old 09-27-2010, 08:18 AM   #7
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

I am using Fedora13 and I didn't change any thing, whatever I told in above steps, worked for me!!!

Last edited by prayag_pjs; 09-27-2010 at 08:30 AM.
 
0 members found this post helpful.
Old 09-27-2010, 08:27 AM   #8
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,733
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
googleearth-package - utility to automatically build a Debian package of Google Earth

Makes a .deb package which can be removed with apt/aptitude/Synaptic, if you are using Debian, Ubuntu, Mint, etc.

$ apt-cache policy googleearth
googleearth:
Installed: 5.1.3535.3218+0.5.7-1
Candidate: 5.1.3535.3218+0.5.7-1
Version table:
*** 5.1.3535.3218+0.5.7-1 0
100 /var/lib/dpkg/status

Too bad Google doesn't make a .deb and put it on their repo like they do for Chrome and Picasa.
 
1 members found this post helpful.
Old 09-27-2010, 08:46 AM   #9
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
gtk2???

I thought Google Earth was a Qt application!?
 
Old 09-27-2010, 08:46 AM   #10
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,229

Rep: Reputation: 175Reputation: 175
Quote:
Originally Posted by prayag_pjs View Post
Hi,

I am using Fedora13 and I didn't change any thing, whatever I told in above steps, worked for me!!!
Strange.
You're link points to the same buggy bin file (the latest stable) and you didn't add anything else... (ps: you shouldn't tell newbies to download the same file again for no reason).

I get the same crash in Fedora as well.
Are you using the 32bit version?

Quote:
Originally Posted by MTK358 View Post
gtk2???

I thought Google Earth was a Qt application!?
It's only needed for the installer that comes with the bin file (Loki based).

Quote:
Originally Posted by craigevil View Post
googleearth-package - utility to automatically build a Debian package of Google Earth

Makes a .deb package which can be removed with apt/aptitude/Synaptic, if you are using Debian, Ubuntu, Mint, etc.

$ apt-cache policy googleearth
googleearth:
Installed: 5.1.3535.3218+0.5.7-1
Candidate: 5.1.3535.3218+0.5.7-1
Version table:
*** 5.1.3535.3218+0.5.7-1 0
100 /var/lib/dpkg/status

Too bad Google doesn't make a .deb and put it on their repo like they do for Chrome and Picasa.
I would prefer that as well, but it's many versions behind the latest stable...

Last edited by jens; 09-27-2010 at 09:01 AM.
 
Old 09-27-2010, 09:17 AM   #11
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
Quote:
Originally Posted by jens View Post
It's only needed for the installer that comes with the bin file (Loki based).
So while Google Earth uses Qt, its installer uses GTK+?
 
Old 09-27-2010, 09:30 AM   #12
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,229

Rep: Reputation: 175Reputation: 175
Quote:
Originally Posted by MTK358 View Post
So while Google Earth uses Qt, its installer uses GTK+?
Yes (and the bug I mentioned is at least one year old and still exists in their beta version as well) ...

Last edited by jens; 09-27-2010 at 09:31 AM.
 
Old 09-27-2010, 03:21 PM   #13
dfiggy
Member
 
Registered: Aug 2010
Location: Valrico, FL
Distribution: Unbutu
Posts: 42

Original Poster
Rep: Reputation: 0
Unhappy Instructions not understood

Thanks to all for the responses. I have not been able to make any of the suggestions work. I have downloaded GoogleEarthLinux.bin to my desktop. From that point, I do not know the right way to proceed to make it a usable application. The suggestion of using chmod +x GoogleEarthLinux.bin failed as follows:
david@david:~$ chmod +x GoogleEarthLinux.bin
chmod: cannot access `GoogleEarthLinux.bin': No such file or directory
It seems that the desktop is not in the search path for this command.
If this is not how the command should have been given, I'd appreciate the corrections.

dfiggy
 
Old 09-27-2010, 03:39 PM   #14
CincinnatiKid
Member
 
Registered: Jul 2010
Distribution: Mageia-3
Posts: 399

Rep: Reputation: 33
Quote:
Originally Posted by dfiggy View Post
Thanks to all for the responses. I have not been able to make any of the suggestions work. I have downloaded GoogleEarthLinux.bin to my desktop. From that point, I do not know the right way to proceed to make it a usable application. The suggestion of using chmod +x GoogleEarthLinux.bin failed as follows:
david@david:~$ chmod +x GoogleEarthLinux.bin
chmod: cannot access `GoogleEarthLinux.bin': No such file or directory
It seems that the desktop is not in the search path for this command.
If this is not how the command should have been given, I'd appreciate the corrections.

dfiggy
You will have to change to the directory where you saved the file:

Code:
cd ~/Desktop
chmod +x GoogleEarthLinux.bin
./GoogleEarthLinux.bin
There is no search path for any command in the way that you are thinking. You generally always have to cd to the directory that contains your files, or use a full or relative path.

There is a search path for the command itself, for instance, you didn't have to type: /usr/bin/chmod, you only had to type chmod, because of the search path. I hope that makes sense.

Last edited by CincinnatiKid; 09-27-2010 at 03:45 PM.
 
Old 09-27-2010, 05:24 PM   #15
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,034

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
@ jens:
Quote:
It crashed when starting it.
The only "fix" for this is closing/disabling the "tips and tricks" window when starting it (you'll only get a second to do this, just click on the window as fast as you can).
To my surprise, this worked. I had to be fast though.... It took me a few times, to be fast enough to click Close the startup tips window, but then it worked, and I could then disable the "show tips & tricks" window at startup from within GE, once it was running.

Now GE works

I tried to find the config file to disable this, [would save very fast clicking], but failed.

Google is sometimes very stupid, but I thank you for this solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[12.2] google earth 5.0 for linux Douwe Slackware 9 02-27-2009 06:52 AM
Google Earth produces 'holes' in planet earth greengrocer Linux - Newbie 5 07-18-2006 11:57 PM
google earth for linux? bruno buys Linux - Software 11 06-14-2006 04:00 PM
Google Earth for Linux AxeZ Linux - Software 2 06-13-2006 12:46 PM
Google Earth for Linux depam Linux - Software 6 03-23-2006 10:27 AM


All times are GMT -5. The time now is 01:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration