-   Linux - Software (
-   -   emacs initial *scratch* message (

CollieJim 06-17-2012 04:10 AM

emacs initial *scratch* message
I would like to get rid of the initial message in *scratch*. It's a nuisance having to delete it.

The message appears to be in startup.el, but it is ignored. The real message is hard-coded in the binary /usr/bin/emacs-23.4.

I tried putting code in .emacs to remove the message, but that did not work. Nothing changed. I used

(set-buffer "*scratch*")
(kill-region (point) (mark))

This works as a separate function, but not in my .emacs file.

rknichols 06-17-2012 08:01 AM

In emacs, under "Options" select "Customize Emacs", then "Settings Matching Regexp...". Enter the word "scratch" as the regexp, and you'll find the setting for "Initial Scratch Message".

CollieJim 06-17-2012 10:33 AM

Thanks. I normally do not have the menu bar displayed, so that had not occurred to me.

All times are GMT -5. The time now is 11:38 PM.