LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-17-2012, 04:10 AM   #1
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 582

Rep: Reputation: 28
emacs initial *scratch* message


I would like to get rid of the initial message in *scratch*. It's a nuisance having to delete it.

The message appears to be in startup.el, but it is ignored. The real message is hard-coded in the binary /usr/bin/emacs-23.4.

I tried putting code in .emacs to remove the message, but that did not work. Nothing changed. I used
Code:
(set-buffer "*scratch*")
(mark-whole-buffer)
(kill-region (point) (mark))
This works as a separate function, but not in my .emacs file.

Last edited by CollieJim; 06-17-2012 at 05:21 AM.
 
Old 06-17-2012, 08:01 AM   #2
rknichols
Senior Member
 
Registered: Aug 2009
Distribution: CentOS
Posts: 4,579

Rep: Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097
In emacs, under "Options" select "Customize Emacs", then "Settings Matching Regexp...". Enter the word "scratch" as the regexp, and you'll find the setting for "Initial Scratch Message".
 
1 members found this post helpful.
Old 06-17-2012, 10:33 AM   #3
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 582

Original Poster
Rep: Reputation: 28
Thanks. I normally do not have the menu bar displayed, so that had not occurred to me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to open an initial consle message mehran53 Linux - Newbie 1 08-07-2008 12:43 AM
How can I post the message in emacs Gnus? ayiiq180 Linux - Software 3 10-04-2006 12:04 PM
Slack 10 and emacs warning message reddazz Slackware 2 07-10-2004 05:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration