LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   vim-tmux-putty (https://www.linuxquestions.org/questions/linux-newbie-8/vim-tmux-putty-4175481238/)

mapleking3 10-17-2013 09:32 PM

vim-tmux-putty
 
When I use putty to connect to sshd in Fedora, I run tmux and ten use vim to code. In vim, I can use scrollwheel to scroll down, but cann't use scroolwheel to scroll up.
If I use xsheel to replace putty and run vim in tmux, I can use scrollwheel to scrool down and up.
If I use putty and I do not run tmux and run vim to code, I can use scroolwheel normally.
In .vimrc, I set "mouse=a".
How to resolve it? Thx!

Ztcoracat 10-19-2013 11:10 PM

Hi:

Welcome to LQ!

This link might help. I wasn't sure if your mouse is wired or wireless-
http://forums.fedoraforum.org/showthread.php?t=279689

The gesture recognition I think is new.
http://rpmfind.net/linux/rpm2html/se...ery=easystroke

Hope that helps-;)

mapleking3 10-20-2013 07:41 PM

Thx, in Fedora Terminal, these all behaved normal. Only when I use putty for window to login in and run vim in tmux, the scroll wheel wouldn't work fine.
By the way, my mouse is wired.

Ztcoracat 10-20-2013 10:33 PM

You are Welcome-;)

SSH provides the same functionality as Putty- Didn't know that btw till today-
Could that be causing the conflict with the mouse I wonder?

Maybe another member using Fedora knows how to get around this.
Sorry I don't know more-

http://www.linuxquestions.org/questi.../putty-472002/

Have a good week!

mapleking3 10-20-2013 11:28 PM

Thanks!
I go to read the linking.

Edward Hunter 10-21-2013 09:52 PM

Hi mapleking3,
I met this issue too. I find a workaround occasionally. It's just simply to change the Putty you use to version 0.62 .

mapleking3 10-22-2013 02:21 AM

Hi Edward Hunter,
As you said, I changed the Putty from 0.63 to 0.62 and solved the problem.
Many thanks!


All times are GMT -5. The time now is 07:08 PM.