LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Slackware and Gentoo only detect 1GB out of 3.5GB of RAM (https://www.linuxquestions.org/questions/linux-newbie-8/slackware-and-gentoo-only-detect-1gb-out-of-3-5gb-of-ram-337034/)

DiscoGranny 06-25-2005 10:02 AM

Slackware and Gentoo only detect 1GB out of 3.5GB of RAM
 
Hey all,

I recently upgraded my RAM to the max I heard a 32-bit system can handle (3.5 GB), but when I installed Gento 2005.0 and ran `cat /prc/meminfo` I only see 904504 kB! Same thing with `top`. This is not good. I thought it was maybe a Gentoo thing, so I tried it with Slackware 10.1 and still the same result.

Now granted I read some problems on here that said I should use the big Mem kernel, but I was under the impression that was only if I had >4GB. What is the solution?

Thanks,
Disco

piscikeeper 06-25-2005 10:10 AM

there are kernels for up to 4gb and up to 2gb that i know of.

nixcraft 06-25-2005 10:18 AM

Have you tried to pass mem=SIZE parameter to kernel while booting?
Code:

mem=4GB
OR
Code:

mem=YOUR-SIZE

prasanta 06-25-2005 10:33 AM

I have faced a similar problem with my kernel only detecting 1 GB of RAM. I tried mem=2GB but that did not materialize. Later on I compiled a kernel which supports 2 GB and now it works fine.

-Prasanta

trickykid 06-25-2005 10:54 AM

These default kernels only support 1GB of RAM. You'll need to recompile with large memory support enabled for the rest to be seen.

btmiller 06-25-2005 01:17 PM

Just to tack on, it makes the Linux memory manager slightly less efficient to have to deal with more than about 900 MB of RAM. Since most people don't have this much RAM, most distro default kernels don't bother to turn on the bigmem option. Of course, if you actually have that much RAM, the minor inefficiency is offset by actually being able to use all your RAM.

DiscoGranny 06-25-2005 03:34 PM

Ok, I found it the kernel and turned it on and everything works. :D Thanks a bunch


All times are GMT -5. The time now is 06:58 AM.