Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 06-25-2005, 09:02 AM   #1
LQ Newbie
Registered: Jun 2004
Posts: 12

Rep: Reputation: 0
Slackware and Gentoo only detect 1GB out of 3.5GB of RAM

Hey all,

I recently upgraded my RAM to the max I heard a 32-bit system can handle (3.5 GB), but when I installed Gento 2005.0 and ran `cat /prc/meminfo` I only see 904504 kB! Same thing with `top`. This is not good. I thought it was maybe a Gentoo thing, so I tried it with Slackware 10.1 and still the same result.

Now granted I read some problems on here that said I should use the big Mem kernel, but I was under the impression that was only if I had >4GB. What is the solution?

Old 06-25-2005, 09:10 AM   #2
Registered: Jul 2003
Location: Pennsylvania USA
Distribution: SuSE
Posts: 425

Rep: Reputation: 30
there are kernels for up to 4gb and up to 2gb that i know of.
Old 06-25-2005, 09:18 AM   #3
Registered: Nov 2004
Location: BIOS
Distribution: RHEL3.0, FreeBSD 5.x, Debian 3.x, Soaris x86 v10
Posts: 379

Rep: Reputation: 30
Have you tried to pass mem=SIZE parameter to kernel while booting?
Old 06-25-2005, 09:33 AM   #4
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
I have faced a similar problem with my kernel only detecting 1 GB of RAM. I tried mem=2GB but that did not materialize. Later on I compiled a kernel which supports 2 GB and now it works fine.

Old 06-25-2005, 09:54 AM   #5
LQ Guru
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 250Reputation: 250Reputation: 250
These default kernels only support 1GB of RAM. You'll need to recompile with large memory support enabled for the rest to be seen.
Old 06-25-2005, 12:17 PM   #6
Senior Member
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Just to tack on, it makes the Linux memory manager slightly less efficient to have to deal with more than about 900 MB of RAM. Since most people don't have this much RAM, most distro default kernels don't bother to turn on the bigmem option. Of course, if you actually have that much RAM, the minor inefficiency is offset by actually being able to use all your RAM.
Old 06-25-2005, 02:34 PM   #7
LQ Newbie
Registered: Jun 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Ok, I found it the kernel and turned it on and everything works. Thanks a bunch


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel and 1.5gb of ram Hexane Mandriva 4 01-21-2005 11:10 AM
Sarge + 1GB RAM how? KaraK Debian 9 01-07-2005 08:00 PM
1gb DDR400 or 1.5gb DDR333? The Grim Reaper General 10 11-10-2004 05:52 PM
1Gb or Ram - Do I need Swap? Riddick SUSE / openSUSE 8 11-10-2004 05:44 AM
Mandrake 10 Reading 1.5GB RAM as 884MB vi0lat0r Linux - Hardware 2 03-19-2004 04:17 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:37 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration