LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   qmake command not found (https://www.linuxquestions.org/questions/linux-newbie-8/qmake-command-not-found-586415/)

lonecrow 09-21-2007 04:30 PM

qmake command not found
 
I am ./configure myth tv, and it tells me that qmake: command not found.

I have tried to apt-get install qt3, but it's already installed

This
Code:

export PATH=$PATH:/usr/lib/qt3/bin
proves to be not working as well. What should i do?

Thanks!

pljvaldez 09-21-2007 04:47 PM

What distro are you using?

lonecrow 09-21-2007 04:54 PM

It is written in my profile, pclinuxos 2007
thanks

pljvaldez 09-21-2007 05:01 PM

I was just curious because I didn't realize PC Linux OS used apt for package management.

On Debian, qmake is part of the qt3-dev-tools package. Can you do an apt-file search qmake to find out what package contains qmake on PCLOS?

lonecrow 09-21-2007 06:27 PM

apt-file search says the command doesnt exist
apt-get install qt3-dev-tools says it cannot find the package :(

pljvaldez 09-21-2007 06:38 PM

Do you have the synaptic package manager? You can try searching for qmake or qt3 and see what comes up in the way of development tools.

lonecrow 09-21-2007 07:00 PM

searching for qmake in the description doesn't give me anything... in synaptic...

Why is this so complicated? I don't get it...

lonecrow 09-21-2007 07:04 PM

you are a freaking genius :P

I typed qt3, and then looked through what it gave me. And I ound the devel tools :P

THANKS!!!!!!!!!!!!!!!!!! :D

pljvaldez 09-21-2007 07:16 PM

Quote:

Originally Posted by lonecrow (Post 2899662)
you are a freaking genius :P

Let's not get carried away... :D I actually feel pretty dumb when I try to answer some questions on an unfamiliar distro. It's one of those "Well, it's got to be there somewhere, if only it was sitting in front of me I might be able to figure it out..."

And hopefully that solves your compiling problem. There's no Mythtv 0.20.2 packages for PCLinuxOS yet?

lonecrow 09-21-2007 09:04 PM

well, i thought there was one. Actually I DID installed mythtv...until I figured out that I couldnt find it but that I had timetv on my computer... lol weird isnt it?

lonecrow 09-21-2007 10:26 PM

Can you tell me what \could be the problem, after I install everything, when I try to run mythtv, it gives me the following error:

mythtv: error while loading shared libraries: libmythtv-0.20.2.so.0: cannot open shared object file: No such file or directory

?

pljvaldez 09-21-2007 11:02 PM

looks like it's missing a symbolic link somewhere. On my debian box, that link points to the file /usr/lib/libmythtv-0.20.2.so.0.20.2.

Do the following to see what the library is named in your distribution:
Code:

cd /usr/lib
ls -l |grep libmythtv

So to recreate it, you would do:
Code:

ln -s /usr/lib/libmythtv-0.20.2.so.0.20.2 libmythtv-0.20.2.so.0
ln -s means "link symbolically" then you put the target item, then the link name.

lonecrow 09-22-2007 09:01 AM

Ok ok... I installed the missing file using synaptic (actually, I looked up every mythtv instances and installed everything) and I got it to work.

Well part of it. You see, when I click on the mythtv icon, I have a screen that fires up, that looks like a setup screen to me, and when I click on finish, that's it. The window closes, and nothing appears.

This is the command you asked me, although I don't think there is a problem now that it loads.
Code:

[matt@localhost lib]$ ls -l |grep mythtv
lrwxrwxrwx  1 root root      24 Sep 21 21:21 libmythtv-0.20.so -> libmythtv-0.20.so.0.20.0*
lrwxrwxrwx  1 root root      24 Sep 21 21:21 libmythtv-0.20.so.0 -> libmythtv-0.20.so.0.20.0*
lrwxrwxrwx  1 root root      24 Sep 21 21:21 libmythtv-0.20.so.0.20 -> libmythtv-0.20.so.0.20.0*
-rwxr-xr-x  1 root root 12744168 Jun  7 13:03 libmythtv-0.20.so.0.20.0*
drwxr-xr-x  4 root root    4096 Sep 21 22:09 mythtv/

I was wondering, I have a PVR-250 USB2, do I need to install anything before running mythtv?

Thanks mate

lonecrow 09-22-2007 09:37 AM

I ran it from the prompt, and it gives me this error:

Code:

No error type from QSqlError?  Strange...
2007-09-22 09:32:36.624 Failed to init MythContext, exiting.

I have not installed zap2it yet, could it be the problem? Or my hardware, as previously noted?

pljvaldez 09-22-2007 12:00 PM

Not sure about the hardware problem, since I have a PCI capture card.

Did you install the mysql database first?

You might start troubleshooting at the mythtv wiki and see what you can do. I'd start with the "Getting Started Guide" and run mythtv-setup, etc.

As for zap2it, it closed down the 1st of Sept. Now you use Schedules Direct. It's $15 for 6 months of service.


All times are GMT -5. The time now is 08:05 AM.