LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   qmake command not found (https://www.linuxquestions.org/questions/linux-newbie-8/qmake-command-not-found-586415/)

lonecrow 09-21-2007 03:30 PM

qmake command not found
 
I am ./configure myth tv, and it tells me that qmake: command not found.

I have tried to apt-get install qt3, but it's already installed

This
Code:

export PATH=$PATH:/usr/lib/qt3/bin
proves to be not working as well. What should i do?

Thanks!

pljvaldez 09-21-2007 03:47 PM

What distro are you using?

lonecrow 09-21-2007 03:54 PM

It is written in my profile, pclinuxos 2007
thanks

pljvaldez 09-21-2007 04:01 PM

I was just curious because I didn't realize PC Linux OS used apt for package management.

On Debian, qmake is part of the qt3-dev-tools package. Can you do an apt-file search qmake to find out what package contains qmake on PCLOS?

lonecrow 09-21-2007 05:27 PM

apt-file search says the command doesnt exist
apt-get install qt3-dev-tools says it cannot find the package :(

pljvaldez 09-21-2007 05:38 PM

Do you have the synaptic package manager? You can try searching for qmake or qt3 and see what comes up in the way of development tools.

lonecrow 09-21-2007 06:00 PM

searching for qmake in the description doesn't give me anything... in synaptic...

Why is this so complicated? I don't get it...

lonecrow 09-21-2007 06:04 PM

you are a freaking genius :P

I typed qt3, and then looked through what it gave me. And I ound the devel tools :P

THANKS!!!!!!!!!!!!!!!!!! :D

pljvaldez 09-21-2007 06:16 PM

Quote:

Originally Posted by lonecrow (Post 2899662)
you are a freaking genius :P

Let's not get carried away... :D I actually feel pretty dumb when I try to answer some questions on an unfamiliar distro. It's one of those "Well, it's got to be there somewhere, if only it was sitting in front of me I might be able to figure it out..."

And hopefully that solves your compiling problem. There's no Mythtv 0.20.2 packages for PCLinuxOS yet?

lonecrow 09-21-2007 08:04 PM

well, i thought there was one. Actually I DID installed mythtv...until I figured out that I couldnt find it but that I had timetv on my computer... lol weird isnt it?

lonecrow 09-21-2007 09:26 PM

Can you tell me what \could be the problem, after I install everything, when I try to run mythtv, it gives me the following error:

mythtv: error while loading shared libraries: libmythtv-0.20.2.so.0: cannot open shared object file: No such file or directory

?

pljvaldez 09-21-2007 10:02 PM

looks like it's missing a symbolic link somewhere. On my debian box, that link points to the file /usr/lib/libmythtv-0.20.2.so.0.20.2.

Do the following to see what the library is named in your distribution:
Code:

cd /usr/lib
ls -l |grep libmythtv

So to recreate it, you would do:
Code:

ln -s /usr/lib/libmythtv-0.20.2.so.0.20.2 libmythtv-0.20.2.so.0
ln -s means "link symbolically" then you put the target item, then the link name.

lonecrow 09-22-2007 08:01 AM

Ok ok... I installed the missing file using synaptic (actually, I looked up every mythtv instances and installed everything) and I got it to work.

Well part of it. You see, when I click on the mythtv icon, I have a screen that fires up, that looks like a setup screen to me, and when I click on finish, that's it. The window closes, and nothing appears.

This is the command you asked me, although I don't think there is a problem now that it loads.
Code:

[matt@localhost lib]$ ls -l |grep mythtv
lrwxrwxrwx  1 root root      24 Sep 21 21:21 libmythtv-0.20.so -> libmythtv-0.20.so.0.20.0*
lrwxrwxrwx  1 root root      24 Sep 21 21:21 libmythtv-0.20.so.0 -> libmythtv-0.20.so.0.20.0*
lrwxrwxrwx  1 root root      24 Sep 21 21:21 libmythtv-0.20.so.0.20 -> libmythtv-0.20.so.0.20.0*
-rwxr-xr-x  1 root root 12744168 Jun  7 13:03 libmythtv-0.20.so.0.20.0*
drwxr-xr-x  4 root root    4096 Sep 21 22:09 mythtv/

I was wondering, I have a PVR-250 USB2, do I need to install anything before running mythtv?

Thanks mate

lonecrow 09-22-2007 08:37 AM

I ran it from the prompt, and it gives me this error:

Code:

No error type from QSqlError?  Strange...
2007-09-22 09:32:36.624 Failed to init MythContext, exiting.

I have not installed zap2it yet, could it be the problem? Or my hardware, as previously noted?

pljvaldez 09-22-2007 11:00 AM

Not sure about the hardware problem, since I have a PCI capture card.

Did you install the mysql database first?

You might start troubleshooting at the mythtv wiki and see what you can do. I'd start with the "Getting Started Guide" and run mythtv-setup, etc.

As for zap2it, it closed down the 1st of Sept. Now you use Schedules Direct. It's $15 for 6 months of service.

lonecrow 10-05-2007 09:55 PM

Hey my friend, it's been a while!! I had put that aside for a while, but now I am back for more!

Ok I know my haupauge works, cause I get a "no channel video" when I type

mplayer /dev/video0

Now, When I do mysql --user=root --password=passwordSETearlier < /usr/share/doc/mythtv-0.20/database/mc.sql, it tells me that the file doesnt exist... What should I do? Im pretty lost in that mysql thing...

Thanks! ;)

lonecrow 10-06-2007 09:38 AM

bump.............

pljvaldez 10-08-2007 11:06 AM

How do you know your hauppauge works? You should get video of some sort when you run mplayer (at least I do).

As for the mysql thing, what exactly are you trying to do? Do you need to reset the mysql password?

lonecrow 10-08-2007 04:48 PM

I know it works because I have something when I type mplayer /dev/video0

What I am trying to do with mysql is the following:

Configuration
To setup mythtv’s backend, we’re going to run myth-setup (that’s the command you can run from a konsole as well). This will ‘setup’ our configuration for when we fire up the mythbackend. However, we need to give the MySQL database structure so that the data can be stored inside of it. To do this, MythTV gives you a .sql file that can be used to form the database structure.
CODE:
[root@localhost~]# su
CODE:
[root@localhost~]# mysql --user=root --password=passwordSETearlier < /usr/share/doc/mythtv-0.20/database/mc.sql
Now the structure is complete. It’s time to run the setup utility.

TAKEN FROM:

http://linux-blog.org/index.php?/arc...nd-MythTV.html

pljvaldez 10-08-2007 04:53 PM

You need to find where mythtv put that database structure file. Go poke around the /usr/share/doc/ directory. Maybe your directory is mythtv-0.20.2 or something different. Basically the end that string "</usr/share/doc/mythtv-0.20/database/mc.sql" is inputting the file mc.sql into mysql. So you probably just need to find the file mc.sql.

lonecrow 10-09-2007 09:05 PM

Ok... but here's a good one for you. How come this happens?
Code:

[root@localhost Desktop]# mysql --user=root --password=**** < /usr/share/doc/mythtv-0.20/database/mc.sql
bash:  /usr/share/doc/mythtv-0.20/database/mc.sql: No such file or directory
[root@localhost Desktop]# ls -l /usr/share/doc/mythtv-0.20/database/
total 4
-rw-r--r-- 1 root root 298 Jan 20  2006 mc.sql
[root@localhost Desktop]#

????????

pljvaldez 10-10-2007 11:01 AM

What are the contents of mc.sql (i.e. cat mc.sql)?

Also, you could try and cd to the directory, and then do
Code:

mysql --user=root --password=**** < ./mc.sql

lonecrow 10-10-2007 04:42 PM

OK!!!!

We are making progress here big time... CD to directory actually solved the problem.. stupid me, must have been a space or something. Anyways, I was able to go through the setup (it sees my USB2 decoder on /dev/v4l/video4 (something like that) and I was able to start mythfrontend. But when I click on WATCH TV, I get an error telling me the mythbackend is not started.... I previously did service mythbackend start and it said ok... What can I try now? I have only a laptop, and from what I understand, backend would be needed if I was trying to watch tv on another computer?

Thanks man:P

pljvaldez 10-10-2007 05:30 PM

Are you trying to start the frontend on the same machine as the backend? If not, I remember reading something about needing to setup mysql for network access.

Currently, I have the frontend on the backend machine, so I didn't bother setting it up for network access.

What is your setup like? Is the backend server on the laptop as well? Mythtv is like every other linux client server setup. The server always needs to run. Sometimes the client is on the same machine. Just like you could install apache on your laptop and serve web pages to firefox running on the same laptop.

lonecrow 10-10-2007 08:45 PM

Well, as I stated, my backend service is running... That is why im wondering if there is anything else I should setup in the menus... I typed

Code:

[root@localhost database]# service mythbackend start
Starting mythbackend:                                          [  OK  ]

any ideas? My setup is everything on my laptop, plain and simple.

lonecrow 10-10-2007 08:49 PM

It says:

Cannot connect to the master backend server. Is it running? Or the IP address is correct in the setup?


Do I have to change something in the IP adress setup if its on the same computer?

pljvaldez 10-11-2007 12:29 PM

Did you run mythtv-setup? If not, stop the backend and then run mythtv-setup. Make sure the ip address is localhost (127.0.0.1).

lonecrow 10-14-2007 02:41 PM

Hey pljvaldez, I found this on another forum, and I think it might be the problem.

Looks like the age-old database problem again.

What do you think the 'mythtv' mysql user's password is? Can you log in to mysql using
Code:
mysql -u mythtv -p mythconverg
??

If you can't log in using that then the mythtv mysql user's password is set to something you don't know.

Either 1. look in /etc/mythtv/mysql.txt to find out what it is or 2. change the mythtv mysql user's password to something more memorable and update all occurances of mysql.txt files to reflect the new login details.


Now, what do I have to do to change the password of mysql? Because I cannot log in using user "root" and my password? Thanks!

lonecrow 10-14-2007 03:33 PM

I'm trying my best to change the password like the following, but it always gives me a syntax error... Where am I wrong?

ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '’****’' at line 1
mysql> SET PASSWORD FOR root@localhost=PASSWORD ’****’;

pljvaldez 10-15-2007 07:40 AM

Not a Mysql server guy. But I used this link to set the passwords the way I wanted. Since I don't use PCLinuxOS, I can't tell you if that is the correct "stop" command for stopping mysql.

Also, I usually do this line after the root user password update
Code:

mysql>UPDATE user SET Password=PASSWORD('mythtv') WHERE User='mythtv';
Also, realize that this is just the mysql database password. So when you enter a password for 'root', don't use the same root password as your system root password.

lonecrow 10-15-2007 03:35 PM

Ok I changed it succesfully (actually it was only a space keystroke problem) But it still gives me the error that it cannot connect to the database. I have two options, can you tell me if that could be a possibility?

1- I did not download any channel data, as I haven't subscribed yet (Because I dont wanna pay if it's not going to work)
2- My USB PVR isnt plugged in my computer right now.

Thanks!

pljvaldez 10-15-2007 07:27 PM

It might have to do with the channel data, but I'm not sure. Schedules Direct gives you a 7 day free trial (which is actually 21 days because Myth downloads the next 14 days of data). So I would just sign up and configure it. Then if it works, you can pay (now $20 for a whole year of service).

As for the PVR being plugged in, that probably will be problem, but I don't think it's causing this particular one...


All times are GMT -5. The time now is 08:59 PM.