-   Linux - Newbie (
-   -   newborn linux user problems (

rammsteiner 03-29-2007 03:38 PM

newborn linux user problems
I have multiple problems currently with my version of linux fedora 6. I'm really new to the system, and these problems may turn out to be really simple, but i dont know how to fix them yet, so please help. I'll just list them and let you guys go from there.
1. I log in to the system and if i try to do a command such as "sudo lsmod" it asks for a password. I know the password, it just wont let me type it in. How do i fix that?
2. The system recognizes my external sound card, but when i play music it won't play through my external speakers, it plays through the laptop speakers. How do i fix that?
3. When shutting down the system hpssd always fails to shut down. Why is that and how can i fix it?
4. I can't connect to the internet. This is because i cant find my NIC in the system so i can set it up. If i type in /sbin/lspci -v it shows that it is there, but i don't know where to take it from there. Any suggestions?
Any help with any of these problems would be greatly appreciated. THANKS!

Sintu 03-29-2007 04:11 PM

1. Actually, you are able to type the password in, it just doesn't show it, for security reasons I presume.

Sorry, that's the only one I can help out with, I'm a bit of a noob myself.

jay73 03-29-2007 04:30 PM

2. Right-click the volume icon on your taskbar and open Volume Control and try the different options; Volume Control may not (and by default problably does not) show all the options; more can be accessed by clicking Preferences, right under Volume Control.

3. Hpssd refers to Hewlet-Packard printing services; if you haven't got an HP printer, it can be disabled : Desktop >Administration > Services

4. Which NIC/motherboard would that be?

rammsteiner 03-29-2007 05:31 PM

Im using a Realtek Semiconductor CO., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet Controller. And thanks for helping out.

jay73 03-29-2007 05:37 PM

Have a look here, same NIC:

rammsteiner 03-29-2007 07:10 PM

tried to follow the instructions, but when i typed in cp /home/desktop/[rammsteiner]/r1000_v1.05/usr/src it would come up with this:
[root@localhost ~]# cp/home/desktop/[rammsteiner]r1000_v1.05/usr/src
cp: missing destination file operand after `/home/desktop/[rammsteiner]/r1000_v1.05/usr/src`
try `cp --help` for more information.

I don't know what that means or what i should do from there. Any help?

Nylex 03-29-2007 08:56 PM

The first thing is, you probably should have "/home/rammsteiner/desktop" as the first part of the source path (it might even be "Desktop", rather than "desktop" as case matters), since your user account is unlikely to be called "desktop". Secondly, you need spaces between cp and the source and destination paths, e.g. "cp /home/rammsteiner/desktop/r1000_v1.05 /usr/src".

rammsteiner 03-29-2007 09:52 PM

Tried what you said Nylex, and still have the same problem. Any suggestions?

jay73 03-29-2007 11:14 PM

Hi rammsteiner,

If you take a look at what wrote I wrote in that post, you'll see you that Desktop has a capital:

cp /home/rammsteiner/Desktop/r1000_v1.05 /usr/src

Always be careful you don't miss a letter or a space: computers are incredibly stupid, you know, they just get all confused when that happens.

And for clarity's sake, let me stress that the username in question obviouslyl is not the nickname you use on this forum but the username you set for yourself during the install.

rammsteiner 03-29-2007 11:52 PM

I've done everything you guys have told me, capitalized the D for desktop, and put a space and everything. But i still get the same response from the system. Also, my username is the same for linux and this site. So, anything?

bdox 03-30-2007 12:32 AM

Use the <Tab> auto complete feature: By pressing the Tab key you can complete commands and filenames. For instance, in your case you can type: "cp <space> /ho<Tab>/ramm<Tab>/Des<Tab>/r100<Tab> <space> /usr/src " ...

more comments: as Nylex said you missed paces between cp and the source and destination paths, but also you are missing space between '/home/desktop/[rammsteiner]/r1000_v1.05'(source dir.) and '/usr/src'(destination dir!)

what about the other 3 problems, are they solved?

rammsteiner 03-30-2007 02:42 AM

Thanks bdox i didn't realize that their was another space in the command. I typed it in and it worked finally, but then the next command im suppose to type in didn't :( cd<space>/usr/src/r1000_v1.05 When i type that command in it comes up "no such file or directory." Any ideas? And yes the other 3 problems i took care of thanks for asking.

rammsteiner 03-30-2007 02:49 AM

Never mind, i got past that part. I also didn't know that a space was needed after /usr/src/. Now when i type in "make clean modules", what is it suppose to say, or do? Cause when i type it in it says "no rule to make target clean. stop."

rammsteiner 03-30-2007 04:54 PM

I don't really know if im doing this right or not, so im just gonna type in what terminal says.

[rammsteiner@localhost ~]$ su -
[root@localhost ~]# cp home/rammsteiner/Desktop/r1000_v1.05 /usr/src
cp: omitting directory `/home/rammsteiner/Desktop/r1000_v1.05`
[root@localhost ~]# cd /usr/src/r1000_v1.05
-bash: cd: /usr/src/r100v1.05: No such file or directory
[root@localhost ~]# cd/usr/src/ r1000_v1.05
[root@localhost src]# make clean modules
make: *** No rule to make target `clean`. Stop.
[root@localhost src]# make clean module
make: *** No rule to make target `clean`. Stop.
[root@localhost src]# make install
make: *** No rule to make target `install`. Stop.

If you guys could tell me what im doing wrong, it would be greatly appreciated. Also, i know it was suppose to be /home/Desktop/rammsteiner/ but it would only do something if i typed /home/rammsteiner/Desktop/. I don't know if that will affect anything.

masonm 03-30-2007 05:13 PM

/home/rammsteiner/Desktop/ would be correct as your Desktop directory is located in your home directory.

Inside any directory the command ls will show you a listing of everything in it. Make use of that as well as the <Tab> to make your life easier.

In order to issue any compile related commands you have to be inside of the directory containing the source code unless you want to type out the full path on every command.

If you type out a command that contains a path <Tab> completion will finish it for you if you type the first few characters of the directory name.

Example: cp home/ram <Tab> will fill in the rest and you'll see cp /home/rammsteiner/ type Des <Tab> after that and you'll see Desktop added to the line. Continue doing that until you have the full correct path name.

All times are GMT -5. The time now is 04:53 PM.