LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Gnome Keyring Daemon not responding (https://www.linuxquestions.org/questions/linux-newbie-8/gnome-keyring-daemon-not-responding-4175623800/)

gillsman 02-15-2018 01:38 PM

Gnome Keyring Daemon not responding
 
This problem has plagued me for some time, basically when I shutdown the computer I will get a message saying "A program is still running" Gnome Keyring Daemon Not Responding.
It only seems to happen every now & then but I have no idea why this happens.

I have searched the Internet for help, there are lots of people with the same problem but few answers. Some have said disabling auto login, rebooting & re enabling it may work, I tried this & thought it was the answer but some time time later it came back again.

I can get the computer to close by typing "shutdown now" in a terminal but I don't know if that may cause any other problems that I'm not aware of.

A permanent fix would be great if anyone has one.

Thanks

pwingert 02-16-2018 10:40 AM

gnome-keyring daemon not responding
 
I'm also having this problem and have had it since my first install on Linux mint 17.3. Totals of 3 years. I have always selected shutdown anyway and have seen no problems. The question is why this has not been fixed and what is the cause. Unfortunately I am just a regular user who is using this system because my boss gave it to me and said use it. I use a single program all day long and then shutdown. We are a small 5 person business with no IT support. If any solutions become available I would be willing to try them.

gillsman 02-16-2018 11:00 AM

I see quiet a lot of people have read the post but no one seems to have an answer which is surprising. I will continue to look for an answer & post here if I am lucky. I know there's plenty of others out there with the same problem.

pwingert 02-16-2018 02:07 PM

ho develops gnome keyring?
 
It would be nice to get hold of the development team and find out if they are even aware of this issue. Considering this has been going on for at least three year I suspect that this issue is not being bug tracked properly leaving them totally in-aware of this issue. Someone who has enough background should hunt down this issue and see if it is on the bug track list and what its priority is.

gillsman 02-16-2018 02:29 PM

I've seen more suggestions, one said if you have updated your kernel removing old kernels may help. I have no idea if this is correct but I did have a few old kernels after updating so I have removed the old ones, (I would not recommend this unless you are happy that the kernel you are using has no issues).
I've down a few shutdowns & reboots today & the issue has not shown itself, although as I said in my original post it didn't happen every time anyway so I will continue to monitor the situation & see what happens.
In the meantime it would be great if someone with superior Linux knowledge could give their views.

pwingert 02-16-2018 02:36 PM

I am running the latest kernel. My machine is an old old old IBM T61 with 4GB ram and an 80Gb HD. My boss never met a refurbished computer he wasn't willing to give to his employees. I also found out that I am actually running Linux under Virtualbox on this machine. Its been carefully hidden behind a start-up screen but discovered it when I was poking around some places I am not supposed to go.

AwesomeMachine 02-16-2018 08:14 PM

You can try to remove it
Code:

$ dpkg -r --force-depends gnome-keyring

ondoho 02-17-2018 05:07 AM

what is issuing the message?
is it on the console (white text on black background) or is it while the graphical env is still active?
what is the verbatim full message?

gillsman 02-17-2018 09:01 AM

I've not seen the issue since I removed an old kernel & I can't remember exactly what the message box looked like, if it surfaces again I will post details. Thanks.
AwsomeMachine, I'm a little worried to remove Gnome keyring as I don't really understand what it is & if I need it, I'm always loathe to do something that might end up with something worse than I had to start with. I'm not suggesting that there is anything wrong with your suggestion, rather that I don't understand it.

gillsman 02-18-2018 05:05 AM

Well, still no shutdown issues since I took the action of removing old kernels, was that the answer? I don't know but for now I'm marking this post as solved.
It seems to have worked for me, will it work for others? I can't say, it could be coincidence but in the absence of any other suggestions there's not much else I can do & I'm left wondering like pwingert are the developers aware of the issue & how come no one seems to have the definitive answer.

AwesomeMachine 02-18-2018 07:28 AM

Removing gnome-keyring will only prevent you being asked for passwords in certain programs, like email.

brvcf 03-07-2018 10:06 PM

Problem occurs 100% of the time on two Mint Cinnamon 64 bit machines after the latest round of updates (3/6/18) when shutting down or restarting from whisker menu. 'shutdown (-r) now' works without an error.

The most commonly reported 'fix' for this problem is purging old kernels. I just reinstalled 18.3 Cinnamon 64 from scratch on one and then installed all the updates. There were only 2 kernels. I removed 4.10 4.13.0-36 is the only one installed. It did not fix the problem. I did not have the problem before the last round of updates.
also
On another computer with 18.2 which has not been turned on for a while I never had the problem until I just installed all the recent updates. It is using 4.10.0-33 kernel. 4.8.0.53, 4.10.0-33, and 4.13.0-36 are installed.

I had no problem with on two 18.3 XFCE 64 bit machines. One I last used/updated Sunday 3/4 or another I just updated (including latest kernel) as of 3/8/18 0245Z.

All computers are set for autologin. I tried turning autologin off on one Cinnamon but that had no effect.

It appears there is something in the most recent batch of updates for Cinnamon that is causing this problem.

I am reporting this info at https://bugs.launchpad.net/ubuntu/+s...ng/+bug/608162. I suggest everyone else do the same, providing as much troubleshooting info as possible.

jakebob 06-15-2018 05:11 PM

Just switched from Linux Lite to Mint Cinnamon 18.3 64 bit and have the same problem on shutdown. Message reads, "A program is still running... gnome-keyring-daemon not responding." The previous post on this issue before mine was dated 03-07-18. Has anyone discovered a solution in the past three months?

Thanks in advance for any/all replies!

ondoho 06-16-2018 12:46 AM

Quote:

Originally Posted by jakebob (Post 5868102)
JThe previous post on this issue before mine was dated 03-07-18. Has anyone discovered a solution in the past three months?

look at post #10.

jakebob 06-16-2018 06:37 PM

Thanks, ondoho.

I'm still a bit of a Linux lightweight... so do I need to remove ALL old kernels or must I determine which one is problematic?


All times are GMT -5. The time now is 10:47 AM.