LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2018, 01:38 PM   #1
gillsman
Member
 
Registered: Mar 2014
Location: UK
Distribution: Mint 18.3
Posts: 192

Rep: Reputation: 35
Gnome Keyring Daemon not responding


This problem has plagued me for some time, basically when I shutdown the computer I will get a message saying "A program is still running" Gnome Keyring Daemon Not Responding.
It only seems to happen every now & then but I have no idea why this happens.

I have searched the Internet for help, there are lots of people with the same problem but few answers. Some have said disabling auto login, rebooting & re enabling it may work, I tried this & thought it was the answer but some time time later it came back again.

I can get the computer to close by typing "shutdown now" in a terminal but I don't know if that may cause any other problems that I'm not aware of.

A permanent fix would be great if anyone has one.

Thanks
 
Old 02-16-2018, 10:40 AM   #2
pwingert
LQ Newbie
 
Registered: Jul 2017
Posts: 4

Rep: Reputation: Disabled
Unhappy gnome-keyring daemon not responding

I'm also having this problem and have had it since my first install on Linux mint 17.3. Totals of 3 years. I have always selected shutdown anyway and have seen no problems. The question is why this has not been fixed and what is the cause. Unfortunately I am just a regular user who is using this system because my boss gave it to me and said use it. I use a single program all day long and then shutdown. We are a small 5 person business with no IT support. If any solutions become available I would be willing to try them.
 
Old 02-16-2018, 11:00 AM   #3
gillsman
Member
 
Registered: Mar 2014
Location: UK
Distribution: Mint 18.3
Posts: 192

Original Poster
Rep: Reputation: 35
I see quiet a lot of people have read the post but no one seems to have an answer which is surprising. I will continue to look for an answer & post here if I am lucky. I know there's plenty of others out there with the same problem.
 
Old 02-16-2018, 02:07 PM   #4
pwingert
LQ Newbie
 
Registered: Jul 2017
Posts: 4

Rep: Reputation: Disabled
ho develops gnome keyring?

It would be nice to get hold of the development team and find out if they are even aware of this issue. Considering this has been going on for at least three year I suspect that this issue is not being bug tracked properly leaving them totally in-aware of this issue. Someone who has enough background should hunt down this issue and see if it is on the bug track list and what its priority is.
 
Old 02-16-2018, 02:29 PM   #5
gillsman
Member
 
Registered: Mar 2014
Location: UK
Distribution: Mint 18.3
Posts: 192

Original Poster
Rep: Reputation: 35
I've seen more suggestions, one said if you have updated your kernel removing old kernels may help. I have no idea if this is correct but I did have a few old kernels after updating so I have removed the old ones, (I would not recommend this unless you are happy that the kernel you are using has no issues).
I've down a few shutdowns & reboots today & the issue has not shown itself, although as I said in my original post it didn't happen every time anyway so I will continue to monitor the situation & see what happens.
In the meantime it would be great if someone with superior Linux knowledge could give their views.
 
Old 02-16-2018, 02:36 PM   #6
pwingert
LQ Newbie
 
Registered: Jul 2017
Posts: 4

Rep: Reputation: Disabled
I am running the latest kernel. My machine is an old old old IBM T61 with 4GB ram and an 80Gb HD. My boss never met a refurbished computer he wasn't willing to give to his employees. I also found out that I am actually running Linux under Virtualbox on this machine. Its been carefully hidden behind a start-up screen but discovered it when I was poking around some places I am not supposed to go.
 
Old 02-16-2018, 08:14 PM   #7
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007
You can try to remove it
Code:
$ dpkg -r --force-depends gnome-keyring
 
Old 02-17-2018, 05:07 AM   #8
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,616
Blog Entries: 9

Rep: Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094
what is issuing the message?
is it on the console (white text on black background) or is it while the graphical env is still active?
what is the verbatim full message?
 
Old 02-17-2018, 09:01 AM   #9
gillsman
Member
 
Registered: Mar 2014
Location: UK
Distribution: Mint 18.3
Posts: 192

Original Poster
Rep: Reputation: 35
I've not seen the issue since I removed an old kernel & I can't remember exactly what the message box looked like, if it surfaces again I will post details. Thanks.
AwsomeMachine, I'm a little worried to remove Gnome keyring as I don't really understand what it is & if I need it, I'm always loathe to do something that might end up with something worse than I had to start with. I'm not suggesting that there is anything wrong with your suggestion, rather that I don't understand it.
 
Old 02-18-2018, 05:05 AM   #10
gillsman
Member
 
Registered: Mar 2014
Location: UK
Distribution: Mint 18.3
Posts: 192

Original Poster
Rep: Reputation: 35
Well, still no shutdown issues since I took the action of removing old kernels, was that the answer? I don't know but for now I'm marking this post as solved.
It seems to have worked for me, will it work for others? I can't say, it could be coincidence but in the absence of any other suggestions there's not much else I can do & I'm left wondering like pwingert are the developers aware of the issue & how come no one seems to have the definitive answer.
 
Old 02-18-2018, 07:28 AM   #11
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007
Removing gnome-keyring will only prevent you being asked for passwords in certain programs, like email.
 
Old 03-07-2018, 10:06 PM   #12
brvcf
LQ Newbie
 
Registered: Dec 2014
Posts: 16

Rep: Reputation: Disabled
Problem occurs 100% of the time on two Mint Cinnamon 64 bit machines after the latest round of updates (3/6/18) when shutting down or restarting from whisker menu. 'shutdown (-r) now' works without an error.

The most commonly reported 'fix' for this problem is purging old kernels. I just reinstalled 18.3 Cinnamon 64 from scratch on one and then installed all the updates. There were only 2 kernels. I removed 4.10 4.13.0-36 is the only one installed. It did not fix the problem. I did not have the problem before the last round of updates.
also
On another computer with 18.2 which has not been turned on for a while I never had the problem until I just installed all the recent updates. It is using 4.10.0-33 kernel. 4.8.0.53, 4.10.0-33, and 4.13.0-36 are installed.

I had no problem with on two 18.3 XFCE 64 bit machines. One I last used/updated Sunday 3/4 or another I just updated (including latest kernel) as of 3/8/18 0245Z.

All computers are set for autologin. I tried turning autologin off on one Cinnamon but that had no effect.

It appears there is something in the most recent batch of updates for Cinnamon that is causing this problem.

I am reporting this info at https://bugs.launchpad.net/ubuntu/+s...ng/+bug/608162. I suggest everyone else do the same, providing as much troubleshooting info as possible.
 
Old 06-15-2018, 05:11 PM   #13
jakebob
LQ Newbie
 
Registered: Jun 2018
Location: USA
Distribution: Mint and Linux Lite
Posts: 9

Rep: Reputation: Disabled
Just switched from Linux Lite to Mint Cinnamon 18.3 64 bit and have the same problem on shutdown. Message reads, "A program is still running... gnome-keyring-daemon not responding." The previous post on this issue before mine was dated 03-07-18. Has anyone discovered a solution in the past three months?

Thanks in advance for any/all replies!

Last edited by jakebob; 06-15-2018 at 05:13 PM.
 
Old 06-16-2018, 12:46 AM   #14
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,616
Blog Entries: 9

Rep: Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094
Quote:
Originally Posted by jakebob View Post
JThe previous post on this issue before mine was dated 03-07-18. Has anyone discovered a solution in the past three months?
look at post #10.
 
Old 06-16-2018, 06:37 PM   #15
jakebob
LQ Newbie
 
Registered: Jun 2018
Location: USA
Distribution: Mint and Linux Lite
Posts: 9

Rep: Reputation: Disabled
Thanks, ondoho.

I'm still a bit of a Linux lightweight... so do I need to remove ALL old kernels or must I determine which one is problematic?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
XRDP and gnome keyring constantm Linux - Software 1 04-19-2018 11:20 AM
How to disable gnome-keyring? fannymites Linux - Software 20 09-30-2016 07:09 PM
[SOLVED] Openbox - Autostart gnome-keyring-daemon message. l0p3n Linux - Desktop 1 07-06-2015 11:00 AM
gnome-keyring-daemon couldn't allocate secure memory jrdioko Linux - Software 0 09-10-2011 12:49 PM
Gnome keyring from nowhere fridgitator Linux - Newbie 2 02-19-2008 11:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration