-   Linux - Newbie (
-   -   1. wireless in ubuntu; 2. new path in bashrc; 3. running java (

johnyjj2 11-01-2009 05:37 PM

1. wireless in ubuntu; 2. new path in bashrc; 3. running java

I've got Ubuntu and I cannot use wireless network (even if it works in Windows). I've got Acer Aspire 5102. I tried to install this compat-wireless-2.6.tar.bz2 from the tutorial here (How to make Atheros AR5007EG Wireless cards work on Ubuntu 8.10 - Driver Download) but it didn't help.

The other thing (not about wireless network) was to follow this tutorial:

I tried to add those lines at the beginning of file to /etc/bash.bashrc but gedit didn't allow me to make any changes to this file. Save wasn't available, only Save As:
# Added by me to enable Apache Ant
EXPORT PATH=$PATH:/home/mainacc/tutorial/apache-ant-1.7.1/bin
EXPORT ANT_HOME=/home/mainacc/tutorial/apache-ant-1.7.1

I also tried:

mainacc@mainacc-laptop:~/tutorial/sphinx4-1.0beta3-bin/sphinx4-1.0beta3/bin$ java -mx256m -jar bin/HelloWorld.jar
The program 'java' can be found in the following packages:
* gcj-4.4-jre-headless
* openjdk-6-jre-headless
* cacao
* gij-4.3
* jamvm
* kaffe
Try: sudo apt-get install <selected package>
java: command not found
mainacc@mainacc-laptop:~/tutorial/sphinx4-1.0beta3-bin/sphinx4-1.0beta3/bin$ sudo apt-get install gcj-4.4-jre-headless
[sudo] password for mainacc:
Czytanie list pakietĂłw... Gotowe
Budowanie drzewa zaleĹĽnoĹci
Odczyt informacji o stanie... Gotowe
E: Nie udaĹo się odnaleĹşć pakietu gcj-4.4-jre-headless

In other words I have file HelloWorld.jar and I try to open it with "java -mx256m -jar bin/HelloWorld.jar" (as explained in the tutorial) but it doesn't run it. So I did what it suggested me to do, i.e. "sudo apt-get install gcj-4.4-jre-headless" but it says "Packet gcj-4.4-jre-headless cannot be found".


chrism01 11-01-2009 06:46 PM

Normally in /etc its /etc/profile (note no leading '.'), similarly for /etc/bashrc.
However, these are the global setting s for all users and you need to be root to edit. In Ubuntu it's

sudo gedit /etc/profile

I believe.

You might just want to edit your personal settings file(s)

/home/you/.bash_profile or /home/you/.bashrc

All times are GMT -5. The time now is 05:46 PM.