Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 11-01-2009, 06:37 PM   #1
LQ Newbie
Registered: Jul 2009
Posts: 21

Rep: Reputation: 0
1. wireless in ubuntu; 2. new path in bashrc; 3. running java


I've got Ubuntu and I cannot use wireless network (even if it works in Windows). I've got Acer Aspire 5102. I tried to install this compat-wireless-2.6.tar.bz2 from the tutorial here (How to make Atheros AR5007EG Wireless cards work on Ubuntu 8.10 - Driver Download) but it didn't help.

The other thing (not about wireless network) was to follow this tutorial:

I tried to add those lines at the beginning of file to /etc/bash.bashrc but gedit didn't allow me to make any changes to this file. Save wasn't available, only Save As:
# Added by me to enable Apache Ant
EXPORT PATH=$PATH:/home/mainacc/tutorial/apache-ant-1.7.1/bin
EXPORT ANT_HOME=/home/mainacc/tutorial/apache-ant-1.7.1

I also tried:

mainacc@mainacc-laptop:~/tutorial/sphinx4-1.0beta3-bin/sphinx4-1.0beta3/bin$ java -mx256m -jar bin/HelloWorld.jar
The program 'java' can be found in the following packages:
* gcj-4.4-jre-headless
* openjdk-6-jre-headless
* cacao
* gij-4.3
* jamvm
* kaffe
Try: sudo apt-get install <selected package>
java: command not found
mainacc@mainacc-laptop:~/tutorial/sphinx4-1.0beta3-bin/sphinx4-1.0beta3/bin$ sudo apt-get install gcj-4.4-jre-headless
[sudo] password for mainacc:
Czytanie list pakietĂłw... Gotowe
Budowanie drzewa zaleĹĽnoĹci
Odczyt informacji o stanie... Gotowe
E: Nie udaĹo się odnaleĹşć pakietu gcj-4.4-jre-headless

In other words I have file HelloWorld.jar and I try to open it with "java -mx256m -jar bin/HelloWorld.jar" (as explained in the tutorial) but it doesn't run it. So I did what it suggested me to do, i.e. "sudo apt-get install gcj-4.4-jre-headless" but it says "Packet gcj-4.4-jre-headless cannot be found".

Old 11-01-2009, 07:46 PM   #2
LQ Guru
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
Normally in /etc its /etc/profile (note no leading '.'), similarly for /etc/bashrc.
However, these are the global setting s for all users and you need to be root to edit. In Ubuntu it's

sudo gedit /etc/profile

I believe.

You might just want to edit your personal settings file(s)

/home/you/.bash_profile or /home/you/.bashrc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
set up java_home path in /home/user/.bashrc but use path in /usr/lib/java vitalstrike82 Slackware 4 01-14-2009 12:25 AM
Java path problems in Ubuntu 7.04 nexl Linux - Software 3 05-26-2008 03:21 PM
Ubuntu 7.10 64bit - how to set java path to/redirect java to ? Thane Ubuntu 1 03-25-2008 06:52 PM
Setting path: /etc/profile, /etc/bashrc or ~/.bashrc Swakoo Linux - General 1 08-07-2007 11:59 PM
"No Java virtual machine could be found from your PATH" - ignores bashrc shaider Linux - Software 7 10-09-2004 01:38 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:58 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration