LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Help needed disabling TCP/UDP checksum offloading in Debian (https://www.linuxquestions.org/questions/linux-networking-3/help-needed-disabling-tcp-udp-checksum-offloading-in-debian-880233/)

brokenpromises 05-12-2011 02:24 AM

Help needed disabling TCP/UDP checksum offloading in Debian
 
Hi Guys,

I'm running the latest, fully patched release of debian virtualized on VMWare ESXi.

Unfortuantely my ESXi server is a whitebox, and I'm using a NIC that's not on the ESXi 'supported hardware' list.

As a result of this, I can't get any connectivity inside of my Guest OSes until I disable TCP/UDP checksum offloading on the network adapter from within the Guest OSes. In windows, this is easily accomplished by right click > properties on the NIC inside of device manager.

How can I do it on a Debian system with no X?

TIA!

jefro 05-12-2011 09:55 PM

ethertool may help.

CodeKrash 05-13-2011 12:24 AM

you may just need an exorbitant amount of coffee :D

brokenpromises 05-14-2011 07:45 PM

Okay all fixed:

The followign two commands switched off all types of offloading.

Code:

$ ethtool --offload  eth0  rx off  tx off
$ ethtool -K eth0 gso off

Here is the output of ethtool before disabling TCO:

Code:

$ ethtool --show-offload  eth0
Offload parameters for eth0:
rx-checksumming: on
tx-checksumming: on
scatter-gather: on
tcp-segmentation-offload: on
udp-fragmentation-offload: off
generic-segmentation-offload: on
generic-receive-offload: off
large-receive-offload: off
ntuple-filters: off
receive-hashing: off

Here it is after running aforementioned commands:

Code:

$ ethtool --show-offload  eth0
Offload parameters for eth0:
rx-checksumming: off
tx-checksumming: off
scatter-gather: off
tcp-segmentation-offload: off
udp-fragmentation-offload: off
generic-segmentation-offload: off
generic-receive-offload: off
large-receive-offload: off
ntuple-filters: off
receive-hashing: off

Thanks for the help! Hope this helps someone in the future.

The error I was getting was in PuTTY, I use my server to tunnel traffic. I was getting an error stating "packet garbled on receive" or similar, and the connection would close itself. I will report back if this hasn't fixed the issue.

brokenpromises 05-15-2011 09:30 PM

Okay all good now, only thing is when I reboot the box the checksumming turns back on and ruins everything - how to make the settings stick on reboot?

jefro 05-16-2011 04:54 PM

I guess you could run a script.

http://www.cyberciti.biz/tips/howto-...permanent.html


All times are GMT -5. The time now is 01:10 AM.