LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-12-2011, 02:24 AM   #1
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 99

Rep: Reputation: 21
Exclamation Help needed disabling TCP/UDP checksum offloading in Debian


Hi Guys,

I'm running the latest, fully patched release of debian virtualized on VMWare ESXi.

Unfortuantely my ESXi server is a whitebox, and I'm using a NIC that's not on the ESXi 'supported hardware' list.

As a result of this, I can't get any connectivity inside of my Guest OSes until I disable TCP/UDP checksum offloading on the network adapter from within the Guest OSes. In windows, this is easily accomplished by right click > properties on the NIC inside of device manager.

How can I do it on a Debian system with no X?

TIA!

Last edited by brokenpromises; 05-12-2011 at 02:26 AM.
 
Old 05-12-2011, 09:55 PM   #2
jefro
Moderator
 
Registered: Mar 2008
Posts: 18,772

Rep: Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807
ethertool may help.
 
1 members found this post helpful.
Old 05-13-2011, 12:24 AM   #3
CodeKrash
LQ Newbie
 
Registered: May 2011
Posts: 21

Rep: Reputation: 1
you may just need an exorbitant amount of coffee

Last edited by CodeKrash; 05-13-2011 at 12:26 AM.
 
Old 05-14-2011, 07:45 PM   #4
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 99

Original Poster
Rep: Reputation: 21
Lightbulb

Okay all fixed:

The followign two commands switched off all types of offloading.

Code:
$ ethtool --offload  eth0  rx off  tx off
$ ethtool -K eth0 gso off
Here is the output of ethtool before disabling TCO:

Code:
$ ethtool --show-offload  eth0
Offload parameters for eth0:
rx-checksumming: on
tx-checksumming: on
scatter-gather: on
tcp-segmentation-offload: on
udp-fragmentation-offload: off
generic-segmentation-offload: on
generic-receive-offload: off
large-receive-offload: off
ntuple-filters: off
receive-hashing: off
Here it is after running aforementioned commands:

Code:
$ ethtool --show-offload  eth0
Offload parameters for eth0:
rx-checksumming: off
tx-checksumming: off
scatter-gather: off
tcp-segmentation-offload: off
udp-fragmentation-offload: off
generic-segmentation-offload: off
generic-receive-offload: off
large-receive-offload: off
ntuple-filters: off
receive-hashing: off
Thanks for the help! Hope this helps someone in the future.

The error I was getting was in PuTTY, I use my server to tunnel traffic. I was getting an error stating "packet garbled on receive" or similar, and the connection would close itself. I will report back if this hasn't fixed the issue.
 
Old 05-15-2011, 09:30 PM   #5
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 99

Original Poster
Rep: Reputation: 21
Okay all good now, only thing is when I reboot the box the checksumming turns back on and ruins everything - how to make the settings stick on reboot?
 
Old 05-16-2011, 04:54 PM   #6
jefro
Moderator
 
Registered: Mar 2008
Posts: 18,772

Rep: Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807Reputation: 2807
I guess you could run a script.

http://www.cyberciti.biz/tips/howto-...permanent.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Network Continuous Packets for TCP/UDP AsadMoeen Linux - Networking 0 04-26-2011 06:12 AM
LXer: Disabling checksum offloading at install OSOL 2009.06 PV DomU on Xen 3.4.1 Ubun LXer Syndicated Linux News 0 07-19-2009 12:20 PM
LXer: Disabling checksum offloading at install OSOL 2009.06 PV DomU on Xen 3.4.1 Ubun LXer Syndicated Linux News 0 07-19-2009 11:50 AM
UDP checksum icortazar3 Linux - Networking 1 12-19-2007 03:13 AM
UDP: Short Packets: and UDP bad checksum: entries in dmesg minutes2memories Linux - Networking 2 02-26-2006 08:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration