-   Linux - Laptop and Netbook (
-   -   ATI Mobility Radeon HD 4870 (

antitu 09-18-2010 11:01 PM

ATI Mobility Radeon HD 4870
2 Attachment(s)

Bought an Alienware M17x with the above video card (Crossfire) and having a problem with X / KDE.


Intel Core i7
8 Gig RAM
ATI Mobility Radeon HD 4870 Crossfire 1Gb
2 x 500g SATA
Slackware 13.1 64bit updated with repository patches
Custom Kernel (AGP/DRM disabled)
Using ATI's Catalyst Driver 10.9 (for now)


When restarting X / KDE the system hard locks. No mouse, keyboard or blinking cursor. The first time I fire up X, everything works good. Graphics are smooth, 3D is working, etc. I end the session, fire off startx and I get a hard lock. Have to hard power off the laptop.

What I've tried:

After leaving X / KDE I rmmod'd ATI's driver, modprobe'd it back in and tried to startx. Same thing - hard lock.

Use the previous version of ATI's driver. Same result - hard lock.

I also tried using the open source drivers. I think I configured them correctly, but I had the same issue. Hard locks when I restarted X.

I have attached the Xorg log and messages. I dev/null'd the files before restarting X to see if there is some clue but the machine locks up before anything gets written.

Any ideas, thoughts?

business_kid 09-19-2010 03:34 AM

I've been here.

Some dweeb updated things and made use of some table that only pcie has, breaking all agp cards in the process. Have a look at these threads (page 2)

and the patch

I have kernel there now on slackware-13.1 and that patch and all seems reasonable.
Have you KMS enabled? Another gotcha is that the firmware supplied by slackware is incomplete, and you need the 2 files referenced. KMS is achieved by
a. adding 'radeon.modeset=1' as a boot parameter
b. adding 'options radeon modeset=1' to /etc/modprobe.d/radeon.conf
c. Running an agp enabled kernel.
d. adding the firmware (referenced in the proronix thread) to /lib/firmware/radeon/

I'm running on the OSS driver, but I'm not a gamer

antitu 09-19-2010 04:03 PM

Do you know if those kernel options are required for the proprietary driver?

antitu 09-19-2010 07:46 PM

I disabled DPMS in xorg.conf and the issue seems to have been resolved. I can restart X without the lock ups. Don't know what is going on with it, but this system sure doesn't appreciate it.

business_kid 09-20-2010 02:56 AM

No, I don't.
I gave up on the proprietary driver after a session of kernel building in the early days of the laptop which included a series of reinstalls for the driver. One of these reinstalls hosed the system, and I was back top ground zero. The kernel stuff will apply if you are using the kernel module afaict.

All times are GMT -5. The time now is 09:28 AM.