LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-29-2010, 06:16 AM   #1
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,564

Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
Slackware-13.1 & Radeon Graphics


I have just upgraded to 13.1 here. Not exactly new to slackware, but as usual it lands 'jammy side down' and there's a few minor issues. It's not quite as simple as usual, because I retired my agp 4X nvidia card for an AGP 8X radeon 730 card. Now I'm running on OSS radeon driver and left with a few issues.
1. glxinfo says
bash-4.1$ glxinfo |grep OpenGL
IRQ's not enabled, falling back to busy waits: 2 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: Mesa DRI R600 (RV730 9495) 20090101 AGP 8x x86/MMX+/3DNow!+/SSE TCL
OpenGL version string: 2.0 Mesa 7.8.1
OpenGL shading language version string: 1.10
OpenGL extensions:

What's that interrupts problem? Is a recompile from git the way out of that? Do I need to set the card up? (new card, remember). If a recompile is in order (As I read) I'd love to know why, and what's wrong with the ioriginal.

2. If I jump to a console (Ctrl_Alt_F2) requiring a mode change down in resolution, I get there. If I jump back to X (Alt_F7) the mode seems to set correctly but X crashes. Ctrl_Alt_ backspace or delete don't help and it's a hard reset.

This new card:
01:00.0 VGA compatible controller: ATI Technologies Inc RV730 Pro AGP [Radeon HD 4600 Series] (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device 0028
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 16
Memory at b0000000 (32-bit, prefetchable) [size=256M]
I/O ports at b800 [size=256]
Memory at cfef0000 (32-bit, non-prefetchable) [size=64K]
Expansion ROM at cfec0000 [disabled] [size=128K]
Capabilities: [50] Power Management version 3
Capabilities: [58] AGP version 3.0

And the interrupot shows in /proc/interrupts
16: 0 IO-APIC-fasteoi radeon@pci:0000:01:00.0
 
Old 08-29-2010, 07:56 AM   #2
octoberblu3
Member
 
Registered: Oct 2005
Distribution: Slackware64-current
Posts: 67

Rep: Reputation: 22
If your resolution is changing, then you may not have kernel mode setting (KMS) working.

Slackware 13.1 should have all the packages necessary. Check out this thread: http://www.linuxquestions.org/questi...-works-760963/ bug ignore anything about recompiling software. There are a couple other steps needed to get KMS working.

Getting KMS working should fix both issues, as it will enable the IRQs requested in part 1, and allow you to have VTs at your monitors default resolution, working around part 2.
 
Old 08-29-2010, 10:14 AM   #3
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Rep: Reputation: 55
To use kms on 13.1/current:
Make a file named "/etc/modprobe.d/radeon.conf", which should include only one line: "options radeon modeset=1".
Then load the radeon module before X starts. Do this from "/etc/rc.d/rc.modules". Add the line "/sbin/modprobe radeon"
somewhere.
I have also added the line "blacklist radeon" to "/etc/modprobe.d/blacklist.conf". One of the threads about radeon kms said this was necessary to "keep the module from loading too early", but I don't know if it is necessary now. It certainly doesn't hurt.
Regards,
Bill
 
Old 08-29-2010, 02:09 PM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,564

Original Poster
Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
/gnashing of teeth.
15 hard resets later, we have established certain facts.

1. If I jump to a console, and return, the mode seems to set correctly because I can see the top bar of whatever was running and the bottom panel in xfce, but the rest of the screen is black and a hard reset is the only way forward.

2, If I put the modprobe.d/radeon.conf file in place, as soon as I type 'modprobe radeon' the monitor throws up it's "no signal" thing which it shows for 2-3 secs before going asleep. Ctrl_Alt_anything doesn't rescue. Switch the monitor back on and it goes straight back off in 2-3 secs. Of course, when I start X, it does the 'modprobe radeon' bit for me, with predictable results. lsmod |grep radeon throws up
radeon 650736 2
ttm 36923 1 radeon
drm_kms_helper 23751 1 radeon
drm 131234 5 radeon,ttm,drm_kms_helper
i2c_algo_bit 4355 1 radeon
i2c_core 15275 5 radeon,drm_kms_helper,drm,i2c_algo_bit,i2c_sis96x

The chipset is SiS 963/741. I'm going off to fiddle with bios stuff, put the brakes on hardware wise and see if that helps. Needless to say, any ideas welcome and any slackware maintainers get busy on some updates please!

Last edited by business_kid; 08-29-2010 at 02:11 PM.
 
Old 08-29-2010, 08:43 PM   #5
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Rep: Reputation: 55
I'm rather shooting in the dark here, but is it possible that you have not removed all of your previous driver? Here is what I get:
Quote:
$ glxinfo |grep OpenGL
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 (RS690 791F) 20090101 NO-TCL DRI2
OpenGL version string: 1.5 Mesa 7.8.1
OpenGL extensions:
I won't swear that it is incorrect, but I don't think that AMD belongs in the vendor string.
Regards,
Bill
 
Old 08-29-2010, 08:47 PM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
AMD does belong in the vendor string for his particular GPU. Well, for all R600/R700 GPUs since AMD funded development of the r600/r700 Mesa driver (and had their own personnel work on it as well).

Adam
 
Old 08-30-2010, 04:46 AM   #7
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,564

Original Poster
Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
Thanks for all the replies lads.
For the record, there _is_no_ previous driver, as I have slack-12.0 with nvidia setup, and I installed slack-13.1 on a fresh partition with no nvidia options. It is possible some of the radeonhd driver is lying about, and if that's an issue I will fix it.

I did try reducing to 4X agp and disabling fast writes, but none of it changed anything. The thread I was sent to by octoberblu3 I had a comment or two on as I was setting up my laptop which has r600 and never sorted it fully(He got kms on 2.6.32, but not 2.6.33.x). This time EVERYTHING is standard, off the slackware install disk, and crashing. Nothing is polluted, knackered or dodgy.
 
Old 08-30-2010, 06:46 AM   #8
dolphin77
Member
 
Registered: May 2009
Posts: 200

Rep: Reputation: 54
Code:
vladimir@darkstar:~$ glxinfo |grep OpenGL
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: Mesa DRI R600 (RV620 95C4) 20090101  TCL DRI2
OpenGL version string: 2.0 Mesa 7.8.1
OpenGL shading language version string: 1.10
OpenGL extensions:
I think you are missing firmware. It is not shipped with slackware. You can download it here http://people.freedesktop.org/~agd5f...e/R600_rlc.bin and http://people.freedesktop.org/~agd5f...e/R700_rlc.bin and put it in /lib/firmware/radeon

Code:
cat /etc/modprobe.d/radeon.conf 
options radeon modeset=1
and here is firmware initialization of firmware from /var/adm/messages:
Code:
Aug 29 20:35:54 darkstar kernel: [drm] Initialized drm 1.1.0 20060810
Aug 29 20:35:54 darkstar kernel: [drm] radeon kernel modesetting enabled.
Aug 29 20:35:54 darkstar kernel: radeon 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Aug 29 20:35:54 darkstar kernel: [drm] radeon: Initializing kernel modesetting.
Aug 29 20:35:54 darkstar kernel: [drm] register mmio base: 0xC8020000
Aug 29 20:35:54 darkstar kernel: [drm] register mmio size: 65536
Aug 29 20:35:54 darkstar kernel: ATOM BIOS: SonyM750
Aug 29 20:35:54 darkstar kernel: [drm] Clocks initialized !
Aug 29 20:35:54 darkstar kernel: [drm] Detected VRAM RAM=128M, BAR=128M
Aug 29 20:35:54 darkstar kernel: [drm] RAM width 64bits DDR
Aug 29 20:35:54 darkstar kernel: [TTM] Zone  kernel: Available graphics memory: 2011314 kiB.
Aug 29 20:35:54 darkstar kernel: [drm] radeon: 128M of VRAM memory ready
Aug 29 20:35:54 darkstar kernel: [drm] radeon: 512M of GTT memory ready.
Aug 29 20:35:54 darkstar kernel: [drm] radeon: using MSI.
Aug 29 20:35:54 darkstar kernel: [drm] radeon: irq initialized.
Aug 29 20:35:54 darkstar kernel: [drm] GART: num cpu pages 131072, num gpu pages 131072
Aug 29 20:35:54 darkstar kernel: [drm] Loading RV620 Microcode
Aug 29 20:35:54 darkstar kernel: platform radeon_cp.0: firmware: requesting radeon/RV620_pfp.bin
Aug 29 20:35:54 darkstar kernel: platform radeon_cp.0: firmware: requesting radeon/RV620_me.bin
Aug 29 20:35:54 darkstar kernel: platform radeon_cp.0: firmware: requesting radeon/R600_rlc.bin

Last edited by dolphin77; 08-30-2010 at 06:53 AM.
 
Old 08-30-2010, 09:59 AM   #9
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,564

Original Poster
Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
Thanks for the suggestion. I grabbed those, and dropped them into /lib/firmware/radeon, but it was already well populated with firmware. Further, the 4650 wasn't requesting those files - from /var/adm/messages
Code:
Aug 30 13:30:25 genius kernel: [drm] radeon defaulting to userspace modesetting.
Aug 30 13:30:25 genius kernel: [drm] Initialized radeon 1.32.0 20080528 for 0000:01:00.0 on minor 0
Aug 30 13:30:25 genius kernel: platform r600_cp.0: firmware: requesting radeon/RV730_pfp.bin
Aug 30 13:30:25 genius kernel: platform r600_cp.0: firmware: requesting radeon/RV730_me.bin
Aug 30 13:34:03 genius kernel: [drm] radeon defaulting to userspace modesetting.
Aug 30 13:34:03 genius kernel: [drm] Initialized radeon 1.32.0 20080528 for 0000:01:00.0 on minor 0
Aug 30 13:34:03 genius kernel: platform r600_cp.0: firmware: requesting radeon/RV730_pfp.bin
Aug 30 13:34:03 genius kernel: platform r600_cp.0: firmware: requesting radeon/RV730_me.bin
Aug 30 14:41:25 genius kernel: [drm] radeon defaulting to userspace modesetting.
Aug 30 14:41:25 genius kernel: [drm] Initialized radeon 1.32.0 20080528 for 0000:01:00.0 on minor 0
Aug 30 14:41:26 genius kernel: platform r600_cp.0: firmware: requesting radeon/RV730_pfp.bin
Aug 30 14:41:26 genius kernel: platform r600_cp.0: firmware: requesting radeon/RV730_me.bin
It has those files it's requesting. So I imagine I can eliminate firmware.
I did also get going with sshd, and checked out what was going on. It's bad. The screen going off is some total kernel Crash; I I was logged in via ssh, did the 'modprobe radeon' thing, and ssh wouldn't even echo keypresses to the console :-o.
With the modeset under X (Ctrl_Alt_fn. . . . Alt_F7) X uses 2% of memory and 99% of cpu, which, I suppose is a crash also. With ssh, however, I was able to run shutdown -h now and it eventually rebooted, so some sanity remained. Even a screensaver crashes!:-O Whatever default screensaver is set up in xfce takes me out, keyboard & mouse useless.
 
Old 08-30-2010, 10:08 AM   #10
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Have you tried disabling AGP entirely? With KMS, you would pass radeon.agpmode=-1 to the kernel.
 
Old 08-30-2010, 12:07 PM   #11
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,564

Original Poster
Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
No, I haven't tried that, but I did try grepping the kernel config for the word RADEON, and the results were illuminating.

CONFIG_DRM_RADEON=m
# CONFIG_DRM_RADEON_KMS is not set
CONFIG_FB_RADEON=m
CONFIG_FB_RADEON_I2C=y
CONFIG_FB_RADEON_BACKLIGHT=y
# CONFIG_FB_RADEON_DEBUG is not set

@%$#! them anyhow! That's the huge kernel. Also, apparently the 'rlc' firmware files are not supplied by slackware which enable modesetting. So dolphin77's post was on the ball. From this
http://www.phoronix.com/forums/showthread.php?t=25805
it would appear they are needed. I'll have to junk the standard slackware kernel and roll my own. Is there not one slackware maintainer with an ATI card?
 
Old 08-30-2010, 12:24 PM   #12
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
CONFIG_DRM_RADEON_KMS determines if KMS is enabled by default. It does not, however, prevent you from enabling it passing radeon.modeset=1 to the kernel. The firmware is required for KMS but is not included in the kernel. At some point the slackware maintainers will need to decide how they want to address that issue. Most distributions have a separate firmware package or two. Since Slackware didn't enable KMS by default (and why would they? It wasn't enabled by default in the kernel they chose because the radeon developers hadn't yet decided to enable it by default) the lack of firmware would only impact those that chose to enable KMS, in which case one would hope that they'd know what they were doing :-)

EDIT: So, in other words, barring any bugs in the driver, the default configuration of Slackware 13.1 should provide 3D acceleration on all r100 through r700 radeon GPUs via the open source driver.

Adam

Last edited by adamk75; 08-30-2010 at 01:06 PM.
 
Old 08-30-2010, 01:34 PM   #13
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,920

Rep: Reputation: Disabled
Pretty much what Adam said - the radeon kms hasn't been (and still may not be) reliable enough for us to even consider shipping with it defaulting to on, so no, we've not really tested it at all.

I've got two machines with AMD/ATI cards:
Homemade box: ATI Technologies Inc RS690 [Radeon X1200 Series]
Thinkpad T30: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
and I know that both of them work (mostly) great with a 2.6.35.4 kernel with radeon kms turned on.
Turning it on is indeed as simple as the modprobe option and then loading the module during early boot (but only *after* real / is mounted or else the firmware won't be around - in other words, don't try to include the radeon module in the initrd, and yes, I speak from experience learned the hard way).

This thread might interest you: http://www.linuxquestions.org/questi...0830-a-829336/
 
Old 08-30-2010, 01:43 PM   #14
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Rep: Reputation: 30
Not sure this will help...
but I know on my machine (w/a radeon xpress 200)
I also had to blacklist drm and then load it before radeon
(I found this info on some radeon wiki page).
I load mine from /etc/rc.d/rc4.d/S50-load-radeon.sh
so that they get loaded right before X starts.

# cat /etc/rc.d/rc4.d/S50-load-radeon.sh
#!/bin/bash
modprobe -v drm
modprobe -v radeon modeset=1 # Load radeon kernel-module with KMS support

HTH

Last edited by aocab; 08-30-2010 at 01:46 PM.
 
Old 08-31-2010, 04:28 AM   #15
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,564

Original Poster
Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
So, Everything should work on a bog standard slackware-13.1, you say.

Any thoughts on the problems in post #1? further testing has allowed me to add 2 more

1. Even allowing a screensaver to function freezes X, although If I just have move to a blank screen in X with just the background, I can dodge quickly to a console and back.

2. You guys have messed up the GB keyboard big time. Here's some of the mistranslations (should be = actually throws up)
\=<;|=>;@=";poundsign=#;euro=missing;~=|;#=\;"=@.

I'm based in Ireland, I need a euro, and it's handy to have a poundsign and a $. The xorg.conf keyboard stuff in xorg.conf is copied directly from slackware-12.0 where it produced a sane keyboard, with piles of keys on Right_Alt. Right_Alt doesn't seem to function now, and many keys are repeated.

The timing of loading modules isn't an issue here, I think, because I boot to runlevel 3. initdefault is always 3 here. Then I log in, and type startx if I want X. Modules load at that point, and modules.dep looks after the order of loading.

I chased up the link, Robbie, and saw stuff about new xorg packages, kernels, ati, nvidia, & nouveau drivers, & 64bit stuff, (which is not relevant to this box). Excellent Work. Are you suggesting I update 13.1 in favour of the newer packages? I went off the beaten track before, and it didn't go well, and proved a time thief. If someone tells me that slackware-13.1 actually doesn't work on ATI graphics (which is blindingly obvious over here), and I need to fix this and that, well then, I'll go for it. But I'm hoping for clarity from somewhere from those with some knowledge of the stuff before diving in with git and gcc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New to Slackware & having problems with graphics bpcHitMe LinuxQuestions.org Member Intro 0 09-11-2009 07:46 AM
ATI on-borad graphics & Nvidia PCI graphics together? PClOStinspace Linux - Hardware 5 04-28-2009 05:30 PM
Bad graphics: ATI raedon graphics card and slackware shady_Dev Linux - Hardware 1 05-22-2008 07:00 AM
64 BIT SuSE 9.3 Pro & ATI Radeon Xpress Graphics Conflict Be.Gurmeet.Be Suse/Novell 0 08-02-2005 10:00 AM
Slackware 9.0 & Radeon 9700 Pro - Can't install drivers Rav Slackware 16 05-22-2003 03:22 PM


All times are GMT -5. The time now is 02:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration