-   Linux - Hardware (
-   -   Suse Linux 9.3 for multihead display with my Nvidia 6600 GT AGP Dual DVI (

GreekMan978 06-22-2005 06:23 PM

Suse Linux 9.3 for multihead display with my Nvidia 6600 GT AGP Dual DVI
I am running Suse Linux 9.3 with an Nvidia 6600 GT dual DVI videocard. It appears to be using the correct video module since Yast is seeing the card. However, I am unable to configure it for multihead display because it's saying that I don't have two videocards. I've heard that there is a method of doing this with an option called twinview in the /etc/X11/xorg.conf . Can anybody assist me with this?


Pcghost 06-23-2005 12:49 PM

When you launch Sax2, or in the YaST Sax2 section, you need to add another graphics card. Call it head 2 or what ever and use the drop down box for hardware address, the address should be something like 1:0:0. SuSe correctly only sees one graphics card, but unless there are two entries in Sax2 for the card, it won't know there are two available heads.

I used twinview for a while, it was a pain. I prefer xinerama.

joe0532 07-05-2005 05:24 PM

I too ran into this problem in SUSE 9.3 with an nvidia 5600 ultra. Different error. In fact; it put the system in a tty mode and when I use telinit 3, startx; it tells me that an overlay delay has been specified in more than one driver, and lists two nv*.o drivers.

Deleting one of the drivers is apparently the wrong answer; and I do not know how to replace the file. Repair did not take care of it.

Open to any suggestions.

spindles 07-10-2005 12:00 PM

Hi Joe0532,
Did you get that 5600 Ultra sorted out?
What did you mainly want to do anyway? e.g. get a clone display? - Xinerama? - just get the driver and 3D working properly?
I am interested because I have just put a Leadtek g-force, nvidia FX5700 in my Suse 9.1 box -- mainly because it has outputs for CRT plus TV (S-video) plus DV. Could be very nice if I can get it sorted out.
Right now I'm fiddling with getting a clone out to the TV. Not sure which is the best way to go -- e.g. Twinview -- which Pcghost (above) says is a pain -- or some other way.
My system is also noting two drivers in some places, nv (from first auto-detect of the card) and nvidia (from online update).
Luckily, it seems only the nvidia is doing anything.
I want to get it organised with sax2, just because the XF86Config says 'please don't edit' so I'm afraid to, because I'm newbie.
Actually I don't know whether I can even use Twinview with this card, or how to find out for sure.

Pcghost 07-10-2005 12:50 PM

Once you know you have installed the Nvidia driver (should have been on the online update), then you no longer need to use the nv driver (but for god sakes don't delete it). As far as the warning in XF86Config saying "do not edit", SuSE says that in a lot of config files. This is Linux, there is no config file you "cannot edit". Just be smart and make a copy of the file before you edit it, and if your edits break something, simply copy the backup file back into place.

EDIT: I just remembered SuSE 9.3 uses xorg, not XFree86, so here is my SuSE xinerama config file.

The main thing regarding the no second screen error is the devices. In Sax, you can see your first video card yes? The dual headed Nvidia cards need two entries here. First, look at the hardware address listed in the first cards entry. Make a note of it. Also make sure it says nvidia not nv in the driver section. Then create a new entry, using the same basic info, and of course selecting the nvidia driver, not the nv driver. Set the hardware address of the second entry (should be a dropdown box) to whichever entry in the list is different than the one you noted from the first card.

Once you have two entries for your card, then do the same in the monitor section. There is likely and entry for whichever monitor SuSE detected on head 1 of the card. Make a new entry for the second monitor. Once you have both the device and monitor sections configured, then go into the display options and enable xinerama and such.

If you get stuck, post the config, and I'll try and spot the error. I have done this at least ten times so I am getting pretty good at tweaking the conf file.

Remember once you get this working backup the config file to floppy so you don't have to go through all this again next time you install or something breaks.

spindles 07-10-2005 01:55 PM

Many thanks Pcghost,
I feel more confident now.
I would rather be editing the config file, because Sax is not very useful unless you happen to be using a monitor from the list supplied. E.g. there is not a place to type in a different make and model. And I can't see e.g. 'Generic CRT Monitor' or 'TV'. Consequently my system thinks I have monitor called "-->VESA".
There is something else that puzzles me: the nvidia readme makes a point of saying to set the refresh rates for the second monitor if it is a TV: But it seems to me that I just want the signal to be pumped out -- I might put it into my tuner/amp, my video machine, my television. They all have plugs for auxillary signals incoming and they all get along well together. Is it really important what refresh/sync rates they get from an external source?

spindles 07-10-2005 03:07 PM

Still playing around with this...
But if anyone has any tips...
Looks like there is no Twinview with this card, at least sax does not have a place to put a value (on or off) for Twinview. Never mind.
Using Sax, I added another device, in XF86Conf, for my TV out signal.
But it crashed KDE. Damn!
I looked at a lot of other people's config files: I thought I was on the right track.

Kde says I need the X RANDR ('resize and rotate extension') version 1.1 or greater.
I wasn't aware that I was trying to resize or rotate anything.

In case anyone can see a problem, here are the two devices from my XF86Config

Section "Device"
BoardName "GeForce FX 5700VE"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
VendorName "NVidia"

Section "Device"
BoardName "GeForce FX 5700VE"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[1]"
Option "TVOverScan"
Option "TVStandard" "PAL-B"
Option "ConnectedMonitor" "TV"
Option "TVOutFormat" "SVIDEO"
Screen 1
Option "Rotate" "off"
VendorName "NVidia"

I didn't think I had to get Xinerama going just to get a TV output: but sax has turned it on.

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "on"
Option "Xinerama" "on"
Screen "Screen[0]"
Screen "Screen[1]"

Warnings from XFree86.0.log

(WW) NVIDIA(0): Multiple displays connected, but only one display allowed;
(WW) NVIDIA(0): using first display
(WW) NVIDIA(1): Option "TVOverScan" requires a floating point value
(WW) NVIDIA(1): Failure reading EDID parameters for display device TV-0
(II) Loading sub module "int10"
(WW) NVIDIA(0): Option "Rotate" is not used
(WW) NVIDIA(0): Option "CalcAlgorithm" is not used

On the positive side, I see my TV screen jumping around when I restart X, so at least I know the signal is getting down the wire, but no pic yet.

Still tinkering...

spindles 07-10-2005 03:58 PM

just noticed,
everything that is not X is displayed on the TV, i.e. the (verbose) output on shutdown and boot.
On boot everything on the monitor also goes down the wire to the TV, up until the nvidia splash: then the TV goes black again.
This is getting annoying now.
Obviously the card itself is quite happy to copy its signal down the s-vidoe wire -- until X gets involved.
Also, it's late, I'm tired, had too much wine -- i.e. usual linux newbie condition.

jschiwal 07-10-2005 04:21 PM

If you are living in the US, you don't want to use the PAL standard. That is the TV standard that they use in England and other European countries. France and Russia use the SECAM standard. ( Not certain I spelled that correctly )

Are you using a laptop with an s-video output? If so you may need to cycle through the video modes using the special key for that before getting an output through the port.

Also, to display on a video screen you may need to use a suitable resolution. I think that the D-1 resolution would be 720x486. This is the resolution that is used for DVD mpeg videos.

My Laptop screen has a native 1280x800 resolution. I used the 'gtf' program to generate modelines for it: gtf 1280 800 60 -x

Perhaps using this program will generate usable modelines for the video out:
gtf 720 486 60 -x
However, I don't think that this output would be interlaced, so you may need to do some googling for that.

spindles 07-10-2005 05:10 PM

Thanks jschiwal,
I will try some of those settings.
I'm in New Zealand and most equipment is PAL here by default, but can still handle other formats, NTSC and even SEACAM -- otherwise it would be like the bad old days when we couldn't watch NTSC videos bought direct from the USA.
I am using a desktop PC -- I just need to have the picture sent across the room to the TV.
This was a 10 second job in XP (but ick!): just plug in the s-video cable and tell the nvidia driver to send the signal down the wire. Has turned out to be a 16 hour job with Suse.
I don't know why I bother -- oh, I remember, Linux doesn't crash every day.

joe0532 07-11-2005 12:49 AM

nVidia multihead display problem
Thanks pcGhost and others. Your suggestions will be given a whirl once I get back home.

I am just running a side-by-side setup. It worked fine and was easy to set up in SUSE 9.1. 9.3 appears to be doing something strange in the config file. I will post it mid next week.

jschiwal 07-14-2005 06:38 PM

Sorry spindles, I had noticed the location for the first poster (MA). That's why I mentioned the PAL/NTSC (Never The Same Color) thing.
There should be several X86 configuration files in the /etc/X11 directory. One of them may have a setting for video. On many laptops for instance, the s-video and external vga ports are tied together, so it's a one or the other deal. Also, a pin may be connected to the s-video port so that the graphics chip may go into a special mode if the s-video port is connected.

If your desktop's video card is dual head and has both an extra vga port as well as a video output, the same may be true in your case.

After finding about the 'gtf' program that is a part of X11, I've saved a lot of time when setting up video for a laptop or flat screen monitor. For a flat screen, I will use the 'gtf' ( General Timing Formula ) program to generate a mode-line for the native resolution of the monitor, and not use any other resolutions. On my laptop that's 1280x800. For the flat top on my desk it's 12800x1024.

The command is used like:
gtf 1280 800 60 -x
This will generate a mode-line for a 1280x800 screen at 60hz refresh.

But, like I may of mentioned earlier, I don't know if this would generate an interlaced output. Actually, I don't know if PAL uses interlaced video.

Well, good luck!

aplourde 07-18-2005 06:29 PM

I'm having some issues as well with running dual head on an nvidia 6800GT. I can get both displays working fine; but the wrong display is the display 0. My big monitor is always the secondary display.

I've tried changing where the displays are plugged into the card (dual DVI's). And I've played with changing the settings in the xorg.conf file (which tend to screw up the resolution and help not at all).

Could someone direct me to the key to choosing which display is my primary display?


spindles 07-19-2005 07:18 AM

Hi aplourde,
I had a look tonight, but could not find a thread I had previously seen on the nvidia linux forum:
I seem to remember somebody saying that the nvidia cards have a default arrangement for primary/secondary that depends on what outputs you are using. E.g. if you have a digital and a crt output, the card will put them one way around and not the other.
I don't recall what advice was added to the thread.
If it was not on the the nvidia forum maybe I saw it here on LQ.
Anyway, you may as well tell us what outputs your card has -- to increase your chances of getting a more specific reply here.

spindles 07-19-2005 07:20 AM

My apologies, you already said, yours is dual DVI.

All times are GMT -5. The time now is 03:18 AM.