LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Please recommend a webcam for Fedora 9 (https://www.linuxquestions.org/questions/linux-hardware-18/please-recommend-a-webcam-for-fedora-9-a-669037/)

Peacedog 09-23-2008 08:24 PM

Does luvcview report the cam as /dev/video0 or /dev/video1, etc.?
Good luck. ;-)

ed_homeLinux 09-23-2008 08:41 PM

When I run luvcview I get


luvcview version 0.2.1
Video driver: x11
A window manager is available
video /dev/video0

Peacedog 09-23-2008 09:16 PM

That looks like an ffmpeg problem. Did you install a stable version of ffmpeg or a snapshot? If it's the later, try a stable version, if it's the former, try an updated version.
Good luck. ;-)

ed_homeLinux 09-24-2008 04:59 PM

I checked the ffmpeg website. They essentially don't produce "stable" versions. Maybe it was that spca driver I installed earlier or maybe ffmpeg doesn't like 64 bit OSes. Anyway, can you recommend something besides ffmpeg for recording video and audio. Thanks.

Ed

Peacedog 09-24-2008 07:25 PM

You cold try mencoder, there is a package called videoview, I haven't used it and do not know much about it.
Good luck. ;-)

ed_homeLinux 09-28-2008 03:18 PM

I redid the OS. I put on the 32 bit version of Fedora 9. I installed the video driver and mplayer. The latter includes mencoder. How do I use mencoder to record video and audio? When I type

mencoder -oac help

I get

mencoder -oac help
MEncoder dev-SVN-r27667-4.3.0 (C) 2000-2008 MPlayer Team
CPU: AMD Athlon(tm) 64 Processor 3400+ (Family: 15, Model: 15, Stepping: 0)
CPUflags: Type: 15 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2


Available codecs:
copy - frame copy, without re-encoding (useful for AC3)
pcm - uncompressed PCM audio
lavc - FFmpeg audio encoder (MP2, AC3, ...)


The availabe codecs from the "-ovc help" are

Available codecs:
copy - frame copy, without re-encoding. Doesn't work with filters.
frameno - special audio-only file for 3-pass encoding, see DOCS.
raw - uncompressed video. Use fourcc option to set format explicitly.
lavc - libavcodec codecs - best quality!
vfw - VfW DLLs, read DOCS/HTML/en/encoding-guide.html.
qtvideo - QuickTime DLLs, currently only SVQ1/3 are supported.

Peacedog 09-28-2008 03:44 PM

You could try this.
Code:

$ mencoder tv:// -tv driver=v4l:width=<width>:height=<height>:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac mp3lame -lameopts cbr:br=64:mode=3 -o <filename>.avi
Taken from here.
You could also retry ffmpeg on the new system and videoview.
Good luck. ;-)

ed_homeLinux 09-29-2008 07:35 PM

Thanks. What values for the width and height are supported? Do you know? I have been trying 320x640. I tried the command as

mencoder tv:// -tv driver=v4l:width=640:height=320:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac mp3lame -lameopts cbr:br=64:mode=3 -o test.avi

and got a message saying "lameopts is not an MEncoder option. I then try

mencoder tv:// -tv driver=v4l:width=640:height=320:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac mp3lame -o test.avi

and got a message saying "MPlayer was compiled without libmp3lame support." From my previous post you can see that "lavc" is available for both audio and video. Therefore, I tried

mencoder tv:// -tv driver=v4l:width=640:height=320:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac lavc -o test.avi

and got a message saying "WARNING: YOU ARE USING V4L DEMUXER WITH V4L2 DRIVERS!!!." I then try setting the driver as "v4l2" instead of "v4l" as shown below.

mencoder tv:// -tv driver=v4l2:width=640:height=320:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac lavc -o test.avi

This appears to work, because it starts throwing a lot of text to the screen and doesn't stop. The light on the camera also comes on. However, there is no picture shown to me. If I interrupt it and try to open the file, I get a message about proprietary and free formats. Is there a format I can use that is already installed on my computer? Should I see the picture as it is being recorded like with luvcview? Thanks for your help.

Ed

Peacedog 09-29-2008 08:58 PM

I don't *think* you'll be able to see what is recorded. There is a good Mencoder guide here. That should help with your options/formats. Hope that helps. You're welcome. ;-)
Good luck. ;-)

Did you try VideoView?
Good luck. ;-)

ed_homeLinux 10-05-2008 06:00 PM

I couldn't get videoview to work. Also, note that mplayer doesn't work with the camera (http://www.quickcamteam.net/software...tible-software).

I installed "cheese." This will record video fine just like luvcview but doesn't appear to record audio.

I plan to start a new thread in the software section. Thanks for your help.

Peacedog 10-05-2008 08:10 PM

You're welcome, I'm not familiar with cheese but, does it have a section/preference to select/configure audio options? If so, that should be set to your usb audio device (camera mic).

Other than that, sorry I couldn't be more help. You may want to pursue or chase down the problem with ffmpeg as it's very useful for more than just the camera.
Good luck. ;-)


All times are GMT -5. The time now is 10:40 PM.