LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Please recommend a webcam for Fedora 9 (https://www.linuxquestions.org/questions/linux-hardware-18/please-recommend-a-webcam-for-fedora-9-a-669037/)

ed_homeLinux 09-10-2008 06:34 PM

Please recommend a webcam for Fedora 9
 
Hi,

I would like to purchase a webcam for my Linux machine. I am currently running Redhat Fedora 9 (x86_64). Would someone please recommend one that is easy to install and use.

Ed

Peacedog 09-10-2008 09:15 PM

Hi ed_homeLinux, I'd recommend any of the UVC compliant cameras. You can read more here. More specifically I recently bought a Logitech Quickcam Pro 9000 that I couldn't be happier with. Painless install and setup, works very nicely.
Good luck. ;-)

ed_homeLinux 09-10-2008 09:31 PM

Thanks for the response. Is the camera automatically recognized upon boot? What software do I use? I have not yet used a webcam under Linux. I have used one a little under Windows.

Ed

Peacedog 09-10-2008 10:09 PM

You're welcome, it wasn't recognized on boot, I had to install the uvc package. YMMV, depends on the distro and kernel, etc.

Software, depends on what you want to do. I'm using Skype and the uvc viewer that comes as part of the driver package to grab snapshots, it also records video with no audio. I'm using ffmpeg and mencoder for video with audio. There should be some aplication available for any job you can think of. Video conferencing for instance, you could use Ekiga.

Good luck. ;-)

ed_homeLinux 09-19-2008 08:43 PM

OK. I have purchased a Logitech Quickcam Pro 9000. I looked around that website and it looks like I need the spca5xx driver. Next, I go to http://www.quickcamteam.net/software...webcam-driver/. From that page I click on the site for the spca5xx driver. Next I click download near the middle at the top (http://mxhaard.free.fr/download.html). Since my kernel is 2.6.26.3-29.fc9.x86_64, I download gspcav1-20071224.tar.gz. I unzip and untar the file. I change to the directory containing the contents of the tar file and type "make." I then get the following message

make -C /lib/modules/`uname -r`/build SUBDIRS=/home/ed/Download/gspcav1-20071224 CC=cc modules
make: *** /lib/modules/2.6.26.3-29.fc9.x86_64/build: No such file or directory. Stop.
make: *** [default] Error 2

The build directory points to "../../../usr/src/kernels/2.6.26.3-29.fc9.x86_64." The link is in red. I go to "../../../usr/src" and find that the directory is completely empty.

Are the steps above correct? Do I need to download something for the empty directory?

Ed

ed_homeLinux 09-19-2008 09:14 PM

I downloaded the kernel source and then needed the gcc compiler. I downloaded that and did both "make" and "make install." Both of those commands appeared to execute successfully. Now, what is next? I brought up "camstreams" but can't get it to work. I select various devices under "open video device," but I get an error that says "The device experienced an error -19 (No such device). The window will be closed.

Ed

Peacedog 09-19-2008 09:30 PM

Hi ed_homeLinux, First, I don't see the camera supported by the driver your trying to install. I'm using the uvc driver you can get the source from subversion.
Code:

svn checkout svn://svn.berlios.de/linux-uvc/linux-uvc/trunk
You can read more here and here.
Second, you need to install your kernel source and headers to compile against.
Good luck. ;-)

Peacedog 09-19-2008 09:32 PM

Sorry, looks like I was a bit late. Try the uvc driver and read up at the links in my last post.
Good luck. ;-)

ed_homeLinux 09-20-2008 07:09 PM

I installed svn and then ran the svn command to get the driver. I changed to the "trunk" directory and ran "make" and then "make install." The second command needed to be run as root. All of the text associated with the commands seemed to indicate everything went fine. I am still not sure if it is setup correctly. How do I make a short video with the camera? Thanks for your help.

Ed

Peacedog 09-20-2008 08:46 PM

The luvcview program will allow you to test the camera and make a video without audio.
Code:

luvcview -h
Will list the cli switches available. If you get nothing or errors, you may need to modprobe the driver first.
Good luck. ;-)

ed_homeLinux 09-21-2008 12:01 AM

Where do I get luvcview? It is not on my system. It doesn't appear to be available from Administration -> Add/Remove software and I haven't yet been able to find it on the web.

Ed

ed_homeLinux 09-21-2008 12:59 AM

GREAT!!!. I found luvcview after some more web searching and downloaded it. I got version 20070512. This can be obtained from http://mxhaard.free.fr/spca50x/Investigation/uvc/. I had trouble running make. I did more searching and found http://forums.fedoraforum.org/showthread.php?t=174877. I then ran "yum install SDL*devel" which took some time. I could then do a "make" and "make install." The camera now works!!!!!!!

ed_homeLinux 09-21-2008 08:09 AM

The video works!!! However, there is no audio. Does anyone know how to get luvcview to record the audio?

Peacedog 09-21-2008 01:49 PM

Hi ed homeLinux, The luvcview software doesn't record audio as far as I know. I have used ffmpeg to do that job.
Code:

ffmpeg -f video4linux2 -s 320x240 -i /dev/video0 -f audio_device -ac 2 -i /dev/dsp1 -f mp4 test.mp4
That works on my system, you may need to change the devices /dev/video0 and /dev/dsp1 accordingly to your system.
Good luck. ;-)

ed_homeLinux 09-23-2008 07:41 PM

I have installed ffmpeg. When I try to run the command you list I get the following


FFmpeg version SVN-r15385, Copyright (c) 2000-2008 Fabrice Bellard, et al.
configuration:
libavutil 49.10. 0 / 49.10. 0
libavcodec 52. 0. 0 / 52. 0. 0
libavformat 52.22. 1 / 52.22. 1
libavdevice 52. 1. 0 / 52. 1. 0
built on Sep 22 2008 22:25:58, gcc: 4.3.0 20080428 (Red Hat 4.3.0-8)
[video4linux2 @ 0x1e23500]Wrong time base (0)
/dev/video0: Error while opening file

What is wrong?

Ed

Peacedog 09-23-2008 08:24 PM

Does luvcview report the cam as /dev/video0 or /dev/video1, etc.?
Good luck. ;-)

ed_homeLinux 09-23-2008 08:41 PM

When I run luvcview I get


luvcview version 0.2.1
Video driver: x11
A window manager is available
video /dev/video0

Peacedog 09-23-2008 09:16 PM

That looks like an ffmpeg problem. Did you install a stable version of ffmpeg or a snapshot? If it's the later, try a stable version, if it's the former, try an updated version.
Good luck. ;-)

ed_homeLinux 09-24-2008 04:59 PM

I checked the ffmpeg website. They essentially don't produce "stable" versions. Maybe it was that spca driver I installed earlier or maybe ffmpeg doesn't like 64 bit OSes. Anyway, can you recommend something besides ffmpeg for recording video and audio. Thanks.

Ed

Peacedog 09-24-2008 07:25 PM

You cold try mencoder, there is a package called videoview, I haven't used it and do not know much about it.
Good luck. ;-)

ed_homeLinux 09-28-2008 03:18 PM

I redid the OS. I put on the 32 bit version of Fedora 9. I installed the video driver and mplayer. The latter includes mencoder. How do I use mencoder to record video and audio? When I type

mencoder -oac help

I get

mencoder -oac help
MEncoder dev-SVN-r27667-4.3.0 (C) 2000-2008 MPlayer Team
CPU: AMD Athlon(tm) 64 Processor 3400+ (Family: 15, Model: 15, Stepping: 0)
CPUflags: Type: 15 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2


Available codecs:
copy - frame copy, without re-encoding (useful for AC3)
pcm - uncompressed PCM audio
lavc - FFmpeg audio encoder (MP2, AC3, ...)


The availabe codecs from the "-ovc help" are

Available codecs:
copy - frame copy, without re-encoding. Doesn't work with filters.
frameno - special audio-only file for 3-pass encoding, see DOCS.
raw - uncompressed video. Use fourcc option to set format explicitly.
lavc - libavcodec codecs - best quality!
vfw - VfW DLLs, read DOCS/HTML/en/encoding-guide.html.
qtvideo - QuickTime DLLs, currently only SVQ1/3 are supported.

Peacedog 09-28-2008 03:44 PM

You could try this.
Code:

$ mencoder tv:// -tv driver=v4l:width=<width>:height=<height>:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac mp3lame -lameopts cbr:br=64:mode=3 -o <filename>.avi
Taken from here.
You could also retry ffmpeg on the new system and videoview.
Good luck. ;-)

ed_homeLinux 09-29-2008 07:35 PM

Thanks. What values for the width and height are supported? Do you know? I have been trying 320x640. I tried the command as

mencoder tv:// -tv driver=v4l:width=640:height=320:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac mp3lame -lameopts cbr:br=64:mode=3 -o test.avi

and got a message saying "lameopts is not an MEncoder option. I then try

mencoder tv:// -tv driver=v4l:width=640:height=320:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac mp3lame -o test.avi

and got a message saying "MPlayer was compiled without libmp3lame support." From my previous post you can see that "lavc" is available for both audio and video. Therefore, I tried

mencoder tv:// -tv driver=v4l:width=640:height=320:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac lavc -o test.avi

and got a message saying "WARNING: YOU ARE USING V4L DEMUXER WITH V4L2 DRIVERS!!!." I then try setting the driver as "v4l2" instead of "v4l" as shown below.

mencoder tv:// -tv driver=v4l2:width=640:height=320:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac lavc -o test.avi

This appears to work, because it starts throwing a lot of text to the screen and doesn't stop. The light on the camera also comes on. However, there is no picture shown to me. If I interrupt it and try to open the file, I get a message about proprietary and free formats. Is there a format I can use that is already installed on my computer? Should I see the picture as it is being recorded like with luvcview? Thanks for your help.

Ed

Peacedog 09-29-2008 08:58 PM

I don't *think* you'll be able to see what is recorded. There is a good Mencoder guide here. That should help with your options/formats. Hope that helps. You're welcome. ;-)
Good luck. ;-)

Did you try VideoView?
Good luck. ;-)

ed_homeLinux 10-05-2008 06:00 PM

I couldn't get videoview to work. Also, note that mplayer doesn't work with the camera (http://www.quickcamteam.net/software...tible-software).

I installed "cheese." This will record video fine just like luvcview but doesn't appear to record audio.

I plan to start a new thread in the software section. Thanks for your help.

Peacedog 10-05-2008 08:10 PM

You're welcome, I'm not familiar with cheese but, does it have a section/preference to select/configure audio options? If so, that should be set to your usb audio device (camera mic).

Other than that, sorry I couldn't be more help. You may want to pursue or chase down the problem with ffmpeg as it's very useful for more than just the camera.
Good luck. ;-)


All times are GMT -5. The time now is 11:19 PM.