LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Module Installation Error (https://www.linuxquestions.org/questions/linux-hardware-18/module-installation-error-59848/)

chem1 05-14-2003 08:34 PM

Module Installation Error
 
Hi,
I am using the command

insmod

to install the module spca50x.o for my Intel CS110 WebCAm.However , I am getting the following error:

spca50x-0.30.o: kernel-module version mismatch
spca50x-0.30.o was compiled for kernel version 2.4.20
while this kernel is version 2.4.20-8.


How do I resoolve the above conflict?

Thankx in advance...

fablepd 08-12-2003 02:10 AM

Hi ! I've got the same problem . 20 is the number of times your release (red hat 9 as mine) has been compiled. you have to compile source . the problem is i get many errors compiling it. i asked for help in spca50x mailing list and they told me to write:

make RH9_REMAP=1

instead of "make" but i get other errors. Read here:
------
Today's Topics:

1. Re: problems compiling spca50x on redhat 9 (2.4.20-8) for use wit (Dennis Gilmore)

--__--__--

list" <spca50x-devs@lists.sourceforge.net>

Subject: Re: [Spca50x-devs] problems compiling spca50x on redhat 9 (2.4.20-8)
for use wit
Date: Fri, 8 Aug 2003 00:39 AM/PM
From: Dennis Gilmore <dennis@dgilmore.net>
To: "Tomas Groth" <tomasgroth@hotmail.com>

<snip>

>> I don't have Redhat 9 myself, but I think this has been mentioned before.
>> try:
>> make KINCLUDE=/usr/src/linux-2.4/include RH9_REMAP=1
>>
>> or parhaps just
>> make RH9_REMAP=1


This is indeed what you need to do. i have just built the module against the
kernel in the new Red Hat beta and it no longer needs the RH9_REMAP to
compile so hopefully soon we wont need it anymore. but in the mean time can
someone with access to update things put it in the FAQ.

Dennis






--__--__--

_______________________________________________
Spca50x-devs mailing list
Spca50x-devs@lists.sourceforge.net
https://lists.sourceforge.net/lists/...o/spca50x-devs


End of Spca50x-devs Digest

claudiu_t 09-10-2003 04:15 PM

hi,

I have the same problem compiling a module from sources on SuSE 8.2. The module I try to compile is the eagle-1.4.0_pre5 ADSL USB driver for Sagem Fast 800 modem. Any idea how I fix this issue?

Regards and many thanks in advance !


All times are GMT -5. The time now is 12:21 AM.