LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-14-2003, 09:34 PM   #1
chem1
Member
 
Registered: Jun 2002
Location: White House, Washignton DC
Distribution: Red Hat 9
Posts: 270

Rep: Reputation: 30
Module Installation Error


Hi,
I am using the command

insmod

to install the module spca50x.o for my Intel CS110 WebCAm.However , I am getting the following error:

spca50x-0.30.o: kernel-module version mismatch
spca50x-0.30.o was compiled for kernel version 2.4.20
while this kernel is version 2.4.20-8.


How do I resoolve the above conflict?

Thankx in advance...
 
Old 08-12-2003, 03:10 AM   #2
fablepd
LQ Newbie
 
Registered: Aug 2003
Location: padova
Distribution: red hat 9 (in future debian)
Posts: 1

Rep: Reputation: 0
Hi ! I've got the same problem . 20 is the number of times your release (red hat 9 as mine) has been compiled. you have to compile source . the problem is i get many errors compiling it. i asked for help in spca50x mailing list and they told me to write:

make RH9_REMAP=1

instead of "make" but i get other errors. Read here:
------
Today's Topics:

1. Re: problems compiling spca50x on redhat 9 (2.4.20-8) for use wit (Dennis Gilmore)

--__--__--

list" <spca50x-devs@lists.sourceforge.net>

Subject: Re: [Spca50x-devs] problems compiling spca50x on redhat 9 (2.4.20-8)
for use wit
Date: Fri, 8 Aug 2003 00:39 AM/PM
From: Dennis Gilmore <dennis@dgilmore.net>
To: "Tomas Groth" <tomasgroth@hotmail.com>

<snip>

>> I don't have Redhat 9 myself, but I think this has been mentioned before.
>> try:
>> make KINCLUDE=/usr/src/linux-2.4/include RH9_REMAP=1
>>
>> or parhaps just
>> make RH9_REMAP=1


This is indeed what you need to do. i have just built the module against the
kernel in the new Red Hat beta and it no longer needs the RH9_REMAP to
compile so hopefully soon we wont need it anymore. but in the mean time can
someone with access to update things put it in the FAQ.

Dennis






--__--__--

_______________________________________________
Spca50x-devs mailing list
Spca50x-devs@lists.sourceforge.net
https://lists.sourceforge.net/lists/...o/spca50x-devs


End of Spca50x-devs Digest
 
Old 09-10-2003, 05:15 PM   #3
claudiu_t
LQ Newbie
 
Registered: Sep 2003
Location: Paris, France
Distribution: SuSE 9
Posts: 10

Rep: Reputation: 0
hi,

I have the same problem compiling a module from sources on SuSE 8.2. The module I try to compile is the eagle-1.4.0_pre5 ADSL USB driver for Sagem Fast 800 modem. Any idea how I fix this issue?

Regards and many thanks in advance !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[Error] Kernel Module : No kernel module build environment saman007uk Debian 7 09-09-2006 07:34 PM
perl module installation init-5 Linux - Software 26 10-25-2004 05:14 AM
perl module installation black_man Slackware 2 10-17-2004 02:57 PM
Module Installation patpawlowski Linux - Hardware 0 03-20-2003 12:21 AM
Module Installation juagut Linux - General 16 08-26-2001 08:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration