LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   KDE4 up-key stops working sporadically (https://www.linuxquestions.org/questions/linux-general-1/kde4-up-key-stops-working-sporadically-828016/)

kevinbenko 08-23-2010 11:16 AM

KDE4 up-key stops working sporadically
 
This is a weird one.

I'm running KDE 4.4.5 under Debian testing/unstable (squeeze/sid), and while I am in KDE, sometimes, my "up-arrow" key stops working.

The only keyboard events I've remapped are <printscreen>, <ctrl>+<pagedown>, and <alt>+<pagedown>

When I logout of KDE, and am in KDM, the offending key works again.

When I <alt><ctrl><Fn> to a virtual terminal, while still logged in to KDE, the offending key works.

XEV run while the key does not work *does* register the keystroke, it just seems to me that, for whatever reason, KDE is not dealing with the keystroke.

setxkbmap doesn't help.

I've used another keyboard, it doesn't help.

I've checked the physical connection, it doesn't help.

------

It seems to me that the only solution is to logout and login again. And while I need not do a reboot, it is still an annoyance.

Can someone offer some suggestions on where I can look to resolve this problem?
I would guess that the solution lies within ${HOME}/.kde/ but I am but an egg.

kevinbenko 08-30-2010 02:14 AM

[SOLVED] Well, I think it's solved
 
No responses.... damn!

I seem to have solved the problem.

I'm not too sure what and why this started happening, but it started a few weeks ago, and it seems to have been KDE4-specific.

Whatever caused it, a solution that seems to have worked was to use KDE4's system settings application.
Under regional & language --> keyboard layout:
enable keyboard layout
set keyboard model to "evdev-managed keyboard"

Now, I have no idea in the blue blazes as to why KDE was acting up on me (my previous layout was a generic 104-key keyboard), as it seemed to have been switching from the Xorg keyboard setting spontaneously, although I am curious as to what caused this spontaneous switch. Although I guess it could have been some conflict between KDE and Xorg.

Well, there are probably other fixes to this problem, but this one seems to have worked for me.

DanielEKFA 12-09-2010 04:45 PM

Well, I can confirm this on Kubuntu 10.10 Maverick. As stated here, http://www.linux-archive.org/debian-...sole-bash.html , the issue appears when logging out and back in. A sudo service kdm restart will bring back working up key behavior.

I'm wondering how you have this "regional & language" option in system settings? I only have Locale, which once opened does title itself "Country/Region & Language" but doesn't let me handle keyboards. "Input Devices" does let me configure keyboards, but in the "Keyboard model" dropdown I have nothing the sorts of evdev... Wonder if you need something in xorg.conf? My xorg.conf has no directives for input devices, only the ATI card that's in the box.

mlangdn 12-10-2010 12:46 AM

I am having a similar problem with my keyboard. For me, it was the down arrow key. I didn't logout, but instead unplugged the keyboard and plugged it back in. Then I found that the numpad keys could be affected next. I haven't fixed it yet, but i ain't looked that hard yet either.

glenstewart 12-25-2010 01:39 PM

How to work around the problem in KDE 4.5.4
 
System Settings
Input Devices
Keyboard
Hardware (tab)
set Keyboard Model: to Generic | Evdev-managed keyboard
Apply

Log out of KDE, then back in. The problem should be fixed.

mlangdn 12-25-2010 11:17 PM

I had an .Xmodmap file that evidently didn't work correctly. I deleted this a week ago and now its fine.


All times are GMT -5. The time now is 11:40 AM.