LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 08-23-2010, 11:16 AM   #1
kevinbenko
Member
 
Registered: Jun 2005
Location: Fargo, North Dakota
Distribution: Debian Testing
Posts: 280

Rep: Reputation: 52
KDE4 up-key stops working sporadically


This is a weird one.

I'm running KDE 4.4.5 under Debian testing/unstable (squeeze/sid), and while I am in KDE, sometimes, my "up-arrow" key stops working.

The only keyboard events I've remapped are <printscreen>, <ctrl>+<pagedown>, and <alt>+<pagedown>

When I logout of KDE, and am in KDM, the offending key works again.

When I <alt><ctrl><Fn> to a virtual terminal, while still logged in to KDE, the offending key works.

XEV run while the key does not work *does* register the keystroke, it just seems to me that, for whatever reason, KDE is not dealing with the keystroke.

setxkbmap doesn't help.

I've used another keyboard, it doesn't help.

I've checked the physical connection, it doesn't help.

------

It seems to me that the only solution is to logout and login again. And while I need not do a reboot, it is still an annoyance.

Can someone offer some suggestions on where I can look to resolve this problem?
I would guess that the solution lies within ${HOME}/.kde/ but I am but an egg.
 
Old 08-30-2010, 02:14 AM   #2
kevinbenko
Member
 
Registered: Jun 2005
Location: Fargo, North Dakota
Distribution: Debian Testing
Posts: 280

Original Poster
Rep: Reputation: 52
Talking [SOLVED] Well, I think it's solved

No responses.... damn!

I seem to have solved the problem.

I'm not too sure what and why this started happening, but it started a few weeks ago, and it seems to have been KDE4-specific.

Whatever caused it, a solution that seems to have worked was to use KDE4's system settings application.
Under regional & language --> keyboard layout:
enable keyboard layout
set keyboard model to "evdev-managed keyboard"

Now, I have no idea in the blue blazes as to why KDE was acting up on me (my previous layout was a generic 104-key keyboard), as it seemed to have been switching from the Xorg keyboard setting spontaneously, although I am curious as to what caused this spontaneous switch. Although I guess it could have been some conflict between KDE and Xorg.

Well, there are probably other fixes to this problem, but this one seems to have worked for me.
 
Old 12-09-2010, 04:45 PM   #3
DanielEKFA
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Rep: Reputation: 0
Well, I can confirm this on Kubuntu 10.10 Maverick. As stated here, http://www.linux-archive.org/debian-...sole-bash.html , the issue appears when logging out and back in. A sudo service kdm restart will bring back working up key behavior.

I'm wondering how you have this "regional & language" option in system settings? I only have Locale, which once opened does title itself "Country/Region & Language" but doesn't let me handle keyboards. "Input Devices" does let me configure keyboards, but in the "Keyboard model" dropdown I have nothing the sorts of evdev... Wonder if you need something in xorg.conf? My xorg.conf has no directives for input devices, only the ATI card that's in the box.
 
Old 12-10-2010, 12:46 AM   #4
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,510

Rep: Reputation: 228Reputation: 228Reputation: 228
I am having a similar problem with my keyboard. For me, it was the down arrow key. I didn't logout, but instead unplugged the keyboard and plugged it back in. Then I found that the numpad keys could be affected next. I haven't fixed it yet, but i ain't looked that hard yet either.
 
Old 12-25-2010, 01:39 PM   #5
glenstewart
LQ Newbie
 
Registered: Dec 2010
Posts: 1

Rep: Reputation: 0
How to work around the problem in KDE 4.5.4

System Settings
Input Devices
Keyboard
Hardware (tab)
set Keyboard Model: to Generic | Evdev-managed keyboard
Apply

Log out of KDE, then back in. The problem should be fixed.
 
Old 12-25-2010, 11:17 PM   #6
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,510

Rep: Reputation: 228Reputation: 228Reputation: 228
I had an .Xmodmap file that evidently didn't work correctly. I deleted this a week ago and now its fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Control key not working after installing KDE4 jimbro727 Linux - Software 1 09-24-2009 02:07 PM
Slackware64-current, KDE4.2.3: Pipe key not working in Konsole gargamel Slackware 5 05-22-2009 07:11 AM
"v" key stops working chichibabin Linux - General 9 10-17-2003 09:46 AM
backspace key stops working rburge Linux - General 0 07-16-2003 09:39 AM
internet connection on RH9 working sporadically vhalik Linux - Networking 3 06-19-2003 02:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 05:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration