LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Why does Krunner not show up when pressing alt+F2 in Slackware64 Ver. 13.0? (http://www.linuxquestions.org/questions/slackware-14/why-does-krunner-not-show-up-when-pressing-alt-f2-in-slackware64-ver-13-0-a-753320/)

Timberwolf753 09-07-2009 09:49 AM

Why does Krunner not show up when pressing alt+F2 in Slackware64 Ver. 13.0?
 
I just installed Slackware 64 Ver. 13.0 and when I do alt+52 xcfe run comes up. On further inspection the xcfe is running along side of kde. I selected kde as my window manager. What is going on here.

mlangdn 09-08-2009 02:59 AM

Krunner has always worked for me. I have no idea why xfce is running alongside of kde. Having two xsessions always requires user input. This is really weird behavior.

AlvaroG 09-08-2009 10:04 AM

Same happens here
 
I'm having the same issue, on Slackware 32bit
If I press Alt-F2, xfrun4 will show up instead of krunner.
pstree output shows 3 xfce processes running on my KDE session, I'm not on my system right now, but I do remember one of the processes is xfce4-desktop-helper (or something like it), other is xfrun4, and the third one I don't remember the name.

Timberwolf753 09-08-2009 06:44 PM

Quote:

Originally Posted by mlangdn (Post 3673965)
Krunner has always worked for me. I have no idea why xfce is running alongside of kde. Having two xsessions always requires user input. This is really weird behavior.

Your telling me. I just booted up fine today with krunner coming up. Lets hope it was just a simple memory goof and that it does not come back again.

Timberwolf753 09-08-2009 06:46 PM

Quote:

Originally Posted by AlvaroG (Post 3674374)
I'm having the same issue, on Slackware 32bit
If I press Alt-F2, xfrun4 will show up instead of krunner.
pstree output shows 3 xfce processes running on my KDE session, I'm not on my system right now, but I do remember one of the processes is xfce4-desktop-helper (or something like it), other is xfrun4, and the third one I don't remember the name.

At least I am not the only one having this issue.

shadowsnipes 09-09-2009 01:24 AM

I think I remember seeing this on my wife's laptop. Just before xfrun (I think) came up instead, a tray icon mentioned that krunner (or the search service) was being disabled to conserve memory. This is with 1GB installed RAM.

Woodsman 09-09-2009 09:33 PM

Quote:

At least I am not the only one having this issue.
Count me in too. :)

I just created a new user account for my HTPC and when I pressed Alt-F2 that GTK thingie (shudder!) appeared.

Quote:

...was being disabled to conserve memory.
Hmm. I had two user accounts running KDE. I have 2 GB of RAM but perhaps my system was pushing the limits. I have 2.1 GB of swap though. Yet perhaps there is a bug related to memory usage. :scratch:

I exited both KDE sessions to the command line (I was in run level 3) and then restarted both KDE sessions. No GTK runner appeared and all was restored to normal.

GrapefruiTgirl 09-09-2009 10:21 PM

Quote:

Originally Posted by mlangdn (Post 3673965)
Krunner has always worked for me. I have no idea why xfce is running alongside of kde. Having two xsessions always requires user input. This is really weird behavior.

I came across a section of the KDE Control Center thingie, dealing with services to be started at startup, and there were both XFCE and KDE services in there enabled by default, on a fresh install.

If you guys haven't come across this, have a look for it, and enable/disable stuff as needed. Maybe this will solve the issue of both DE's background services running when you don't want that, as well as defining which *runner you want to use.

:twocents:
Sasha

Woodsman 09-09-2009 10:26 PM

Hmm. I don't see any Xfce services listed.

mlangdn 09-09-2009 10:30 PM

I just took a look at that. I don't have anything form XFCE in there running. Maybe that's why I have never had the problem.

GrapefruiTgirl 09-09-2009 10:36 PM

Well, I'll tell ya what (and I hope this doesn't count as "off topic"-- it does qualify as "weird" though..)

I just executed

shell$ startkde -- :1

from a console window from my XFCE session, and for a few seconds, KDE started up on a new VT, but at the last stage of the KDM greeter, it borked back to my XFCE session, only now, it's BOTH XFCE AND KDE :scratch: at the same time.

I have my XFCE-themed apps I was running in XFCE, all where they were; I have my wallpapers changed over to those that I had set in KDE; I have the KDE taskbar on both monitors, but my autohiding XFCE taskbar appears when I hit the top of the screen (on TOP of the KDE taskbars).

I'm not sure *what* DE I'm running at this moment...

UPDATE -- hitting CTRL-C on the console where I executed the "startkde" command caused all the KDE stuff to disappear, leaving my XFCE session as it should be. So, I guess I was running XFCE, but with KDE overlaid onto it. :confused:

Woodsman 09-10-2009 01:01 AM

Okay, I found the culprits.

The apps are not located in KDE Control Center Services but in Control Center Autostart.

There are several Xfce autostart desktop files located in /etc/xdg/autostart and /etc/xfce/xdg/autostart.

The files get stuffed into ~/.config/autostart.

Also, I suddenly started having problems with KRunner freezing. I opened the krunnerrc config file and deleted a long weird-looking string from [TaskDialog]headerState. No more freezing.

GrapefruiTgirl 09-10-2009 07:45 AM

Quote:

Originally Posted by Woodsman (Post 3676866)
Also, I suddenly started having problems with KRunner freezing. I opened the krunnerrc config file and deleted a long weird-looking string from [TaskDialog]headerState. No more freezing.

Nice :p

Do you happen to have a record of that 'long, weird-looking string?' so we'll know what to watch out for?

Sasha

Woodsman 09-10-2009 11:34 AM

Quote:

Do you happen to have a record of that 'long, weird-looking string?' so we'll know what to watch out for?
Not anymore. :( But that was not the problem. A couple of logins later and KRunner again started hanging. This time I deleted the krunnerrc config file. I lost the history but not a big deal. So far I haven't had KRunner freeze, but I haven't logged in sufficient times to know whether the problem is gone.

I have to say that I am using only KDE 4 with my new HTPC. I intend to stay with KDE 4. But things sure are buggy. I hope the Slackware dev team adds 4.3.1 to Current very soon. :) I could care less about all the arguments about KDE 4. I like the look-and-feel. I just want a version that is less buggy and 4.3.x has a few thousand bug fixes.

shadowsnipes 09-10-2009 01:03 PM

Quote:

Originally Posted by shadowsnipes (Post 3675413)
I think I remember seeing this on my wife's laptop. Just before xfrun (I think) came up instead, a tray icon mentioned that krunner (or the search service) was being disabled to conserve memory. This is with 1GB installed RAM.

Correcting myself. I went back to the machine and it turns out it was the Stigi file indexer that was suspended.

krunner appears to be working now as well. Weird. Maybe it just needed a long login to warm up enough ;) That would make sense if it was still indexing executables when I logged out previously.


All times are GMT -5. The time now is 11:12 AM.