LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   udevd hangs for few seconds - cfg80211: failed to add phy80211 symlink to netdev! (http://www.linuxquestions.org/questions/slackware-14/udevd-hangs-for-few-seconds-cfg80211-failed-to-add-phy80211-symlink-to-netdev-4175430575/)

agrest 10-04-2012 08:07 PM

udevd hangs for few seconds - cfg80211: failed to add phy80211 symlink to netdev!
 
Hi,

I have Dell Latitude D600 and D610, both have ipw2200. First I installed Slackware 14 on D600 with generic kernel with initrd (ext4). I notice udevd hang, I don't use wifi on it so I removed and problem went away. Today I did fresh install on D610 with generic-smp-3.2.29 with initrd (ext4) and udevd also hangs for few seconds (see link below). I think on D600 with Slackware 13.37 on 3.2 kernel I did not have that problem.

http://ksnider1.sixbit.org/udevd.jpg

hotchili 10-04-2012 08:42 PM

If it is the problem I think it is, then you can workaround it by adding your wlan
driver to /etc/modprobe.d/blacklist.conf ( in my case I had to add: blacklist brcmsmac )
and then load the module via modprobe in /etc/rc.d/rc.local...

Problem is caused by a change in udev, upgrading to a newer kernel version (3.4+) should also fix it.
If you want to know more details: http://marc.info/?l=linux-netdev&m=132655490826765&w=2

willysr 10-04-2012 10:13 PM

i could use this trick for my old laptop which also uses ipw2200 firmware and have the same problems

Thanks

Grischuna 10-04-2012 10:14 PM

Hello agrest,

I had exactly the same issue with the same ipw2200 wireless module and fixed it with the solution that hotchili explains a while ago. You will find other posts here explaining the issue.

Cheers


All times are GMT -5. The time now is 01:27 AM.