LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-04-2012, 08:07 PM   #1
agrest
LQ Newbie
 
Registered: Oct 2010
Posts: 1

Rep: Reputation: 0
udevd hangs for few seconds - cfg80211: failed to add phy80211 symlink to netdev!


Hi,

I have Dell Latitude D600 and D610, both have ipw2200. First I installed Slackware 14 on D600 with generic kernel with initrd (ext4). I notice udevd hang, I don't use wifi on it so I removed and problem went away. Today I did fresh install on D610 with generic-smp-3.2.29 with initrd (ext4) and udevd also hangs for few seconds (see link below). I think on D600 with Slackware 13.37 on 3.2 kernel I did not have that problem.

http://ksnider1.sixbit.org/udevd.jpg
 
Old 10-04-2012, 08:42 PM   #2
hotchili
Member
 
Registered: Sep 2009
Location: Germany
Distribution: slackware64-current
Posts: 72

Rep: Reputation: 18
If it is the problem I think it is, then you can workaround it by adding your wlan
driver to /etc/modprobe.d/blacklist.conf ( in my case I had to add: blacklist brcmsmac )
and then load the module via modprobe in /etc/rc.d/rc.local...

Problem is caused by a change in udev, upgrading to a newer kernel version (3.4+) should also fix it.
If you want to know more details: http://marc.info/?l=linux-netdev&m=132655490826765&w=2

Last edited by hotchili; 10-04-2012 at 08:43 PM.
 
1 members found this post helpful.
Old 10-04-2012, 10:13 PM   #3
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,638

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
i could use this trick for my old laptop which also uses ipw2200 firmware and have the same problems

Thanks
 
Old 10-04-2012, 10:14 PM   #4
Grischuna
Member
 
Registered: Mar 2009
Distribution: Slackware64 14.0 multilib
Posts: 44

Rep: Reputation: 0
Hello agrest,

I had exactly the same issue with the same ipw2200 wireless module and fixed it with the solution that hotchili explains a while ago. You will find other posts here explaining the issue.

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
udevd - rmdir(/dev/.udev/failed) failed: Permission denied pbhj Slackware 20 03-21-2008 11:46 AM
Failed boot with udevd-event jumico Linux - Hardware 0 02-11-2007 02:53 PM
LXer: Include diff attachment -- Re: Fedora-netdev FC4: kernel-2.6.14-1.1656_FC4.netdev.7 is now available! LXer Syndicated Linux News 0 01-09-2006 09:01 PM
LXer: Fedora-netdev FC4: kernel-2.6.14-1.1653_FC4.netdev.6 is now available! LXer Syndicated Linux News 0 12-15-2005 02:32 PM
LXer: Fedora-netdev FC4: kernel-2.6.14-1.1644_FC4.netdev.5 is now available! LXer Syndicated Linux News 0 12-12-2005 04:01 PM


All times are GMT -5. The time now is 07:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration