LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Sound problem - Default sound card (http://www.linuxquestions.org/questions/slackware-14/sound-problem-default-sound-card-4175449567/)

AryMaynart 02-10-2013 01:43 PM

Sound problem - Default sound card
 
Heloo,

I am having a problem with my sound card. I have two of them, onboard and a c-media pci. Slack is setting the onboard card has the default one.
I want to change this. I google it, but the solutions i have found does not work. I think is because of slack version.
This does not help. Its returning a syntax error on line 5

Code:

PROBLEM: alsa is setting the wrong device as the default sound; you can force the correct default as follows:

FIX: Create /etc/asound.conf and add an entry for the working card/slot and device:

  pcm.!default {
        type hw
        card 1
        device 0
  }
  ctl.!default {
        type hw
        card 1
        device 0
  }

Look what I have here!!

Code:

root@Ary-PC:/proc/asound# cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xdfef4000 irq 23
1 [CMI8738 ]: CMI8738 - C-Media CMI8738
C-Media CMI8738 (model 37) at 0xe800, irq 19

I want to set C-media has default sound card.
How can i do that?

kkady32 02-10-2013 02:04 PM

Try to put in /etc/modprobe.d/sound.conf
Code:

options snd_hda_intel index=-2
options snd_cmipci index=0

These changes require a system reboot.

AryMaynart 02-10-2013 05:46 PM

Should I create that?
 
Quote:

Originally Posted by kkady32 (Post 4888607)
Try to put in /etc/modprobe.d/sound.conf
Code:

options snd_hda_intel index=-2
options snd_cmipci index=0

These changes require a system reboot.

Hi,

I don't have this file at this folder. Should I create that?
I made the sound work, but i am having to change the driver in each app.
My sound card still being the second choice of slack.
And why i have to close my player before i see youtube videos?
And why i cant play music and see videos at the same time?
I don't believe salckware just permit one sound media based at a time.

kkady32 02-11-2013 12:50 AM

You must create this file.
If your sound card order changes on boot, you can specify their order in any file ending with .conf in /etc/modprobe.d
You can also provide an index of -2 to instruct ALSA to never use a card as the primary one.
Source from here

AryMaynart 02-11-2013 04:24 PM

Does not work
 
Quote:

Originally Posted by kkady32 (Post 4888862)
You must create this file.
If your sound card order changes on boot, you can specify their order in any file ending with .conf in /etc/modprobe.d
You can also provide an index of -2 to instruct ALSA to never use a card as the primary one.
Source from here

This command does not work on my slackware 14.

Code:

options snd slots=snd_mia,snd_hda_intel
options snd_mia index=0
options snd_hda_intel index=1

Even at the terminal i have an error.
Code:

root@Ary-PC:/etc/modprobe.d# . alsa-base.conf
bash: options: command not found
bash: options: command not found
bash: options: command not found


tuxbg 02-11-2013 04:37 PM

No you shouldn't execute that /etc/modprobe.d/alsa-base.conf
Put that file in /lib/modprobe.d instead of /etc/modprobe.d ,and then reboot your computer
This is mine

Code:

cat /lib/modprobe.d/alsa.conf
options snd-hda-intel index=1
options snd-ctxfi index=0


AryMaynart 02-12-2013 09:16 AM

Quote:

Originally Posted by tuxbg (Post 4889440)
No you shouldn't execute that /etc/modprobe.d/alsa-base.conf
Put that file in /lib/modprobe.d instead of /etc/modprobe.d ,and then reboot your computer
This is mine

Code:

cat /lib/modprobe.d/alsa.conf
options snd-hda-intel index=1
options snd-ctxfi index=0


Ok.
Its working.
The sound card still is not the default, but that is not the bigger problem now. Why, when i am seeing a video and try to play a music i receive the message: Your sound card is beeing used or occuped with another aplication.
This is a big problem. Can i solve that?

AryMaynart 02-13-2013 09:41 PM

Annyone???
In slackware 14 i can play just one media at time.
How can I solve that??


All times are GMT -5. The time now is 05:13 PM.