LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-10-2013, 01:43 PM   #1
AryMaynart
LQ Newbie
 
Registered: Feb 2013
Posts: 15

Rep: Reputation: Disabled
Sound problem - Default sound card


Heloo,

I am having a problem with my sound card. I have two of them, onboard and a c-media pci. Slack is setting the onboard card has the default one.
I want to change this. I google it, but the solutions i have found does not work. I think is because of slack version.
This does not help. Its returning a syntax error on line 5

Code:
PROBLEM: alsa is setting the wrong device as the default sound; you can force the correct default as follows:

FIX: Create /etc/asound.conf and add an entry for the working card/slot and device:

   pcm.!default {
        type hw
        card 1
        device 0
   }
   ctl.!default {
        type hw
        card 1
        device 0
   }
Look what I have here!!

Code:

root@Ary-PC:/proc/asound# cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xdfef4000 irq 23
1 [CMI8738 ]: CMI8738 - C-Media CMI8738
C-Media CMI8738 (model 37) at 0xe800, irq 19

I want to set C-media has default sound card.
How can i do that?
 
Old 02-10-2013, 02:04 PM   #2
kkady32
Member
 
Registered: Dec 2010
Distribution: Slackware64
Posts: 86

Rep: Reputation: 14
Try to put in /etc/modprobe.d/sound.conf
Code:
options snd_hda_intel index=-2
options snd_cmipci index=0
These changes require a system reboot.
 
Old 02-10-2013, 05:46 PM   #3
AryMaynart
LQ Newbie
 
Registered: Feb 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Should I create that?

Quote:
Originally Posted by kkady32 View Post
Try to put in /etc/modprobe.d/sound.conf
Code:
options snd_hda_intel index=-2
options snd_cmipci index=0
These changes require a system reboot.
Hi,

I don't have this file at this folder. Should I create that?
I made the sound work, but i am having to change the driver in each app.
My sound card still being the second choice of slack.
And why i have to close my player before i see youtube videos?
And why i cant play music and see videos at the same time?
I don't believe salckware just permit one sound media based at a time.
 
Old 02-11-2013, 12:50 AM   #4
kkady32
Member
 
Registered: Dec 2010
Distribution: Slackware64
Posts: 86

Rep: Reputation: 14
You must create this file.
If your sound card order changes on boot, you can specify their order in any file ending with .conf in /etc/modprobe.d
You can also provide an index of -2 to instruct ALSA to never use a card as the primary one.
Source from here
 
Old 02-11-2013, 04:24 PM   #5
AryMaynart
LQ Newbie
 
Registered: Feb 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Does not work

Quote:
Originally Posted by kkady32 View Post
You must create this file.
If your sound card order changes on boot, you can specify their order in any file ending with .conf in /etc/modprobe.d
You can also provide an index of -2 to instruct ALSA to never use a card as the primary one.
Source from here
This command does not work on my slackware 14.

Code:
options snd slots=snd_mia,snd_hda_intel
options snd_mia index=0
options snd_hda_intel index=1
Even at the terminal i have an error.
Code:
root@Ary-PC:/etc/modprobe.d# . alsa-base.conf
bash: options: command not found
bash: options: command not found
bash: options: command not found
 
Old 02-11-2013, 04:37 PM   #6
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 249

Rep: Reputation: Disabled
No you shouldn't execute that /etc/modprobe.d/alsa-base.conf
Put that file in /lib/modprobe.d instead of /etc/modprobe.d ,and then reboot your computer
This is mine

Code:
cat /lib/modprobe.d/alsa.conf 
options snd-hda-intel index=1
options snd-ctxfi index=0

Last edited by tuxbg; 02-11-2013 at 04:38 PM.
 
Old 02-12-2013, 09:16 AM   #7
AryMaynart
LQ Newbie
 
Registered: Feb 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by tuxbg View Post
No you shouldn't execute that /etc/modprobe.d/alsa-base.conf
Put that file in /lib/modprobe.d instead of /etc/modprobe.d ,and then reboot your computer
This is mine

Code:
cat /lib/modprobe.d/alsa.conf 
options snd-hda-intel index=1
options snd-ctxfi index=0
Ok.
Its working.
The sound card still is not the default, but that is not the bigger problem now. Why, when i am seeing a video and try to play a music i receive the message: Your sound card is beeing used or occuped with another aplication.
This is a big problem. Can i solve that?
 
Old 02-13-2013, 09:41 PM   #8
AryMaynart
LQ Newbie
 
Registered: Feb 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Annyone???
In slackware 14 i can play just one media at time.
How can I solve that??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] (F13) Surround Sound Problem. Built in sound card, blue port not working. 1337.HDLA Linux - Hardware 5 09-15-2010 04:32 AM
[SOLVED] How to make a sound card a Default Sound Card Srikanth VM Slackware 5 09-29-2009 05:01 AM
general problem ... rhel 5 everything of sound card got configured but no sound raaki_88 Linux - Enterprise 3 08-13-2008 08:30 AM
fc6 sound card problem(SigmaTel STAC9200),no sound,who can help me? weller Linux - Laptop and Netbook 4 02-10-2008 08:19 AM
Sound problem at openSuSE 10.2. Sound card unidentified perfectly Fakhri Linux - Hardware 0 04-29-2007 10:01 PM


All times are GMT -5. The time now is 03:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration