LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   some issues with Slackware 14.1 32 bits xfce (http://www.linuxquestions.org/questions/slackware-14/some-issues-with-slackware-14-1-32-bits-xfce-4175494319/)

recan 02-09-2014 06:41 AM

some issues with Slackware 14.1 32 bits xfce
 
Hi everyone some issues after success installation of slackware 14.1 32 bits xfce for the first time
let start with the sound in skype :
- the sound is working fine only I can't get the microphone working in skype.
- howto enable a applet to control the network , I m using a wired connection
and it worke fine but it i turn off the modem and start slackware , i will not be able to connect to internet , it seems that the modem must be on when the system boot up.

- about resolution in console when the system boot , I tried to use a good resolution in order to read the boot lines but it doesn t work , alawys the resolution in boot is poor


any help plz will be welome

rkfb 02-09-2014 08:03 AM

Quote:

Originally Posted by recan (Post 5114384)
Hi everyone some issues after success installation of slackware 14.1 32 bits xfce for the first time
let start with the sound in skype :
- the sound is working fine only I can't get the microphone working in skype.
- howto enable a applet to control the network , I m using a wired connection
and it worke fine but it i turn off the modem and start slackware , i will not be able to connect to internet , it seems that the modem must be on when the system boot up.

- about resolution in console when the system boot , I tried to use a good resolution in order to read the boot lines but it doesn t work , alawys the resolution in boot is poor


any help plz will be welome

I think if you look in the skype preferences under audio you can select your microphone there somewhere from a dropdown list.

I would say don't turn off your modem, leave it on. Or switch it on first and wait for it to boot up and connect before starting slackware.

Dugan has some information on setting the console resolution here:

http://duganchen.ca/writings/slackware/setup/

TobiSGD 02-09-2014 08:04 AM

Quote:

Originally Posted by recan (Post 5114384)
- howto enable a applet to control the network , I m using a wired connection
and it worke fine but it i turn off the modem and start slackware , i will not be able to connect to internet , it seems that the modem must be on when the system boot up.

Try to configure your network with NetworkManager (run netconfig as root and choose the NetworkManager option), then run nm-applet in XFCE.

Quote:

- about resolution in console when the system boot , I tried to use a good resolution in order to read the boot lines but it doesn t work , alawys the resolution in boot is poor
Which video driver do you use?

allend 02-09-2014 08:15 AM

Quote:

- the sound is working fine only I can't get the microphone working in skype
Have you used 'alsamixer' to check the Capture settings of your sound device? (If this does not seem to work, please post a screenshot of the alsamixer Capture page.

Quote:

- howto enable a applet to control the network , I m using a wired connection
From the email to root titled "Welcome to Linux (Slackware 14.1)!"
Quote:

If you will be using wireless (or even a wired interface), you might
want to let NetworkManager handle your network connections. This is
a choice during the initial installation, but may also be selected
later by rerunning netconfig, or by setting the startup script
to executable (chmod 755 /etc/rc.d/rc.networkmanager). When Network
Manager is used to handle connections, a nice interface is provided
to scan for wireless access points and make changes to the network
configuration. This interface runs automatically with KDE or Xfce.
In fluxbox, the nm-applet program will need to be launched. Other
window managers lack a system tray to display nm-applet, so for those
you might want to look at wicd in /extra, which also provides a nice
GUI tool for connecting to wireless (or wired) networks. For window
managers that do not provide a tray for running programs, start
"wicd-client" to make changes. With NetworkManager or wicd, it's
a good idea to remove any existing network configuration in
/etc/rc.d/rc.inet1.conf first. This can be done by running netconfig
and setting the machine to use loopback. Then, if you're using
NetworkManager run it a second time and select NetworkManager.
Quote:

but it i turn off the modem and start slackware , i will not be able to connect to internet , it seems that the modem must be on when the system boot up
If you set up networking using rc.inet1.conf during initial install, then, as root, 'sh /etc/rc.d/rc.inet1 restart' should activate networking.

Quote:

- about resolution in console when the system boot , I tried to use a good resolution in order to read the boot lines but it doesn t work
The early boot stage video resolution is controlled by the 'vga=' line in /etc/lilo.conf. You can experiment with different resolutions by setting 'vga=ask' in /etc/lilo.conf, rerunning 'lilo' and then rebooting. If you find something that works, you can make the change permanent with a suitable entry in /etc/lilo.conf and rerunning 'lilo'.
Later in the boot stage, the kernel switches to using KMS. The resolution can be set by using the 'video=' option. Full details are found in /usr/src/linux/Documentation/fb/modedb.txt. For initial testing you can append a kernel parameter at boot by hitting TAB and typing something like ' video=1280x1024'. If you find something that works, you can make the change permanent by adding the setting to the 'append=' line in /etc/lilo.conf and rerunning 'lilo'.

TobiSGD 02-09-2014 08:32 AM

Quote:

Originally Posted by allend (Post 5114406)
Later in the boot stage, the kernel switches to using KMS. The resolution can be set by using the 'video=' option. Full details are found in /usr/src/linux/Documentation/fb/modedb.txt. For initial testing you can append a kernel parameter at boot by hitting TAB and typing something like ' video=1280x1024'. If you find something that works, you can make the change permanent by adding the setting to the 'append=' line in /etc/lilo.conf and rerunning 'lilo'.

Keep in mind that this will not work with the proprietary drivers from AMD/Nvidia.

allend 02-09-2014 08:39 AM

Quote:

Keep in mind that this will not work with the proprietary drivers from AMD/Nvidia.
Problems with resolution at boot are often associated with Intel graphics.

TobiSGD 02-09-2014 08:46 AM

According to the OP's signature he is using Nvidia. That information may be wrong for this particular machine, though.

enorbet 02-09-2014 10:43 AM

Regarding Skype - I have found that it is a tad buggy with capture devices. Often my mic will not work but if I change it to something else, apply, and then change back and apply, then it works. I'm sometimes tempted to tell my Skype friends to just get TeamSpeak which works similarly but flawlessly.

Didier Spaier 02-09-2014 12:32 PM

To get an applet to manage your network, run as root "netconfig", choose NetworkManager, run as root "/etc/rc.d/rc.networkmanager restart" then if the applet doesn't show run as a regular user "nm-applet".

recan 02-09-2014 03:11 PM

2 Attachment(s)
Hi , First thank you for everyone have read my post and specially for all whom answered , this wonderful really
almost my issues are solved by the genius instructions found in yours posts only one not yet
yes it is microphone in skype may be this will help to find solutions

Attachment 14712

Attachment 14713

allend 02-09-2014 04:59 PM

Have you tried setting the microphone to 'HDA Intel PCH, ALC887-VD Analog (hw:0.0)' or 'HDA Intel PCH, ALC887-VD Alt Analog (hw:0.2)' in Skype?

PS- Reported to be working by Srinivas Gowda here. http://askubuntu.com/questions/16372...rking-in-skype

recan 02-09-2014 05:13 PM

Quote:

Originally Posted by allend (Post 5114621)
Have you tried setting the microphone to 'HDA Intel PCH, ALC887-VD Analog (hw:0.0)' or 'HDA Intel PCH, ALC887-VD Alt Analog (hw:0.2)' in Skype?

PS- Reported to be working by Srinivas Gowda here. http://askubuntu.com/questions/16372...rking-in-skype

thank you , yes i tried all what i can in skype option for microphone but not working alos the section for recording on alsa project
arecord -vv -fdat foo.wav

thank you again

allend 02-09-2014 06:45 PM

Your screenshot for alsamixer in post#10 showed the output device settings. How about the Capture settings? (Hit F4
)

recan 02-10-2014 02:18 AM

1 Attachment(s)
Quote:

Originally Posted by allend (Post 5114658)
your screenshot for alsamixer in post#10 showed the output device settings. How about the capture settings? (hit f4
)

Attachment 14715

allend 02-10-2014 07:57 AM

Everything looks like it should be working, so I am getting desperate for ideas.

I did find this that seems to be very similar to your predicament. http://forum.kde.org/viewtopic.php?f=19&t=110552
You could try the 'model=auto' option to the snd-hda-intel kernel module suggested there. For Slackware specific advice see http://docs.slackware.com/howtos:har..._snd-hda-intel

Another desperate idea would be to try the 'model=inv-dmic' option to the snd-hda-intel kernel module as suggested here http://sourceforge.net/mailarchive/m...sg_id=31843256

If that fails, perhaps try emailing Takashi Iwai directly (the address is in the last link). Nobody knows more about snd-hda-intel ;)


All times are GMT -5. The time now is 11:24 AM.