LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-09-2014, 07:41 AM   #1
recan
LQ Newbie
 
Registered: Jan 2014
Distribution: Slackware-x86_14.1
Posts: 19

Rep: Reputation: Disabled
some issues with Slackware 14.1 32 bits xfce


Hi everyone some issues after success installation of slackware 14.1 32 bits xfce for the first time
let start with the sound in skype :
- the sound is working fine only I can't get the microphone working in skype.
- howto enable a applet to control the network , I m using a wired connection
and it worke fine but it i turn off the modem and start slackware , i will not be able to connect to internet , it seems that the modem must be on when the system boot up.

- about resolution in console when the system boot , I tried to use a good resolution in order to read the boot lines but it doesn t work , alawys the resolution in boot is poor


any help plz will be welome
 
Old 02-09-2014, 09:03 AM   #2
rkfb
Member
 
Registered: Oct 2003
Location: Guildford, England
Distribution: slackware
Posts: 303

Rep: Reputation: 41
Quote:
Originally Posted by recan View Post
Hi everyone some issues after success installation of slackware 14.1 32 bits xfce for the first time
let start with the sound in skype :
- the sound is working fine only I can't get the microphone working in skype.
- howto enable a applet to control the network , I m using a wired connection
and it worke fine but it i turn off the modem and start slackware , i will not be able to connect to internet , it seems that the modem must be on when the system boot up.

- about resolution in console when the system boot , I tried to use a good resolution in order to read the boot lines but it doesn t work , alawys the resolution in boot is poor


any help plz will be welome
I think if you look in the skype preferences under audio you can select your microphone there somewhere from a dropdown list.

I would say don't turn off your modem, leave it on. Or switch it on first and wait for it to boot up and connect before starting slackware.

Dugan has some information on setting the console resolution here:

http://duganchen.ca/writings/slackware/setup/
 
1 members found this post helpful.
Old 02-09-2014, 09:04 AM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097
Quote:
Originally Posted by recan View Post
- howto enable a applet to control the network , I m using a wired connection
and it worke fine but it i turn off the modem and start slackware , i will not be able to connect to internet , it seems that the modem must be on when the system boot up.
Try to configure your network with NetworkManager (run netconfig as root and choose the NetworkManager option), then run nm-applet in XFCE.

Quote:
- about resolution in console when the system boot , I tried to use a good resolution in order to read the boot lines but it doesn t work , alawys the resolution in boot is poor
Which video driver do you use?
 
Old 02-09-2014, 09:15 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Quote:
- the sound is working fine only I can't get the microphone working in skype
Have you used 'alsamixer' to check the Capture settings of your sound device? (If this does not seem to work, please post a screenshot of the alsamixer Capture page.

Quote:
- howto enable a applet to control the network , I m using a wired connection
From the email to root titled "Welcome to Linux (Slackware 14.1)!"
Quote:
If you will be using wireless (or even a wired interface), you might
want to let NetworkManager handle your network connections. This is
a choice during the initial installation, but may also be selected
later by rerunning netconfig, or by setting the startup script
to executable (chmod 755 /etc/rc.d/rc.networkmanager). When Network
Manager is used to handle connections, a nice interface is provided
to scan for wireless access points and make changes to the network
configuration. This interface runs automatically with KDE or Xfce.
In fluxbox, the nm-applet program will need to be launched. Other
window managers lack a system tray to display nm-applet, so for those
you might want to look at wicd in /extra, which also provides a nice
GUI tool for connecting to wireless (or wired) networks. For window
managers that do not provide a tray for running programs, start
"wicd-client" to make changes. With NetworkManager or wicd, it's
a good idea to remove any existing network configuration in
/etc/rc.d/rc.inet1.conf first. This can be done by running netconfig
and setting the machine to use loopback. Then, if you're using
NetworkManager run it a second time and select NetworkManager.
Quote:
but it i turn off the modem and start slackware , i will not be able to connect to internet , it seems that the modem must be on when the system boot up
If you set up networking using rc.inet1.conf during initial install, then, as root, 'sh /etc/rc.d/rc.inet1 restart' should activate networking.

Quote:
- about resolution in console when the system boot , I tried to use a good resolution in order to read the boot lines but it doesn t work
The early boot stage video resolution is controlled by the 'vga=' line in /etc/lilo.conf. You can experiment with different resolutions by setting 'vga=ask' in /etc/lilo.conf, rerunning 'lilo' and then rebooting. If you find something that works, you can make the change permanent with a suitable entry in /etc/lilo.conf and rerunning 'lilo'.
Later in the boot stage, the kernel switches to using KMS. The resolution can be set by using the 'video=' option. Full details are found in /usr/src/linux/Documentation/fb/modedb.txt. For initial testing you can append a kernel parameter at boot by hitting TAB and typing something like ' video=1280x1024'. If you find something that works, you can make the change permanent by adding the setting to the 'append=' line in /etc/lilo.conf and rerunning 'lilo'.
 
1 members found this post helpful.
Old 02-09-2014, 09:32 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097
Quote:
Originally Posted by allend View Post
Later in the boot stage, the kernel switches to using KMS. The resolution can be set by using the 'video=' option. Full details are found in /usr/src/linux/Documentation/fb/modedb.txt. For initial testing you can append a kernel parameter at boot by hitting TAB and typing something like ' video=1280x1024'. If you find something that works, you can make the change permanent by adding the setting to the 'append=' line in /etc/lilo.conf and rerunning 'lilo'.
Keep in mind that this will not work with the proprietary drivers from AMD/Nvidia.
 
Old 02-09-2014, 09:39 AM   #6
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Quote:
Keep in mind that this will not work with the proprietary drivers from AMD/Nvidia.
Problems with resolution at boot are often associated with Intel graphics.
 
Old 02-09-2014, 09:46 AM   #7
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097
According to the OP's signature he is using Nvidia. That information may be wrong for this particular machine, though.
 
1 members found this post helpful.
Old 02-09-2014, 11:43 AM   #8
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 737

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Regarding Skype - I have found that it is a tad buggy with capture devices. Often my mic will not work but if I change it to something else, apply, and then change back and apply, then it works. I'm sometimes tempted to tell my Skype friends to just get TeamSpeak which works similarly but flawlessly.
 
1 members found this post helpful.
Old 02-09-2014, 01:32 PM   #9
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 4,681

Rep: Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240
To get an applet to manage your network, run as root "netconfig", choose NetworkManager, run as root "/etc/rc.d/rc.networkmanager restart" then if the applet doesn't show run as a regular user "nm-applet".
 
1 members found this post helpful.
Old 02-09-2014, 04:11 PM   #10
recan
LQ Newbie
 
Registered: Jan 2014
Distribution: Slackware-x86_14.1
Posts: 19

Original Poster
Rep: Reputation: Disabled
Hi , First thank you for everyone have read my post and specially for all whom answered , this wonderful really
almost my issues are solved by the genius instructions found in yours posts only one not yet
yes it is microphone in skype may be this will help to find solutions

skype.png

alsa.png
 
Old 02-09-2014, 05:59 PM   #11
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Have you tried setting the microphone to 'HDA Intel PCH, ALC887-VD Analog (hw:0.0)' or 'HDA Intel PCH, ALC887-VD Alt Analog (hw:0.2)' in Skype?

PS- Reported to be working by Srinivas Gowda here. http://askubuntu.com/questions/16372...rking-in-skype
 
Old 02-09-2014, 06:13 PM   #12
recan
LQ Newbie
 
Registered: Jan 2014
Distribution: Slackware-x86_14.1
Posts: 19

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by allend View Post
Have you tried setting the microphone to 'HDA Intel PCH, ALC887-VD Analog (hw:0.0)' or 'HDA Intel PCH, ALC887-VD Alt Analog (hw:0.2)' in Skype?

PS- Reported to be working by Srinivas Gowda here. http://askubuntu.com/questions/16372...rking-in-skype
thank you , yes i tried all what i can in skype option for microphone but not working alos the section for recording on alsa project
arecord -vv -fdat foo.wav

thank you again
 
Old 02-09-2014, 07:45 PM   #13
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Your screenshot for alsamixer in post#10 showed the output device settings. How about the Capture settings? (Hit F4
)
 
Old 02-10-2014, 03:18 AM   #14
recan
LQ Newbie
 
Registered: Jan 2014
Distribution: Slackware-x86_14.1
Posts: 19

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by allend View Post
your screenshot for alsamixer in post#10 showed the output device settings. How about the capture settings? (hit f4
)
capture.png
 
Old 02-10-2014, 08:57 AM   #15
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Everything looks like it should be working, so I am getting desperate for ideas.

I did find this that seems to be very similar to your predicament. http://forum.kde.org/viewtopic.php?f=19&t=110552
You could try the 'model=auto' option to the snd-hda-intel kernel module suggested there. For Slackware specific advice see http://docs.slackware.com/howtos:har..._snd-hda-intel

Another desperate idea would be to try the 'model=inv-dmic' option to the snd-hda-intel kernel module as suggested here http://sourceforge.net/mailarchive/m...sg_id=31843256

If that fails, perhaps try emailing Takashi Iwai directly (the address is in the last link). Nobody knows more about snd-hda-intel

Last edited by allend; 02-10-2014 at 09:04 AM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cryptography... what's difference between 8bits / 16 bits / 32 bits/ 64 bits/128bits? ybpark81 Linux - Security 4 02-19-2012 09:38 AM
Button of Xchat on Slackware 13.1 in 64 bits and 32 bits Laodiceans Slackware 1 06-21-2010 06:32 PM
[SOLVED] Slackware64 KDE -- seeing bits of Xfce laying about koenigdavidmj Slackware 1 10-21-2009 12:47 AM
When will official Slackware 64 bits comes ? carlos.macleod Slackware 7 08-29-2005 07:57 AM


All times are GMT -5. The time now is 04:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration