LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware64 -current xfce4-session (http://www.linuxquestions.org/questions/slackware-14/slackware64-current-xfce4-session-4175463056/)

tuxbg 05-22-2013 03:38 PM

Slackware64 -current xfce4-session
 
After upgrade xfce4-session-4.10.1 i don't have reboot and shutdown buttons from Action Buttons applet.They are disabled.

hitest 05-22-2013 03:41 PM

Quote:

Originally Posted by tuxbg (Post 4956784)
After upgrade xfce4-session-4.10.1 i don't have reboot and shutdown buttons from Action Buttons applet.They are disabled.

The same has happened here. I went and checked /etc/group and nothing looks awry. I'm now shutting down using a terminal.

tuxbg 05-22-2013 03:44 PM

I recompile xfce4-session-4.10 and all works.But can't get 4.10.1 version to work

Stephen Morgan 05-22-2013 04:29 PM

I had what sounds like the same problem, but it was a problem with slim, rather than XFCE, and was solved by removing "ck-launch-session" from ~/.xinitrc

Ahau 05-22-2013 04:59 PM

xfce4-session 4.10.1 added support for systemd. This support is optional and the package will build without systemd but it sounds like there might be a few wrinkles that still need to settle out. For now at least, you need to add --disable-systemd to the configure options, as described here: http://forum.xfce.org/viewtopic.php?id=8041

That will restore the missing buttons and you don't need to run outside the consolekit session.

tuxbg 05-22-2013 11:16 PM

Big thanks.That solved my problem.Dear Pat and Slackware team you need to recompile xfce4-session with --disable-systemd to work properly.

hitest 05-23-2013 08:09 AM

Quote:

Originally Posted by tuxbg (Post 4957002)
Big thanks.That solved my problem.Dear Pat and Slackware team you need to recompile xfce4-session with --disable-systemd to work properly.

I find it odd that the good people at XFce have put this default option in their new release. I am plagued by this issue on two Slackware-current(32 bit) stations.

tomtomjkw 05-24-2013 08:04 AM

Recompiled package is now available, thx Pat.

hitest 05-24-2013 08:06 AM

Quote:

Originally Posted by tomtomjkw (Post 4958116)
Recompiled package is now available, thx Pat.

Thank you kindly Pat! Shut down is now working properly again! :)

Code:

Fri May 24 04:18:18 UTC 2013
ap/slackpkg-2.82.0-noarch-9.tgz:  Rebuilt.
  Set DOWNLOAD_ALL=on in slackpkg.conf by default to avoid script failures
  caused by programs (wget is an example) that may require library updates.
  Without this option, a program might be needed again before the supporting
  libraries have been upgraded.
d/slacktrack-2.15-i486-1.txz:  Upgraded.
x/fontconfig-2.10.93-i486-1.txz:  Upgraded.
xfce/xfce4-session-4.10.1-i486-2.txz:  Rebuilt.
  Recompiled with --disable-systemd.


the3dfxdude 05-25-2013 04:59 PM

I had seen that systemd patch on xfce4-session git, but I hadn't realized that the detection was so poor, pretty much anything will match systemd=enabled regardless. The configure disable switch will work until console-kit stops working (since it is unmaintained...wonder who let that happen?) or the xfce folks decide it's no longer needed. I'm looking for alternatives and have one brewing. Anyone has an idea, lets talk.


All times are GMT -5. The time now is 07:42 AM.