LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-22-2013, 04:38 PM   #1
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 249

Rep: Reputation: Disabled
Slackware64 -current xfce4-session


After upgrade xfce4-session-4.10.1 i don't have reboot and shutdown buttons from Action Buttons applet.They are disabled.
 
Old 05-22-2013, 04:41 PM   #2
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,249

Rep: Reputation: 574Reputation: 574Reputation: 574Reputation: 574Reputation: 574Reputation: 574
Question

Quote:
Originally Posted by tuxbg View Post
After upgrade xfce4-session-4.10.1 i don't have reboot and shutdown buttons from Action Buttons applet.They are disabled.
The same has happened here. I went and checked /etc/group and nothing looks awry. I'm now shutting down using a terminal.
 
Old 05-22-2013, 04:44 PM   #3
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 249

Original Poster
Rep: Reputation: Disabled
I recompile xfce4-session-4.10 and all works.But can't get 4.10.1 version to work
 
Old 05-22-2013, 05:29 PM   #4
Stephen Morgan
Member
 
Registered: Feb 2011
Location: England
Distribution: Slackware
Posts: 154

Rep: Reputation: 15
I had what sounds like the same problem, but it was a problem with slim, rather than XFCE, and was solved by removing "ck-launch-session" from ~/.xinitrc
 
Old 05-22-2013, 05:59 PM   #5
Ahau
Member
 
Registered: Jun 2011
Location: USA
Distribution: Porteus, Slackware
Posts: 58

Rep: Reputation: 19
xfce4-session 4.10.1 added support for systemd. This support is optional and the package will build without systemd but it sounds like there might be a few wrinkles that still need to settle out. For now at least, you need to add --disable-systemd to the configure options, as described here: http://forum.xfce.org/viewtopic.php?id=8041

That will restore the missing buttons and you don't need to run outside the consolekit session.

Last edited by Ahau; 05-22-2013 at 06:01 PM.
 
2 members found this post helpful.
Old 05-23-2013, 12:16 AM   #6
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 249

Original Poster
Rep: Reputation: Disabled
Big thanks.That solved my problem.Dear Pat and Slackware team you need to recompile xfce4-session with --disable-systemd to work properly.

Last edited by tuxbg; 05-23-2013 at 12:27 AM. Reason: Need Pat to recompile package.
 
1 members found this post helpful.
Old 05-23-2013, 09:09 AM   #7
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,249

Rep: Reputation: 574Reputation: 574Reputation: 574Reputation: 574Reputation: 574Reputation: 574
Quote:
Originally Posted by tuxbg View Post
Big thanks.That solved my problem.Dear Pat and Slackware team you need to recompile xfce4-session with --disable-systemd to work properly.
I find it odd that the good people at XFce have put this default option in their new release. I am plagued by this issue on two Slackware-current(32 bit) stations.
 
Old 05-24-2013, 09:04 AM   #8
tomtomjkw
Member
 
Registered: Jan 2008
Distribution: Slackware64-current
Posts: 127

Rep: Reputation: 31
Recompiled package is now available, thx Pat.
 
1 members found this post helpful.
Old 05-24-2013, 09:06 AM   #9
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,249

Rep: Reputation: 574Reputation: 574Reputation: 574Reputation: 574Reputation: 574Reputation: 574
Quote:
Originally Posted by tomtomjkw View Post
Recompiled package is now available, thx Pat.
Thank you kindly Pat! Shut down is now working properly again!

Code:
Fri May 24 04:18:18 UTC 2013
ap/slackpkg-2.82.0-noarch-9.tgz:  Rebuilt.
  Set DOWNLOAD_ALL=on in slackpkg.conf by default to avoid script failures
  caused by programs (wget is an example) that may require library updates.
  Without this option, a program might be needed again before the supporting
  libraries have been upgraded.
d/slacktrack-2.15-i486-1.txz:  Upgraded.
x/fontconfig-2.10.93-i486-1.txz:  Upgraded.
xfce/xfce4-session-4.10.1-i486-2.txz:  Rebuilt.
  Recompiled with --disable-systemd.
 
Old 05-25-2013, 05:59 PM   #10
the3dfxdude
Member
 
Registered: May 2007
Posts: 331

Rep: Reputation: 100Reputation: 100
I had seen that systemd patch on xfce4-session git, but I hadn't realized that the detection was so poor, pretty much anything will match systemd=enabled regardless. The configure disable switch will work until console-kit stops working (since it is unmaintained...wonder who let that happen?) or the xfce folks decide it's no longer needed. I'm looking for alternatives and have one brewing. Anyone has an idea, lets talk.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xfce4-power-manager crashes on resume from suspend (Slackware64 14.0) ruario Slackware 2 04-03-2013 09:31 PM
[SOLVED] Slackware64-current 1st April, 2010: Black screen on leaving KDE session gargamel Slackware 2 04-01-2010 04:08 AM
Updating from Slackware64-current to Slackware64 13. glore2002 Slackware 4 08-28-2009 07:50 PM
how can i have xfce4 in my session when i login? mjalalynia Linux - Desktop 14 07-21-2008 01:27 AM
xfce4-session fails to save session ! OneManArmy Debian 0 12-10-2004 03:14 PM


All times are GMT -5. The time now is 02:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration