LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 14 with Intel i810 video (http://www.linuxquestions.org/questions/slackware-14/slackware-14-with-intel-i810-video-4175447472/)

enine 01-27-2013 09:19 PM

Slackware 14 with Intel i810 video
 
Hello all,
I'm trying to install Slackware 14 on an older laptop of mine and am running into the same problem I had with Slackware 12. The fix listed in this thread is to reinstall the i810 driver over the Intel driver but I can't find the i810 driver in 14. Any suggestions?

Didier Spaier 01-28-2013 02:34 AM

here. Beware, it's 6 years old now though. Guess Pat does not ship that anymore for a reason...

allend 01-28-2013 02:59 AM

You do not describe your problem which does not help.
There is the i810 kernel module in Slackware 14.0 and your device is supported by the intel driver in Xorg. There are many options available for the i810 for the intel driver in Xorg.
From 'man intel'
Quote:

The driver supports hardware accelerated 3D via the Direct Rendering Infrastructure (DRI), but only in depth 16 for the i810/i815

enine 01-28-2013 05:10 AM

when I try to start x it begins to load the window manager then fades to white. The problem in Slackware 12 was the -intel driver package did this but the -i810 driver package works.

allend 01-28-2013 05:23 AM

Are you trying to start KDE?
From CHANGES_AND_HINTS.TXT for Slackware 14.0
Quote:

Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection
With the changes in the kernel to enable KMS, Intel graphics supported by i810 took a hit in functionality. As I recall, ~25,000 lines of code was dropped from the driver due to incompatibility with KMS. Do not expect to get the same level of functionality that you had in Slackware 12.

Didier Spaier 01-28-2013 05:23 AM

Until you find a more specific solution, you could try to use the VESA X driver. Just do this as root:
Code:

cp /etc/X11/xorg.conf-vesa /etc/X11/xorg-vesa.conf
and restart X.

allend 01-28-2013 05:25 AM

I think that should read
Code:

cp /etc/X11/xorg.conf-vesa /etc/X11/xorg.conf

Didier Spaier 01-28-2013 05:37 AM

Quote:

Originally Posted by allend (Post 4878926)
I think that should read
Code:

cp /etc/X11/xorg.conf-vesa /etc/X11/xorg.conf

As long as the name has the .conf extension it will be read by the X server. I write it that way to remind me which video driver is set in that file, but of course that is not mandatory.

allend 01-28-2013 05:39 AM

Thanks for that Didier!

Didier Spaier 01-28-2013 05:37 PM

Shame on me, I was wrong!
 
Well, in fact half-wrong.

(1) any filename ending in .conf in /etc/X11/xorg.conf.d will be read by the X server.
(2) but in /etc/X11/ only xorg.conf will be read.

I should have RTFM as man xorg.conf says that under the DESCRIPTION title:
" Xorg uses a configuration file called xorg.conf and files ending in the suffix .conf from the directory xorg.conf.d for its initial setup."

So you could use either one of these commands:
Code:

cp /etc/X11/xorg.conf-vesa /etc/X11/xorg.conf
cp /etc/X11/xorg.conf-vesa /etc/X11/xorg.conf.d/xorg-vesa.conf


Arcosanti 02-05-2013 07:42 PM

One possibility depending on how old your display driver is, is to see if the i915 driver will work. I have an Intel GM855 display and i915 is what driver is in use on my system running Slackware 13.37. I understand that i915 fixes a lot of the problems that were present in the earlier i8xx drivers.


All times are GMT -5. The time now is 11:24 PM.