LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-27-2013, 10:19 PM   #1
enine
Member
 
Registered: Nov 2003
Distribution: Slackware 14.1
Posts: 816
Blog Entries: 3

Rep: Reputation: 91
Slackware 14 with Intel i810 video


Hello all,
I'm trying to install Slackware 14 on an older laptop of mine and am running into the same problem I had with Slackware 12. The fix listed in this thread is to reinstall the i810 driver over the Intel driver but I can't find the i810 driver in 14. Any suggestions?
 
Old 01-28-2013, 03:34 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,528

Rep: Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187
here. Beware, it's 6 years old now though. Guess Pat does not ship that anymore for a reason...
 
Old 01-28-2013, 03:59 AM   #3
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,485

Rep: Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856
You do not describe your problem which does not help.
There is the i810 kernel module in Slackware 14.0 and your device is supported by the intel driver in Xorg. There are many options available for the i810 for the intel driver in Xorg.
From 'man intel'
Quote:
The driver supports hardware accelerated 3D via the Direct Rendering Infrastructure (DRI), but only in depth 16 for the i810/i815
 
Old 01-28-2013, 06:10 AM   #4
enine
Member
 
Registered: Nov 2003
Distribution: Slackware 14.1
Posts: 816
Blog Entries: 3

Original Poster
Rep: Reputation: 91
when I try to start x it begins to load the window manager then fades to white. The problem in Slackware 12 was the -intel driver package did this but the -i810 driver package works.
 
Old 01-28-2013, 06:23 AM   #5
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,485

Rep: Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856
Are you trying to start KDE?
From CHANGES_AND_HINTS.TXT for Slackware 14.0
Quote:
Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection
With the changes in the kernel to enable KMS, Intel graphics supported by i810 took a hit in functionality. As I recall, ~25,000 lines of code was dropped from the driver due to incompatibility with KMS. Do not expect to get the same level of functionality that you had in Slackware 12.
 
Old 01-28-2013, 06:23 AM   #6
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,528

Rep: Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187
Until you find a more specific solution, you could try to use the VESA X driver. Just do this as root:
Code:
cp /etc/X11/xorg.conf-vesa /etc/X11/xorg-vesa.conf
and restart X.
 
Old 01-28-2013, 06:25 AM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,485

Rep: Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856
I think that should read
Code:
cp /etc/X11/xorg.conf-vesa /etc/X11/xorg.conf
 
Old 01-28-2013, 06:37 AM   #8
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,528

Rep: Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187
Quote:
Originally Posted by allend View Post
I think that should read
Code:
cp /etc/X11/xorg.conf-vesa /etc/X11/xorg.conf
As long as the name has the .conf extension it will be read by the X server. I write it that way to remind me which video driver is set in that file, but of course that is not mandatory.
 
1 members found this post helpful.
Old 01-28-2013, 06:39 AM   #9
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,485

Rep: Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856
Thanks for that Didier!
 
Old 01-28-2013, 06:37 PM   #10
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,528

Rep: Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187
Shame on me, I was wrong!

Well, in fact half-wrong.

(1) any filename ending in .conf in /etc/X11/xorg.conf.d will be read by the X server.
(2) but in /etc/X11/ only xorg.conf will be read.

I should have RTFM as man xorg.conf says that under the DESCRIPTION title:
" Xorg uses a configuration file called xorg.conf and files ending in the suffix .conf from the directory xorg.conf.d for its initial setup."

So you could use either one of these commands:
Code:
cp /etc/X11/xorg.conf-vesa /etc/X11/xorg.conf
cp /etc/X11/xorg.conf-vesa /etc/X11/xorg.conf.d/xorg-vesa.conf

Last edited by Didier Spaier; 01-28-2013 at 06:39 PM.
 
Old 02-05-2013, 08:42 PM   #11
Arcosanti
Member
 
Registered: Apr 2004
Location: Mesa, AZ USA
Distribution: Slackware 13.37 kernel 2.6.39.1 gcc 4.5.2
Posts: 172

Rep: Reputation: 9
One possibility depending on how old your display driver is, is to see if the i915 driver will work. I have an Intel GM855 display and i915 is what driver is in use on my system running Slackware 13.37. I understand that i915 fixes a lot of the problems that were present in the earlier i8xx drivers.
 
Old 07-24-2014, 08:55 PM   #12
enine
Member
 
Registered: Nov 2003
Distribution: Slackware 14.1
Posts: 816
Blog Entries: 3

Original Poster
Rep: Reputation: 91
Quote:
Originally Posted by allend View Post
Are you trying to start KDE?
From CHANGES_AND_HINTS.TXT for Slackware 14.0

Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection

With the changes in the kernel to enable KMS, Intel graphics supported by i810 took a hit in functionality. As I recall, ~25,000 lines of code was dropped from the driver due to incompatibility with KMS. Do not expect to get the same level of functionality that you had in Slackware 12.
I'm doing a cleanup of my closet and dug out this old laptop and this fix got it working
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel i810 video mode to use at boot prompt for high res video in Xwin will_kranz Linux - Newbie 0 02-17-2009 11:07 AM
Where to find Intel i810 video drivers enine Slackware 4 02-27-2008 02:43 PM
i810 & i915 blank screen Intel Corporation 82845G onboard video davimint Slackware 30 06-28-2007 04:58 AM
No S-Video Signal on Intel i810 eman45008 Ubuntu 1 05-31-2006 08:13 AM
alsa / slackware current / Intel i810 hjles Slackware 14 01-25-2005 07:11 AM


All times are GMT -5. The time now is 03:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration