LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 12, HAL automount (http://www.linuxquestions.org/questions/slackware-14/slackware-12-hal-automount-566948/)

arubin 07-05-2007 05:21 PM

Slackware 12, HAL automount
 
I have just installed slackware 12 and cannot get the hang of Hal.

I plug in a usb drive and the box comes up asking what I want to do with it.

What I want to do is automount and nothing else, no new boxes, no konquerer.

How do I do this?

Where is a good Hal FAQ

TIA

dive 07-05-2007 06:38 PM

You should be able to choose 'do nothing' and tick the box to always do this. It's a kde feature rather than Hal.

There are also options in control centre to put device icons on the desktop when mounted.

It's possible to use a combination of Hal and Autofs so it's possible to have the choice of using command line or konqueror.

Boow 07-05-2007 06:46 PM

I dont know if kde's automounter will mount the cd without opening konqueror. I think ivman will function the way you want but you have to disable kde's automounting. Maybe someone that has ivman installed in kde 3.5.7 can tell you better than I can.

arubin 07-06-2007 02:05 AM

'Do nothing' leaves the device unmounted. I have the option set so that the device icon appears but it is still unmounted.

rworkman 07-06-2007 02:12 AM

HAL doesn't actually mount anything; for lack of a better way to put it, HAL simply provides (in a standardized format) information about the hardware and what actions are potentially allowed, and then something else can use dbus methods (pending proper permissions) to actually *do* something with/to the hardware.

For what you're trying to do, I believe you'll want to investigate ivman and/or pmount (though there may very well be other options). http://slackbuilds.org has ivman and pmount scripts for 11.0, but they have not been tested or approved for use on 12.0, so caveat emptor.

Datamike 07-06-2007 06:38 AM

I don't think there is a good FAQ for HAL yet, nor much in terms of troubleshooting or tutorials on how to use it. I'm also having trouble getting into terms with HAL.

For example, just inserting and getting my CDROM mounted, is a problem. I do get the box asking what to do with it. But when I click that I want browse it, konqueror launches and I get a weird error message:

A security policy in place prevents this sender from sending this message to this recipient: see message bus configuration file (rejected message had
interface "org.freedesktop.Hal.Device.Volume"
member "Mount" error name "(unset)"
destination "org.freedesktop.Hal")


Anyone have a clue what this means?

arubin 07-06-2007 06:42 AM

I do not know if this will help your problem but it may be worth checking that the cdrom line is commented out in fstab and that you are joined to the cdrom group.

ludist 07-06-2007 06:53 AM

Not tested, but I think you should be member of plugdev group..

info taken from CHANGES_AND_HINTS.TXT

bmfan 07-06-2007 08:15 AM

Quote:

Originally Posted by Datamike
I don't think there is a good FAQ for HAL yet, nor much in terms of troubleshooting or tutorials on how to use it. I'm also having trouble getting into terms with HAL.

For example, just inserting and getting my CDROM mounted, is a problem. I do get the box asking what to do with it. But when I click that I want browse it, konqueror launches and I get a weird error message:

A security policy in place prevents this sender from sending this message to this recipient: see message bus configuration file (rejected message had
interface "org.freedesktop.Hal.Device.Volume"
member "Mount" error name "(unset)"
destination "org.freedesktop.Hal")


Anyone have a clue what this means?

It means you didnt add yourself to the 'plugdev' and 'cdrom' groups
" Users in the "plugdev" or "cdrom" group will be able to use such devices on the desktop without the need to mount/umount them manually."

Datamike 07-07-2007 12:39 AM

Quote:

Originally Posted by bmfan
It means you didnt add yourself to the 'plugdev' and 'cdrom' groups
" Users in the "plugdev" or "cdrom" group will be able to use such devices on the desktop without the need to mount/umount them manually."

I did actually, but I noticed that my HAL has the same problem as my Apache; reloading or restarting doesn't help. Whenever I changed some settings, I have to restart apache, using the stop-start sequence. With HAL, even that did not help. I have to reboot the whole computer. Very strange. Anyone else have this issue?

But yeah, now it works. Thanks for the help :)

Are there more groups for this purpose? E.g. if I want to automount an usb stick or an external usb drive, etc. Any groups I should add myself to accomplish this?

rworkman 07-07-2007 01:46 AM

Quote:

Originally Posted by Datamike
I did actually, but I noticed that my HAL has the same problem as my Apache; reloading or restarting doesn't help. Whenever I changed some settings, I have to restart apache, using the stop-start sequence. With HAL, even that did not help. I have to reboot the whole computer. Very strange. Anyone else have this issue?

Yes and no. Yes, in that restarting hald won't solve it. No, in that restarting dbus will. That's documented in CHANGES_AND_HINTS.TXT, by the way.

Quote:

Are there more groups for this purpose? E.g. if I want to automount an usb stick or an external usb drive, etc. Any groups I should add myself to accomplish this?
plugdev and cdrom should cover it.

Datamike 07-07-2007 02:34 AM

Quote:

Originally Posted by rworkman
Yes and no. Yes, in that restarting hald won't solve it. No, in that restarting dbus will. That's documented in CHANGES_AND_HINTS.TXT, by the way.

And not surprisingly, I have read the said document, at least the bits about HAL. When I said restarting HAL, I meant restarting DBUS. Sorry for the confusion. For me, the difference isn't so clear.

Reloading (as in /etc/rc.d/rc.messagebus reload) does not help. Neither does stopping and starting. Actually, automounting stops responding if I stop and start again. It's very peculiar.

gargamel 07-07-2007 03:43 PM

Not sure, but maybe you need to re-login after adding yourself to the relevant groups, as your login session reads the groups your user belongs to at login time... It shouldn't be necessary to reboot, but it may be necessary to restart D-BUS and/or HAL.

gargamel

Tux-Slack 07-07-2007 05:18 PM

Quote:

Originally Posted by bmfan
It means you didnt add yourself to the 'plugdev' and 'cdrom' groups
" Users in the "plugdev" or "cdrom" group will be able to use such devices on the desktop without the need to mount/umount them manually."

This works, if you have in fstab the option users on that device.
But what about USB storage devices? Where do I need to add the users?

happyslacker 07-17-2007 02:39 PM

Don't add users - it is unnecessary.

How to use USB flash drive with Slackware Linux

First turn on HAL and D-BUS (if you don't):
Code:

chmod +x /etc/rc.d/rc.messagebus
/etc/rc.d/rc.messagebus start
chmod +x /etc/rc.d/rc.hald
/etc/rc.d/rc.hald start

and then install package installpkg vsupdfstab-0.1-noarch-0.tgz:

Maybe you must restart KDE.


All times are GMT -5. The time now is 08:25 PM.