LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Settup PPP without KPPP (http://www.linuxquestions.org/questions/slackware-14/settup-ppp-without-kppp-266515/)

ibanez862 12-14-2004 10:57 PM

Settup PPP without KPPP
 
Any one know how I can setup ppp with a dialout account that uses dynamic IP addresses? I would rather not use kppp because that would force me to install kde and i'd rather not do that. I tried the ppp config tool and everything connected but when I try to go to a website or try to log into chat it acts as though its not online. Any suggestions?

masand 12-14-2004 11:14 PM

hi there

try the command line tool

wvdial

man wvdial will help u more on this

regards

sh1ft 12-14-2004 11:30 PM

Why not just read up on the docs for ppp in linux or the man pages and configure the conf. pages in /etc manually?


That is the slackware way after all :p

Ipolit 12-15-2004 02:40 AM

I'm doing it manually
you need two scripts, here are my:
/etc/ppp/btc
'' ATZ
OK ATDP,0134200
CONNECT ''
ogin: impuls
word: infotel

/etc/ppp/ppp-btc
pppd connect "/usr/sbin/chat -v -f /etc/ppp/btk" /dev/ttyLT0 38400 lock \
-detach crtscts modem defaultroute noipdefault ipcp-accept-local \
ipcp-accept-remote persist demand holdoff 10

NB: the /dev/ttyLTO is my modem device - winmodem
normally it should be /dev/ttyS0
you must specify a DNS in /etc/resolv.conf
the easiest way is to write there
nameserver 127.0.0.1 and to start named on your computer
option demand means that the connection will be created when you make request to internet. You can remove it, if you will not use the modem all the time.

there is a pppsetup command, but it has never worked for me fine.

Ipolit 12-15-2004 02:44 AM

change K to C in the second scrit
pppd connect "/usr/sbin/chat -v -f /etc/ppp/btc" /dev/ttyLT0 38400 lock \

JohnKFT 12-15-2004 03:36 AM

If you do not want to fiddle with scripts I agree with masand - wvdial seems simple and reliable, and easy to set up multiple ISP connections, programs to run on shutdown and so on. I run it in a small terminal in the bottom corner of the screen so it also shows me what is happening, tells me the IP addresses and enables me to disconnect simply by closing the terminal. The configuration file is a model of clarity.

chopp 12-15-2004 10:36 AM

I found just the opposite. Wvdial didn't work for me at all for some reason.
I also didn't want to use kppp (fluxbox is my choice) I used pppsetup, and the only changes I had to make were changing my modem from ttyS0 to ttySHCF0 in both /etc/ppp/options and options.demand.

Worked just fine.

chopp

ibanez862 12-15-2004 08:34 PM

Thanks for all the suggestions! I'll try them all and post my results. :)

gnashley 12-15-2004 11:57 PM

You might try this:
http://amigolinux.org/download/scripts/ispsetup1.2
This is pppsetup hacked to set up dynamic DNS and only asks for your isp info, port location of modem and phone#.

Or just use ppp, but after setup add 'usepeerdns' to the options file, and put a ping in ip-up for every few minutes to keep the connection up.

d00msweek 12-16-2004 05:33 AM

What should I put in the chat script so that it will automatically redial if the line is busy?

tigre_blanca 12-16-2004 09:48 AM

you can just load and run gnome-ppp. It is similar to kppp.

ebit 12-17-2004 06:09 AM

I use chestnut-dialer, found it on sourceforge. Works fine for me.

RockmanExe 12-17-2004 06:00 PM

also check yawmppp it looks pretty cool as a small thin bar

Cheers

ibanez862 12-17-2004 09:04 PM

Alright I'v tried everything but wvdial so far and everything connects just fine (although i have to log into root to connect). But still I can't go to any websites or anything. Would this have to do with permisions? And if so what group would I have to add my user to in order to browse the web?

Ipolit 12-18-2004 03:29 AM

DNS problem perhaps
or if you're connected to a network and have a default gateway it's trying to go through it. You should
ifconfig eth0 down and then connect via modem
As I said before, start named on your computer and put in
/etc/resolv.conf
nameserver 127.0.0.1


All times are GMT -5. The time now is 11:17 PM.