LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-14-2004, 11:57 PM   #1
ibanez862
LQ Newbie
 
Registered: Dec 2004
Distribution: Debian Etch
Posts: 14

Rep: Reputation: 0
Settup PPP without KPPP


Any one know how I can setup ppp with a dialout account that uses dynamic IP addresses? I would rather not use kppp because that would force me to install kde and i'd rather not do that. I tried the ppp config tool and everything connected but when I try to go to a website or try to log into chat it acts as though its not online. Any suggestions?
 
Old 12-15-2004, 12:14 AM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi there

try the command line tool

wvdial

man wvdial will help u more on this

regards
 
Old 12-15-2004, 12:30 AM   #3
sh1ft
Member
 
Registered: Feb 2004
Location: Ottawa, Ontario, Can
Distribution: Slackware, ubuntu
Posts: 391

Rep: Reputation: 31
Why not just read up on the docs for ppp in linux or the man pages and configure the conf. pages in /etc manually?


That is the slackware way after all
 
Old 12-15-2004, 03:40 AM   #4
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 293

Rep: Reputation: 31
I'm doing it manually
you need two scripts, here are my:
/etc/ppp/btc
'' ATZ
OK ATDP,0134200
CONNECT ''
ogin: impuls
word: infotel

/etc/ppp/ppp-btc
pppd connect "/usr/sbin/chat -v -f /etc/ppp/btk" /dev/ttyLT0 38400 lock \
-detach crtscts modem defaultroute noipdefault ipcp-accept-local \
ipcp-accept-remote persist demand holdoff 10

NB: the /dev/ttyLTO is my modem device - winmodem
normally it should be /dev/ttyS0
you must specify a DNS in /etc/resolv.conf
the easiest way is to write there
nameserver 127.0.0.1 and to start named on your computer
option demand means that the connection will be created when you make request to internet. You can remove it, if you will not use the modem all the time.

there is a pppsetup command, but it has never worked for me fine.
 
Old 12-15-2004, 03:44 AM   #5
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 293

Rep: Reputation: 31
change K to C in the second scrit
pppd connect "/usr/sbin/chat -v -f /etc/ppp/btc" /dev/ttyLT0 38400 lock \
 
Old 12-15-2004, 04:36 AM   #6
JohnKFT
Member
 
Registered: Aug 2003
Location: NW Scotland
Distribution: Slackware 10
Posts: 169

Rep: Reputation: 30
If you do not want to fiddle with scripts I agree with masand - wvdial seems simple and reliable, and easy to set up multiple ISP connections, programs to run on shutdown and so on. I run it in a small terminal in the bottom corner of the screen so it also shows me what is happening, tells me the IP addresses and enables me to disconnect simply by closing the terminal. The configuration file is a model of clarity.
 
Old 12-15-2004, 11:36 AM   #7
chopp
Member
 
Registered: Sep 2003
Location: AB. Canada
Distribution: Slackware
Posts: 126

Rep: Reputation: 16
I found just the opposite. Wvdial didn't work for me at all for some reason.
I also didn't want to use kppp (fluxbox is my choice) I used pppsetup, and the only changes I had to make were changing my modem from ttyS0 to ttySHCF0 in both /etc/ppp/options and options.demand.

Worked just fine.

chopp
 
Old 12-15-2004, 09:34 PM   #8
ibanez862
LQ Newbie
 
Registered: Dec 2004
Distribution: Debian Etch
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks for all the suggestions! I'll try them all and post my results.
 
Old 12-16-2004, 12:57 AM   #9
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,772

Rep: Reputation: 478Reputation: 478Reputation: 478Reputation: 478Reputation: 478
You might try this:
http://amigolinux.org/download/scripts/ispsetup1.2
This is pppsetup hacked to set up dynamic DNS and only asks for your isp info, port location of modem and phone#.

Or just use ppp, but after setup add 'usepeerdns' to the options file, and put a ping in ip-up for every few minutes to keep the connection up.
 
Old 12-16-2004, 06:33 AM   #10
d00msweek
Member
 
Registered: Jan 2004
Location: Cebu City, Philippines
Distribution: Slackware 10,Gentoo 2005.1,LFS
Posts: 92

Rep: Reputation: 15
What should I put in the chat script so that it will automatically redial if the line is busy?
 
Old 12-16-2004, 10:48 AM   #11
tigre_blanca
LQ Newbie
 
Registered: Aug 2003
Location: Colorado
Distribution: mandrake 2006
Posts: 1

Rep: Reputation: 0
you can just load and run gnome-ppp. It is similar to kppp.
 
Old 12-17-2004, 07:09 AM   #12
ebit
Member
 
Registered: Jul 2004
Distribution: Slackware 10.1
Posts: 39

Rep: Reputation: 15
I use chestnut-dialer, found it on sourceforge. Works fine for me.
 
Old 12-17-2004, 07:00 PM   #13
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Rep: Reputation: 30
also check yawmppp it looks pretty cool as a small thin bar

Cheers
 
Old 12-17-2004, 10:04 PM   #14
ibanez862
LQ Newbie
 
Registered: Dec 2004
Distribution: Debian Etch
Posts: 14

Original Poster
Rep: Reputation: 0
Alright I'v tried everything but wvdial so far and everything connects just fine (although i have to log into root to connect). But still I can't go to any websites or anything. Would this have to do with permisions? And if so what group would I have to add my user to in order to browse the web?
 
Old 12-18-2004, 04:29 AM   #15
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 293

Rep: Reputation: 31
DNS problem perhaps
or if you're connected to a network and have a default gateway it's trying to go through it. You should
ifconfig eth0 down and then connect via modem
As I said before, start named on your computer and put in
/etc/resolv.conf
nameserver 127.0.0.1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KPPP vs ppp-go in slackware pj320 Linux - Networking 1 07-26-2005 07:24 PM
kppp mdk10 ppp exit status 10 "CONNECT 44000/LAPM/" geek745 Linux - Networking 2 09-10-2004 12:04 AM
Kppp how to set in Dial up Script for PPP Keynote Red Hat 7 03-16-2004 05:02 PM
more reliable ppp dialup client than kppp? randomx Linux - Software 3 10-27-2003 10:45 PM
Apache settup failure poortl9109 Linux - Software 6 12-24-2002 06:56 AM


All times are GMT -5. The time now is 01:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration