LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Setting framebuffer console refresh rate on Slackware 12.1/GeForce 8 (http://www.linuxquestions.org/questions/slackware-14/setting-framebuffer-console-refresh-rate-on-slackware-12-1-geforce-8-a-660201/)

ErV 08-03-2008 06:50 PM

Setting framebuffer console refresh rate on Slackware 12.1/GeForce 8
 
Hello.

I've recently decided to use framebuffer (i.e. non-text-based) console on slackware 12.1 and I'd like to set refresh rate to something different than 60hz (i'd like to use 1024x768 85 hz).

System info:
1) Slackware 12.1
2)GeForce 8400.
3) 2.6.25-7 kernel, custom built.
CONFIG_FB, CONFIG_FB_VESA is "y"
CONFIG_FB_UVESA is not set,
CONFIG_FB_NVIDIA is "m".
4) in /etc/lilo.conf vga line is "vga=773", which sets 1024x768 256colors mode, but (unfortunately) with 60hz refresh rate.
5) 32bit system.
6) NVIDIA_linux-173.14.09 proprietary driver.

What I've tried:
1) tried to use fbset and searched for some kind of howto for this problem, looked for nvidia-related info in HOWTO-framebuffer.

Problems:
1) 1024x768-85 mode is not described in /etc/fb.modes (could be fixed by videogen, I suppose?)
2) fbset -a 1024x768-70 (should be better than 60 hz, anyway, and this mode is described in fb.modules) doesn't do anything - console video mode doesn't change. Doesn't print error messages either.
3) There doesn't seem to be any framebuffer related ("lsmod |grep fb") kernel modules loaded.
4) there is nvidiafb module available, but it isn't possible to load it (fails with "unknown symbol" error message). It is said that this module conflicts with proprietary drivers.
5) HOWTO-framebuffer doesn't mention anything about nvidia.

Question:
How do I set 1024x768-85 module? Using quick google search ("fbset GeForce 8", etc) I haven't found some kind of howto for my videocard and fbset.

Daedra 08-04-2008 01:51 AM

Well first thing is you can't use the nvidiafb with the nividia drivers. They are incompatible. You can try uvesafb, it has refresh rate adjustments and it works really well. here is the official website http://dev.gentoo.org/~spock/projects/uvesafb/ and here is a howto type post I made a while ago. Keep in mind you will have to recompile your kernrel to get this to work. http://www.linuxquestions.org/questi...hlight=uvesafb

ErV 08-04-2008 07:12 AM

Quote:

Originally Posted by Daedra (Post 3235844)
Well first thing is you can't use the nvidiafb with the nividia drivers. They are incompatible.

I know that, see "Problems" #4.

Quote:

Originally Posted by Daedra (Post 3235844)
You can try uvesafb, it has refresh rate adjustments and it works really well.

I'll try it.

ErV 09-01-2008 04:42 PM

Due to the hardware problems with monitor I was unable to configure uvesafb and can't try to solve "refresh rate in terminal" problem anymore, so I'll have to leave this unsolved. Thanks to the help.

keefaz 09-01-2008 05:18 PM

There is a note about uvesafb and nvidia cards in <kernel source dir>/Documentation/fb/uvesafb.txt
Quote:

Adjusting the refresh rate is only possible with a VBE 3.0 compliant
Video BIOS. Note that many nVidia Video BIOS-es claim to be VBE 3.0
compliant, while they simply ignore any refresh rate settings.
I don't know if it is relevant with your hardware problem though

ErV 09-01-2008 05:25 PM

Quote:

Originally Posted by keefaz (Post 3266521)
There is a note about uvesafb and nvidia cards in <kernel source dir>/Documentation/fb/uvesafb.txt

I don't know if it is relevant with your hardware problem though

Probably.
Unfortunately, my monitor now is half-broken and refuses to display terminal (and everything that is not 1024x768 85hz) at all when it warms up a bit, so solution for this (if exists) will have to wait until I'll either fix monitor or buy a new one (it won't be soon), because working blind-folded (or through ssh) isn't an option and I have more important things to do right now. Thanks for the info.


All times are GMT -5. The time now is 04:17 PM.