LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   qemu and Slackware64-current, Windows 98SE as a guest ( Partly solved! ) (http://www.linuxquestions.org/questions/slackware-14/qemu-and-slackware64-current-windows-98se-as-a-guest-partly-solved-875270/)

afreitascs 04-15-2011 11:08 PM

qemu and Slackware64-current, Windows 98SE as a guest ( Partly solved! )
 
Hi. okay with you all? :-)

I used qemu (qemu-0.9.1-i386-2_SBo) with Windows98SE as a guest, but since the last Slackware-current update of this version of qemu no longer works ...more precisely after "Mon Apr 8 06:58:48 UTC 2011" Update ...

Then installed the version "qemu-0.12.5.tar.gz" of Slackbuils, but this If the mouse is not detected in Windows 98 ...
I also installed the version of the Alien "qemu-0.10.0-i486-1alien" without success ...

Windows 98SE worked very well with the version of qemu-0.9.1-i386-2_SBo!

I know the mouse is not detectable in Windows 98SE is a Bug

https://bugs.launchpad.net/qemu/+bug/521994

Any comments would be welcome

Thanks

ps: I also have not had success in Slack 32. I use on a daily 64-bit version of Slackware .

Phorize 04-15-2011 11:55 PM

Quote:

Originally Posted by afreitascs (Post 4326042)
Hi. okay with you all? :-)

I used qemu (qemu-0.9.1-i386-2_SBo) with Windows98SE as a guest, but since the last Slackware-current update of this version of qemu no longer works ...more precisely after "Mon Apr 8 06:58:48 UTC 2011" Update ...

Then installed the version "qemu-0.12.5.tar.gz" of Slackbuils, but this If the mouse is not detected in Windows 98 ...
I also installed the version of the Alien "qemu-0.10.0-i486-1alien" without success ...

Windows 98SE worked very well with the version of qemu-0.9.1-i386-2_SBo!

I know the mouse is not detectable in Windows 98SE is a Bug

https://bugs.launchpad.net/qemu/+bug/521994

Any comments would be welcome


Thanks

ps: I also have not had success in Slack 32. I use on a daily 64-bit version of Slackware .

The only thing that occurs to me is why would anyone want to run windows 98 on anything?! Not very helpful I know but you did say any comment would be welcome!:)

Erik_FL 04-16-2011 12:57 AM

Quote:

Originally Posted by kristizz (Post 4326069)
The only thing that occurs to me is why would anyone want to run windows 98 on anything?! Not very helpful I know but you did say any comment would be welcome!:)

I run Windows 98 and 95 to play a lot of my older games. There are a lot of fun games like 3D pinball and 3D minigolf that run only on those operating systems. I've never tried QEMU on Linux to run them though. I usually use Microsoft Virtual PC 2007 on Windows. However, one can run them in VirtualBox without the Guest Additions (no screen resizing and no mouse integration).

My suggestion is to see how well VirtualBox meets your needs to run Windows 95 and 98 on Linux.

The best virtual support to run Windows 95 and 98 is with Microsoft Virtual PC on Windows XP, Vista, or Windows 7. You can use mouse integration and all the other features of Virtual PC. If you want to fully support Windows 95, use the Guest Additions from Virtual PC 2004 in the Guest OS while using Virtual PC 2007 SP1 in the Host OS.

ponce 04-16-2011 01:39 AM

FYI, reading comment 13 on the ubuntu bug linked, I just tried on -current with qemu-0.14.0 and mouse is working fine on my 98se.qcow2 :)

Alien Bob 04-16-2011 05:13 AM

Quote:

Originally Posted by ponce (Post 4326101)
FYI, reading comment 13 on the ubuntu bug linked, I just tried on -current with qemu-0.14.0 and mouse is working fine on my 98se.qcow2 :)

The OP's issue may be that he is not able to use later versions of qemu. After qemu-0.10 the support for the kqemu kernel accelerator was dropped. Which means, if you have an older CPU (without hardware virtualization support) you have to stick with an older version of qemu (so that you can use kqemu to get acceptable performance in the virtual machine).

Eric

afreitascs 04-16-2011 02:47 PM

Thank you guys for the answers :-)

In the tests that I got:

Quote:

qemu-0.9.1-i386-2_SBo no longer works
qemu-0.14.0 ---> works, but mouse is slow
qemu-0.13.0 ---> works, but mouse is slow
qemu-0.12.5 ----> mouse does not work
qemu-0.10.0-i486-1alien ----> not working
My main question is because the version "qemu-0.9.1-i386-2"
I wore, no longer works, after I updated (Tue Apr 8 06:58:48 UTC 2011)
Slackware 64-current?


Another question is: How do I know which libs, dependencies, are used by a program installed on Slackware? Is there a command for that?

I know I should know more than I know in Linux, but I use linux without academic pretension, so consider myself newbie.

Many thanks

zasavage 04-16-2011 03:38 PM

HI there afreitascs

I use VirtualBox 4 and have win98 SE installed with scitech display doctor for the display settings
I can resize and adjust the display .

Regards
Lawrence

afreitascs 04-16-2011 04:33 PM

Quote:

Originally Posted by Alien Bob (Post 4326179)
The OP's issue may be that he is not able to use later versions of qemu. After qemu-0.10 the support for the kqemu kernel accelerator was dropped. Which means, if you have an older CPU (without hardware virtualization support) you have to stick with an older version of qemu (so that you can use kqemu to get acceptable performance in the virtual machine).

Eric

Hello Alien Bob

I have the Athlon X2, which supports hardware
virtualization (AMD Athlon X2 5200),and I used qemu without kqemu .

at zasavage

Qemu is light, but VB is heavy, although I have also installed VB.
Out of curiosity, I'll test on Win98 VB. I did not know Vb gave support for Windows 98


many thanks :-)

Alien Bob 04-16-2011 04:44 PM

Quote:

Originally Posted by afreitascs (Post 4326610)
Hello Alien Bob

I have the Athlon X2, which supports hardware
virtualization (AMD Athlon X2 5200),and I used qemu without kqemu

In that case, you should be using qemu-kvm instead.

Eric

afreitascs 04-16-2011 06:41 PM

Quote:

Originally Posted by Alien Bob (Post 4326615)
In that case, you should be using qemu-kvm instead.

Eric

Thanks I'll test here ...

afreitascs 04-16-2011 11:05 PM

Hi

I installed qemu-kvm-0.14.0-x86_64-1alien.tgz

So I typed:

Quote:

$qemu -hda dados/win98 -m 128 -boot c -net none
then obtained:

Quote:

qemu: error while loading shared libraries: libvdeplug.so.3: cannot open shared object file: No such file or directory
I tried to create a new guest and got the same thing :

Quote:

$qemu-img create -f qcow dados/win98_ 2000M
qemu-img: error while loading shared libraries: libvdeplug.so.3: cannot open shared object file: No such file or directory
Any comments are welcome

many thanks

ponce 04-16-2011 11:29 PM

for Eric's qemu-kvm build, you need also the dependency vde.

afreitascs 04-17-2011 12:01 AM

Quote:

Originally Posted by ponce (Post 4326810)
for Eric's qemu-kvm build, you need also the dependency vde.

I installed "vde" worked, but I got this:

Quote:

$ qemu -hda dados/win98 -m 128 -boot c -net none
open /dev/kvm: No such file or directory
Could not initialize KVM, will disable KVM support

I have installed qemu-kvm
Quote:

$ ls | grep /var/log/packages/qemu-kvm-0.14.0-x86_64-1alien
many thanks

ps:Remember that when using qemu 0.14.0 (not qemu-kvm) everything works fine, but the mouse gets very slow.
Using qemu version 0.9.1 everything worked fine, the mouse was not slow. With the upgrade from Slackware current, qemu 0.9.1 stopped working ... :-(

ponce 04-17-2011 02:21 AM

Quote:

Originally Posted by afreitascs (Post 4326823)
Quote:

$ qemu -hda dados/win98 -m 128 -boot c -net none
open /dev/kvm: No such file or directory
Could not initialize KVM, will disable KVM support

that is because you have to load the kvm modules in your kernel (if not you use only full software emulation - much slower).
try a
Code:

modprobe kvm_amd
in console (as root) before launching qemu (should be kvm_intel, if you got a cpu with intel virtualization extensions).
Code:

echo "/sbin/modprobe kvm_amd" >> /etc/rc.d/rc.modules
to have it automatically loaded at boot

afreitascs 04-17-2011 01:32 PM

3 Attachment(s)
Quote:

Originally Posted by ponce (Post 4326871)
that is because you have to load the kvm modules in your kernel (if not you use only full software emulation - much slower).
try a
Code:

modprobe kvm_amd
in console (as root) before launching qemu (should be kvm_intel, if you got a cpu with intel virtualization extensions).
Code:

echo "/sbin/modprobe kvm_amd" >> /etc/rc.d/rc.modules
to have it automatically loaded at boot

Before thanks for this tip :-)

Well
Now windows starts ,then freezes on a black screen
(see image 1(4.png)). Note, (GKrellM) that the large CPU activity ...

Also, if I try to start a new installation, after creating
"QEMU disk image" successfully, crashes when trying to detect cdrom (boot given
by fd0 (Start computer wich CD-ROM support) (see image 3 and 4 attachment (7.jpg and 8.jpg) (high CPU activity))

many thanks


All times are GMT -5. The time now is 11:28 AM.