LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Problem with terminal emulators: schema (http://www.linuxquestions.org/questions/slackware-14/problem-with-terminal-emulators-schema-699814/)

JosephS 01-25-2009 01:46 PM

Problem with terminal emulators: schema
 
My problem is with the console.
The settings are:
schema > Linux colors
keyboard > linux console
encoding > default

I like to use white on black, but the white print is so light it's hard to
read with white on black. It used to be fine. I don't know what happened to
change this.

The problem is with the terminal emulators: shell or the linux console.

Thanks for help.

guanx 01-25-2009 09:05 PM

Seems it's been changed from the default. Change it back in the "Settings | Configure Konsole" dialog. The options are under the "Schema" tab.

JosephS 01-25-2009 11:33 PM

I did change it back to these:
schema > Linux colors
keyboard > linux console
encoding > default

That's what I had before. Now it doesn't work. There must be something else wrong.

guanx 01-26-2009 05:12 AM

Each of the colors can be set separately. If that's not the problem, please attach you screenshot.

JosephS 01-26-2009 06:30 PM

2 Attachment(s)
Here is a snapshot of the shell, white on black:
Attachment 31

Here is a snapshot of MC:
Attachment 32

guanx 01-26-2009 09:41 PM

Quote:

Originally Posted by JosephS (Post 3422213)
Here is a snapshot of the shell, white on black:
Attachment 31
Here is a snapshot of MC:
Attachment 32

The colors are fine. You may want a new pair of glasses :-P

Well, if not satisfied, please try some other fonts. "Console" may be a good choice. You could copy "/usr/share/apps/konsole/fonts/console8x16.pcf.gz" to "$HOME/.fonts/", run "fc-cache", restart Konsole and choose the font "Console".

Turning off anti-aliasing may also help. A simple way to turn off AA is from the "KDE control center", choose "Appearance and Themes" -> "Fonts".

You can also turn off AA for specific fonts in the fontconfig configuration file ("/etc/fonts/local.conf" or "$HOME/.fonts.conf").
Code:

    <match target="font" >
        <test compare="eq" name="family" >
            <string>Courier</string>
            <string>Courier 10 Pitch</string>
        </test>
        <edit mode="assign" name="antialias" >
            <bool>false</bool>
        </edit>
    </match>

Or you can set white characters to use the bold face in the Schema dialog of Konsole. (You have been there.)

JosephS 01-27-2009 07:17 PM

Quote:

The colors are fine. You may want a new pair of glasses :-P
I went to the library today to look at the snapshots. They look a lot better on the computer there than on my computer. I reinstalled the nvidia drivers. Thought that might help. It didn't.

Could this be a problem with hardware: graphics card, etc?
Things look OK on the Desktop and using Firefox, and in the terminal, but not the terminal emulators.

Thanks.

DavidHindman 01-27-2009 09:16 PM

Are you using an LCD display where the resolution of the video card isn't set to match the actual hardware resolution of the LCD display?

If that's the case, I'd imagine bit mapped fonts would look odd.

JosephS 01-27-2009 09:35 PM

Quote:

DavidHindman
Are you using an LCD display where the resolution of the video card isn't set to match the actual hardware resolution of the LCD display?
I'm using a CRT: Seanix Model: B19BL

Graphics Card:
VGA compatible controller: nVidia Corporation NV6 [Vanta/Vanta LT] (rev 15)

I have the Nvidia drivers installed from Slacbuilds.org:
nvidia-legacy71-driver
nvidia-legacy71-kernel

I haven't changed any of the settings for fonts.

Thanks.

guanx 01-28-2009 04:21 PM

Quote:

Originally Posted by JosephS (Post 3423551)
I'm using a CRT: Seanix Model: B19BL

Lower your monitor's brightness (intensity) a little and raise it's contrast as much as possible.

Can you see thin lines clearly? You can draw some lines with kolourpaint. If every line seems to be diffused, maybe your monitor is too old or the humidity is too high.

JosephS 01-28-2009 06:58 PM

Quote:

Lower your monitor's brightness (intensity) a little and raise it's contrast as much as possible.

Can you see thin lines clearly? You can draw some lines with kolourpaint. If every line seems to be diffused, maybe your monitor is too old or the humidity is too high.
I tried Kolourpaint. It workde OK.
I set the contrast to 100%. The brightness at 75%.
Didn't fix it. The monitor is a little dimmer than it should be I think, but no more than usual. It is older.

I use the terminals: Shell and Linux Console (I added the Terminal sessions to the panel). Would it help to reinstall this program? Which
package would contain the termnal emulators?

If that doesn't work then I will try replacing the video card or monitor.

Thanks.

guanx 01-28-2009 09:19 PM

1 Attachment(s)
Quote:

Originally Posted by JosephS (Post 3424615)
I tried Kolourpaint. It workde OK.
I set the contrast to 100%. The brightness at 75%.
Didn't fix it. The monitor is a little dimmer than it should be I think, but no more than usual. It is older.

I use the terminals: Shell and Linux Console (I added the Terminal sessions to the panel). Would it help to reinstall this program? Which
package would contain the termnal emulators?

If that doesn't work then I will try replacing the video card or monitor.

Thanks.

It's not a software problem since your screenshot is exactly the end result of software rendering. However, it's strange that kolourpaint works well. No idea at present.

Can you see my attachment clearly? No character is anti-aliased. If you see anything smooth, there's a hardware problem.

JosephS 01-29-2009 07:12 AM

The characters are not as sharp as they should be. I turned up the
contrast and brightness as high as they could go; that helps to a point, especially for the blue to stand out more.

I turned off anti-aliasing on my computer. This seems to help the white in vim to stand out more (although I had anti-aliasing on before and vim worked fine). With anti-aliasing the print looks better for Firefox and the start menu.

Thanks.


All times are GMT -5. The time now is 02:34 AM.