LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-25-2009, 01:46 PM   #1
JosephS
Member
 
Registered: Jun 2007
Distribution: Debian Squeeze, CrunchBang Waldorf
Posts: 493

Rep: Reputation: 37
Problem with terminal emulators: schema


My problem is with the console.
The settings are:
schema > Linux colors
keyboard > linux console
encoding > default

I like to use white on black, but the white print is so light it's hard to
read with white on black. It used to be fine. I don't know what happened to
change this.

The problem is with the terminal emulators: shell or the linux console.

Thanks for help.
 
Old 01-25-2009, 09:05 PM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Seems it's been changed from the default. Change it back in the "Settings | Configure Konsole" dialog. The options are under the "Schema" tab.

Last edited by guanx; 01-25-2009 at 09:07 PM.
 
Old 01-25-2009, 11:33 PM   #3
JosephS
Member
 
Registered: Jun 2007
Distribution: Debian Squeeze, CrunchBang Waldorf
Posts: 493

Original Poster
Rep: Reputation: 37
I did change it back to these:
schema > Linux colors
keyboard > linux console
encoding > default

That's what I had before. Now it doesn't work. There must be something else wrong.
 
Old 01-26-2009, 05:12 AM   #4
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Each of the colors can be set separately. If that's not the problem, please attach you screenshot.
 
Old 01-26-2009, 06:30 PM   #5
JosephS
Member
 
Registered: Jun 2007
Distribution: Debian Squeeze, CrunchBang Waldorf
Posts: 493

Original Poster
Rep: Reputation: 37
Here is a snapshot of the shell, white on black:
snapshot-shell.png

Here is a snapshot of MC:
snapshot-mc.png

Last edited by JosephS; 01-26-2009 at 06:33 PM.
 
Old 01-26-2009, 09:41 PM   #6
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by JosephS View Post
Here is a snapshot of the shell, white on black:
Attachment 31
Here is a snapshot of MC:
Attachment 32
The colors are fine. You may want a new pair of glasses :-P

Well, if not satisfied, please try some other fonts. "Console" may be a good choice. You could copy "/usr/share/apps/konsole/fonts/console8x16.pcf.gz" to "$HOME/.fonts/", run "fc-cache", restart Konsole and choose the font "Console".

Turning off anti-aliasing may also help. A simple way to turn off AA is from the "KDE control center", choose "Appearance and Themes" -> "Fonts".

You can also turn off AA for specific fonts in the fontconfig configuration file ("/etc/fonts/local.conf" or "$HOME/.fonts.conf").
Code:
    <match target="font" >
        <test compare="eq" name="family" >
            <string>Courier</string>
            <string>Courier 10 Pitch</string>
        </test>
        <edit mode="assign" name="antialias" >
            <bool>false</bool>
        </edit>
    </match>
Or you can set white characters to use the bold face in the Schema dialog of Konsole. (You have been there.)
 
Old 01-27-2009, 07:17 PM   #7
JosephS
Member
 
Registered: Jun 2007
Distribution: Debian Squeeze, CrunchBang Waldorf
Posts: 493

Original Poster
Rep: Reputation: 37
Quote:
The colors are fine. You may want a new pair of glasses :-P
I went to the library today to look at the snapshots. They look a lot better on the computer there than on my computer. I reinstalled the nvidia drivers. Thought that might help. It didn't.

Could this be a problem with hardware: graphics card, etc?
Things look OK on the Desktop and using Firefox, and in the terminal, but not the terminal emulators.

Thanks.
 
Old 01-27-2009, 09:16 PM   #8
DavidHindman
Member
 
Registered: Dec 2008
Distribution: Slack 13 + JWM
Posts: 101

Rep: Reputation: 23
Are you using an LCD display where the resolution of the video card isn't set to match the actual hardware resolution of the LCD display?

If that's the case, I'd imagine bit mapped fonts would look odd.
 
Old 01-27-2009, 09:35 PM   #9
JosephS
Member
 
Registered: Jun 2007
Distribution: Debian Squeeze, CrunchBang Waldorf
Posts: 493

Original Poster
Rep: Reputation: 37
Quote:
DavidHindman
Are you using an LCD display where the resolution of the video card isn't set to match the actual hardware resolution of the LCD display?
I'm using a CRT: Seanix Model: B19BL

Graphics Card:
VGA compatible controller: nVidia Corporation NV6 [Vanta/Vanta LT] (rev 15)

I have the Nvidia drivers installed from Slacbuilds.org:
nvidia-legacy71-driver
nvidia-legacy71-kernel

I haven't changed any of the settings for fonts.

Thanks.
 
Old 01-28-2009, 04:21 PM   #10
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by JosephS View Post
I'm using a CRT: Seanix Model: B19BL
Lower your monitor's brightness (intensity) a little and raise it's contrast as much as possible.

Can you see thin lines clearly? You can draw some lines with kolourpaint. If every line seems to be diffused, maybe your monitor is too old or the humidity is too high.

Last edited by guanx; 01-28-2009 at 04:25 PM.
 
Old 01-28-2009, 06:58 PM   #11
JosephS
Member
 
Registered: Jun 2007
Distribution: Debian Squeeze, CrunchBang Waldorf
Posts: 493

Original Poster
Rep: Reputation: 37
Quote:
Lower your monitor's brightness (intensity) a little and raise it's contrast as much as possible.

Can you see thin lines clearly? You can draw some lines with kolourpaint. If every line seems to be diffused, maybe your monitor is too old or the humidity is too high.
I tried Kolourpaint. It workde OK.
I set the contrast to 100%. The brightness at 75%.
Didn't fix it. The monitor is a little dimmer than it should be I think, but no more than usual. It is older.

I use the terminals: Shell and Linux Console (I added the Terminal sessions to the panel). Would it help to reinstall this program? Which
package would contain the termnal emulators?

If that doesn't work then I will try replacing the video card or monitor.

Thanks.
 
Old 01-28-2009, 09:19 PM   #12
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by JosephS View Post
I tried Kolourpaint. It workde OK.
I set the contrast to 100%. The brightness at 75%.
Didn't fix it. The monitor is a little dimmer than it should be I think, but no more than usual. It is older.

I use the terminals: Shell and Linux Console (I added the Terminal sessions to the panel). Would it help to reinstall this program? Which
package would contain the termnal emulators?

If that doesn't work then I will try replacing the video card or monitor.

Thanks.
It's not a software problem since your screenshot is exactly the end result of software rendering. However, it's strange that kolourpaint works well. No idea at present.

Can you see my attachment clearly? No character is anti-aliased. If you see anything smooth, there's a hardware problem.
Attached Images
File Type: png noaa.png (12.9 KB, 11 views)

Last edited by guanx; 01-28-2009 at 09:21 PM.
 
Old 01-29-2009, 07:12 AM   #13
JosephS
Member
 
Registered: Jun 2007
Distribution: Debian Squeeze, CrunchBang Waldorf
Posts: 493

Original Poster
Rep: Reputation: 37
The characters are not as sharp as they should be. I turned up the
contrast and brightness as high as they could go; that helps to a point, especially for the blue to stand out more.

I turned off anti-aliasing on my computer. This seems to help the white in vim to stand out more (although I had anti-aliasing on before and vim worked fine). With anti-aliasing the print looks better for Firefox and the start menu.

Thanks.

Last edited by JosephS; 01-29-2009 at 07:15 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Delete key not working in terminal emulators statguy Slackware 5 12-31-2008 01:51 PM
LXer: 13 Terminal Emulators for Linux LXer Syndicated Linux News 0 09-22-2008 10:00 AM
LXer: Terminal Emulators Review LXer Syndicated Linux News 0 09-16-2007 10:50 PM
Terminal emulators don't work in X pherthyl Linux - Software 1 03-12-2004 12:58 AM
Terminal Emulators Question ximiansavior Linux - Software 4 11-17-2003 06:07 AM


All times are GMT -5. The time now is 01:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration