LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Problem with sound in Slackware 10 (http://www.linuxquestions.org/questions/slackware-14/problem-with-sound-in-slackware-10-a-260472/)

infornography 11-29-2004 07:16 AM

Problem with sound in Slackware 10
 
Yesterday I installed Slackware 10, it worked perfectly. I was so impressed that today I removed my windows partition, and reinstalled Slack as the only OS in the computer. This time though, there was a problem.

When it booted, I got the following error message just before the login prompt:

ALSA warning: No mixer settings found in /etc/asound.state. Sound may be muted. Use 'alsa mixer' to unmute your sound card, and then 'alsactl store' to save the default ALSA mixer settings to be loaded at boot.

I ignored it and started KDE to see what would happen. Sound wasn't muted, but it was very quiet. I had to turn my speakers right up to hear. So then I did as it said, ran 'alsa mixer' as root, and set the Master, PCM, Synth, Line, CD, PC Speaker, and Aux volumes to max.

I started KDE again, and sure enough, the music at the splash screen was very loud. I thought it was fixed. But now every program I run in KDE has even quieter sound than before, almost silent. It's only the splash screen that has any real volume.

What the hell is wrong with this thing?

I would really appreciate any help.

EDIT: In case it matters, I have also made sure that kmixer, and the volume control on several apps is set as high as it will go, but it has no effect.

egag 11-29-2004 07:27 AM

i think it's still your alsmixer settings.
first set it with " alsamixer " and use " alsactl store " after that to store the values.
btw. i always put everything at ca. 80% of max volume.

then, with kmix you should be able to control all.

egag

ringwraith 11-29-2004 05:41 PM

You might want to disable arts. You will lose your kde startup sound, but I have found my music works better then. Or try another desktop environment such as gnome. It seems like arts and alsa have some problems at times.

infornography 11-30-2004 04:06 AM

Well I have managed to get a little further. If I run alsaconf, as root obviously, I get sound working perfectly, even as a normal user. But then after I reboot, I have to do it all again. How can I make it remember?

Hiper 11-30-2004 05:44 AM

set volume in alsamixer, do alsactl store
then add in /etc/rc.d/rc.local:
alsactl restore

also in the sound options in the kde control panel, there are volume load options, disable them or disable all arts stuff


All times are GMT -5. The time now is 07:56 PM.