LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-29-2004, 08:16 AM   #1
infornography
Member
 
Registered: Oct 2003
Location: Australia
Distribution: Xubuntu 6.10
Posts: 73

Rep: Reputation: 15
Problem with sound in Slackware 10


Yesterday I installed Slackware 10, it worked perfectly. I was so impressed that today I removed my windows partition, and reinstalled Slack as the only OS in the computer. This time though, there was a problem.

When it booted, I got the following error message just before the login prompt:

ALSA warning: No mixer settings found in /etc/asound.state. Sound may be muted. Use 'alsa mixer' to unmute your sound card, and then 'alsactl store' to save the default ALSA mixer settings to be loaded at boot.

I ignored it and started KDE to see what would happen. Sound wasn't muted, but it was very quiet. I had to turn my speakers right up to hear. So then I did as it said, ran 'alsa mixer' as root, and set the Master, PCM, Synth, Line, CD, PC Speaker, and Aux volumes to max.

I started KDE again, and sure enough, the music at the splash screen was very loud. I thought it was fixed. But now every program I run in KDE has even quieter sound than before, almost silent. It's only the splash screen that has any real volume.

What the hell is wrong with this thing?

I would really appreciate any help.

EDIT: In case it matters, I have also made sure that kmixer, and the volume control on several apps is set as high as it will go, but it has no effect.

Last edited by infornography; 11-29-2004 at 08:17 AM.
 
Old 11-29-2004, 08:27 AM   #2
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
i think it's still your alsmixer settings.
first set it with " alsamixer " and use " alsactl store " after that to store the values.
btw. i always put everything at ca. 80% of max volume.

then, with kmix you should be able to control all.

egag
 
Old 11-29-2004, 06:41 PM   #3
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
You might want to disable arts. You will lose your kde startup sound, but I have found my music works better then. Or try another desktop environment such as gnome. It seems like arts and alsa have some problems at times.
 
Old 11-30-2004, 05:06 AM   #4
infornography
Member
 
Registered: Oct 2003
Location: Australia
Distribution: Xubuntu 6.10
Posts: 73

Original Poster
Rep: Reputation: 15
Well I have managed to get a little further. If I run alsaconf, as root obviously, I get sound working perfectly, even as a normal user. But then after I reboot, I have to do it all again. How can I make it remember?
 
Old 11-30-2004, 06:44 AM   #5
Hiper
Member
 
Registered: Aug 2003
Location: Portugal
Distribution: Slackware 10.0
Posts: 100

Rep: Reputation: 15
set volume in alsamixer, do alsactl store
then add in /etc/rc.d/rc.local:
alsactl restore

also in the sound options in the kde control panel, there are volume load options, disable them or disable all arts stuff
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound problem in Slackware 10.1 The Professor Slackware 3 08-23-2005 12:12 PM
Slackware sound problem, HELP! fiddle Slackware 4 08-08-2005 04:06 PM
Slackware 10 sound problem Kellen Linux - Newbie 5 12-04-2004 07:59 PM
Slackware 10 Sound Problem Jeffmrg Slackware 12 08-09-2004 07:07 AM
Sound problem Slackware 10 arubin Slackware 3 07-01-2004 09:54 AM


All times are GMT -5. The time now is 09:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration