LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Nvidia driver in slackware 13.37? (http://www.linuxquestions.org/questions/slackware-14/nvidia-driver-in-slackware-13-37-a-905303/)

michaelinux 09-27-2011 06:55 PM

Nvidia driver in slackware 13.37?
 
I have installed nvidia driver in slackware 13.37 and it works fine.. well at least i know it installed correctly, the thing is that when i try to load kde in normal mode it freezes when is about to load the K, i only get a blurry blue K and then it stops loading. i can only load it on failsafe mode.
does anybody know what can i do?

bonixavier 09-27-2011 06:58 PM

Did you install extra/xf86-video-nouveau-blacklist?

camorri 09-27-2011 07:01 PM

Did you do a full install? Are you running the huge kernel, or have you switched kernels to the generic kernel?

Have you tried any other desktop? Give xfce a try, and see if you get a desktop.

michaelinux 09-27-2011 07:20 PM

Quote:

Originally Posted by camorri (Post 4483868)
Did you do a full install? Are you running the huge kernel, or have you switched kernels to the generic kernel?

Have you tried any other desktop? Give xfce a try, and see if you get a desktop.

yes i did a full install and i'm using the default kernel.
i can use xfce and the others WMs is just kde that give me this problem :(

---------- Post added 09-27-11 at 07:20 PM ----------

Quote:

Originally Posted by bonixavier (Post 4483865)
Did you install extra/xf86-video-nouveau-blacklist?

i just did, it didn't help. :(

Cultist 09-27-2011 07:21 PM

Quote:

Originally Posted by michaelinux (Post 4483890)
i just did, it didn't help. :(

make sure you reboot after adding the blacklist. It has to be loaded with startup

michaelinux 09-27-2011 07:25 PM

Quote:

Originally Posted by Cultist (Post 4483893)
make sure you reboot after adding the blacklist. It has to be loaded with startup

i guess i'm unlucky, i rebooted and it's still the same..
I've had this problem before in slackware 13.1 but i thought it was a bug on that release, i guess there's got to be something else...

allend 09-27-2011 07:31 PM

From CHANGES_AND_HINTS.TXT
Quote:

Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection

camorri 09-27-2011 07:33 PM

Are you sure the Nvidia driver is running? Have a look at /etc/X11/xorg.conf and verify in the Section "device" the Driver is "nvidia". Here is what it looks like on my system...

Quote:

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection
If you are still running the Huge kernel, you need to switch. That kernel is intended for installation only.
Here is a link to a nice easy to read How To.

-->http://genek.net/LinuxAdventures/sysadmin/index.html See the section on Basic Setup, it describes how to switch kernels. Not hard at all.

michaelinux 09-27-2011 08:15 PM

Quote:

Originally Posted by camorri (Post 4483905)
Are you sure the Nvidia driver is running? Have a look at /etc/X11/xorg.conf and verify in the Section "device" the Driver is "nvidia". Here is what it looks like on my system...



If you are still running the Huge kernel, you need to switch. That kernel is intended for installation only.
Here is a link to a nice easy to read How To.

-->http://genek.net/LinuxAdventures/sysadmin/index.html See the section on Basic Setup, it describes how to switch kernels. Not hard at all.

i switched the kernel, anyway the problem has turn worse, now if i maximize kde panel it turns black (using default air theme), and i'm still using the failsafe mode which disable all desktop effects.

allend 09-27-2011 08:52 PM

Please provide some details of your system by posting the output of:
'/sbin/lspci' - to provide the graphics card details
'uname -a' - to show the kernel details
as well as the name of the nVidia driver package that you installed.

michaelinux 09-28-2011 11:45 AM

Quote:

Originally Posted by allend (Post 4483944)
Please provide some details of your system by posting the output of:
'/sbin/lspci' - to provide the graphics card details
'uname -a' - to show the kernel details
as well as the name of the nVidia driver package that you installed.

Result from /sbin/lspci :

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
01:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7300 SE/7200 GS] (rev a1)


uname -a :

Linux SLACKER 2.6.37.6-smp #1 SMP Sat Apr 9 14:01:14 CDT 2011 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz GenuineIntel GNU/Linux


and the name of the nvidia driver i installed is : NVIDIA-Linux-x86-275.28

zasavage 09-28-2011 12:43 PM

I have once had a similar problem with a machine that first had a on-board display card replaced by a proper display card ..

The only I could fix it was to delete the /home/%USER%/.kde directory in the home directory ..

Hope it helps

Lawrence

allend 09-28-2011 12:44 PM

Hmm, weird. All that looks just fine and dandy.
I have an almost identical device running with the same kernel and have no problems. I must admit that I have not bothered to update the nVidia driver since version 260.19.44

If the nVidia installer has worked correctly, then the nouveau driver should have been blacklisted.

Did you allow the installer to update your /etc/X11/xorg.conf?
You should only need a section like this:
Code:

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 7300 LE"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

and perhaps this
Code:

Section "Extensions"
    Option        "Composite" "Enable"
EndSection


michaelinux 09-28-2011 01:35 PM

Quote:

Originally Posted by allend (Post 4484588)
Hmm, weird. All that looks just fine and dandy.
I have an almost identical device running with the same kernel and have no problems. I must admit that I have not bothered to update the nVidia driver since version 260.19.44

If the nVidia installer has worked correctly, then the nouveau driver should have been blacklisted.

Did you allow the installer to update your /etc/X11/xorg.conf?
You should only need a section like this:
Code:

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 7300 LE"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

and perhaps this
Code:

Section "Extensions"
    Option        "Composite" "Enable"
EndSection


yeah, well for some reason it just doesn't work, :( i've tried everything and loading kde still freezes at the final blue K, i might try that old 260.19.44 version you said, maybe that would work.

michaelinux 09-28-2011 01:56 PM

Quote:

Originally Posted by michaelinux (Post 4484617)
yeah, well for some reason it just doesn't work, :( i've tried everything and loading kde still freezes at the final blue K, i might try that old 260.19.44 version you said, maybe that would work.

Guess what.... yeah it actually worked, for some stupid weird reason the old drivers work.
thank you guys for all your help i guess this is solved!!


All times are GMT -5. The time now is 11:33 PM.