LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-27-2011, 05:55 PM   #1
michaelinux
Member
 
Registered: Apr 2009
Location: El Salvador
Distribution: Slackware -current
Posts: 166

Rep: Reputation: 17
Nvidia driver in slackware 13.37?


I have installed nvidia driver in slackware 13.37 and it works fine.. well at least i know it installed correctly, the thing is that when i try to load kde in normal mode it freezes when is about to load the K, i only get a blurry blue K and then it stops loading. i can only load it on failsafe mode.
does anybody know what can i do?

Last edited by michaelinux; 09-28-2011 at 12:56 PM.
 
Old 09-27-2011, 05:58 PM   #2
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Rep: Reputation: 60
Did you install extra/xf86-video-nouveau-blacklist?
 
Old 09-27-2011, 06:01 PM   #3
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,839

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Did you do a full install? Are you running the huge kernel, or have you switched kernels to the generic kernel?

Have you tried any other desktop? Give xfce a try, and see if you get a desktop.
 
Old 09-27-2011, 06:20 PM   #4
michaelinux
Member
 
Registered: Apr 2009
Location: El Salvador
Distribution: Slackware -current
Posts: 166

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by camorri View Post
Did you do a full install? Are you running the huge kernel, or have you switched kernels to the generic kernel?

Have you tried any other desktop? Give xfce a try, and see if you get a desktop.
yes i did a full install and i'm using the default kernel.
i can use xfce and the others WMs is just kde that give me this problem

---------- Post added 09-27-11 at 07:20 PM ----------

Quote:
Originally Posted by bonixavier View Post
Did you install extra/xf86-video-nouveau-blacklist?
i just did, it didn't help.
 
Old 09-27-2011, 06:21 PM   #5
Cultist
Member
 
Registered: Feb 2010
Location: Chicago, IL
Distribution: Slackware64 14.1
Posts: 777

Rep: Reputation: 101Reputation: 101
Quote:
Originally Posted by michaelinux View Post
i just did, it didn't help.
make sure you reboot after adding the blacklist. It has to be loaded with startup
 
Old 09-27-2011, 06:25 PM   #6
michaelinux
Member
 
Registered: Apr 2009
Location: El Salvador
Distribution: Slackware -current
Posts: 166

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by Cultist View Post
make sure you reboot after adding the blacklist. It has to be loaded with startup
i guess i'm unlucky, i rebooted and it's still the same..
I've had this problem before in slackware 13.1 but i thought it was a bug on that release, i guess there's got to be something else...
 
Old 09-27-2011, 06:31 PM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,394

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
From CHANGES_AND_HINTS.TXT
Quote:
Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection
 
Old 09-27-2011, 06:33 PM   #8
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,839

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Are you sure the Nvidia driver is running? Have a look at /etc/X11/xorg.conf and verify in the Section "device" the Driver is "nvidia". Here is what it looks like on my system...

Quote:
Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection
If you are still running the Huge kernel, you need to switch. That kernel is intended for installation only.
Here is a link to a nice easy to read How To.

-->http://genek.net/LinuxAdventures/sysadmin/index.html See the section on Basic Setup, it describes how to switch kernels. Not hard at all.
 
Old 09-27-2011, 07:15 PM   #9
michaelinux
Member
 
Registered: Apr 2009
Location: El Salvador
Distribution: Slackware -current
Posts: 166

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by camorri View Post
Are you sure the Nvidia driver is running? Have a look at /etc/X11/xorg.conf and verify in the Section "device" the Driver is "nvidia". Here is what it looks like on my system...



If you are still running the Huge kernel, you need to switch. That kernel is intended for installation only.
Here is a link to a nice easy to read How To.

-->http://genek.net/LinuxAdventures/sysadmin/index.html See the section on Basic Setup, it describes how to switch kernels. Not hard at all.
i switched the kernel, anyway the problem has turn worse, now if i maximize kde panel it turns black (using default air theme), and i'm still using the failsafe mode which disable all desktop effects.
 
Old 09-27-2011, 07:52 PM   #10
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,394

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Please provide some details of your system by posting the output of:
'/sbin/lspci' - to provide the graphics card details
'uname -a' - to show the kernel details
as well as the name of the nVidia driver package that you installed.
 
Old 09-28-2011, 10:45 AM   #11
michaelinux
Member
 
Registered: Apr 2009
Location: El Salvador
Distribution: Slackware -current
Posts: 166

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by allend View Post
Please provide some details of your system by posting the output of:
'/sbin/lspci' - to provide the graphics card details
'uname -a' - to show the kernel details
as well as the name of the nVidia driver package that you installed.
Result from /sbin/lspci :

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
01:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7300 SE/7200 GS] (rev a1)


uname -a :

Linux SLACKER 2.6.37.6-smp #1 SMP Sat Apr 9 14:01:14 CDT 2011 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz GenuineIntel GNU/Linux


and the name of the nvidia driver i installed is : NVIDIA-Linux-x86-275.28
 
Old 09-28-2011, 11:43 AM   #12
zasavage
Member
 
Registered: Sep 2010
Location: Bloemfontein , South Africa
Distribution: Slackware 13.37 and Slackware 14
Posts: 193

Rep: Reputation: 6
I have once had a similar problem with a machine that first had a on-board display card replaced by a proper display card ..

The only I could fix it was to delete the /home/%USER%/.kde directory in the home directory ..

Hope it helps

Lawrence
 
Old 09-28-2011, 11:44 AM   #13
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,394

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Hmm, weird. All that looks just fine and dandy.
I have an almost identical device running with the same kernel and have no problems. I must admit that I have not bothered to update the nVidia driver since version 260.19.44

If the nVidia installer has worked correctly, then the nouveau driver should have been blacklisted.

Did you allow the installer to update your /etc/X11/xorg.conf?
You should only need a section like this:
Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7300 LE"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection
and perhaps this
Code:
Section "Extensions"
    Option         "Composite" "Enable"
EndSection
 
Old 09-28-2011, 12:35 PM   #14
michaelinux
Member
 
Registered: Apr 2009
Location: El Salvador
Distribution: Slackware -current
Posts: 166

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by allend View Post
Hmm, weird. All that looks just fine and dandy.
I have an almost identical device running with the same kernel and have no problems. I must admit that I have not bothered to update the nVidia driver since version 260.19.44

If the nVidia installer has worked correctly, then the nouveau driver should have been blacklisted.

Did you allow the installer to update your /etc/X11/xorg.conf?
You should only need a section like this:
Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7300 LE"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection
and perhaps this
Code:
Section "Extensions"
    Option         "Composite" "Enable"
EndSection
yeah, well for some reason it just doesn't work, i've tried everything and loading kde still freezes at the final blue K, i might try that old 260.19.44 version you said, maybe that would work.
 
Old 09-28-2011, 12:56 PM   #15
michaelinux
Member
 
Registered: Apr 2009
Location: El Salvador
Distribution: Slackware -current
Posts: 166

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by michaelinux View Post
yeah, well for some reason it just doesn't work, i've tried everything and loading kde still freezes at the final blue K, i might try that old 260.19.44 version you said, maybe that would work.
Guess what.... yeah it actually worked, for some stupid weird reason the old drivers work.
thank you guys for all your help i guess this is solved!!
 
  


Reply

Tags
kde, nvidia drivers, slackware 13.37


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware 13.37.0 NVIDIA driver kea_kea Slackware 6 07-31-2011 11:58 AM
cant install nvidia driver in slackware 12.1 b3rx Slackware 5 05-27-2008 08:22 AM
NVIDIA driver on Slackware 10.1 nesor Linux - Hardware 6 09-24-2005 08:54 PM
NVidia driver on slackware 10.1, nvidia.o not found azazel11998 Linux - General 3 09-02-2005 11:19 AM
nvidia driver in slackware 8.1 bynaar Slackware 2 07-16-2002 05:55 AM


All times are GMT -5. The time now is 05:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration