LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   No value for $TERM variable (http://www.linuxquestions.org/questions/slackware-14/no-value-for-%24term-variable-808168/)

Moiseshb 05-16-2010 12:49 PM

No value for $TERM variable
 
Hi everybody :D
I'm using Slackware64-current and everything is fine except by the $TERM variable. When I try to run sbopkg, for example, i get this error message:
Code:

root pedro # sbopkg
tput: No value for $TERM and no -T specified
TERM environment variable not set.
tput: No value for $TERM and no -T specified

I made a quick fix putting "export TERM=xterm" on .bashrc but this is bothering me because all terminal windows had "Untitled window" as name.
Here is a screenshot: http://h.imagehost.org/0998/xfce.png
Thanks

PS:Sorry for my bad english,i'm brazilian,i hope you have understood

GazL 05-16-2010 02:34 PM

If you look in edit/preferences then click on the advanced tab you'll see there's a field to set $TERM.

I use the good old fashioned xterm rather than terminal myself and that seems to look after itself.

Moiseshb 05-16-2010 06:22 PM

Oh i'm feeling so dumb now
Thanks
EDIT:Problem partially solved :D I'm still getting "Ultitled window" but I don't care
SOLVED

ivandi 05-16-2010 09:39 PM

It looks like a bug in XFCE Terminal. Every time I open the Preferences these variables (TitleInitial and Term) are reset. So I have to manually edit ~/.config/Terminal/terminalrc to set them. I am not sure but I think it happened after the update from May 6.

the3dfxdude 05-16-2010 11:20 PM

If xfce is built against gtk+ 2.18, this bug surfaces. A patch is already in the Terminal git tree, and I notified Pat. I suppose that on May 6 the bug surfaced when xfce was recompiled. But this patch needs to be applied and Terminal recompiled. Too bad I took so long at getting around to this. I knew about this problem for a few weeks when I built xfce 4.6.1 on another distro.

Moiseshb 05-17-2010 03:27 PM

Yes it's a bug
It was solved but now is back
I'm still using "export TERM=xterm" on .bashrc

the3dfxdude 05-17-2010 09:11 PM

Moiseshb, download xfce-4.6.1-i486-8, upgradepkg, and restart xfce. You can test the fix by opening and closing the preference dialog.


All times are GMT -5. The time now is 06:34 AM.